aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJuha-Matti Tilli <juha-matti.tilli@nokia.com>2016-02-29 11:28:52 +0200
committerMaxim Uvarov <maxim.uvarov@linaro.org>2016-03-02 11:13:41 +0300
commite7763e9eb89747896386da27647599b7ee878389 (patch)
tree4a39a61e08f40eca37983e23eacd26065c921b37 /configure.ac
parent23d778bb359c64532002440f59b4e4be2eea7188 (diff)
example: l2fwd_simple: add single-threaded l2fwd example
The ODP distribution is lacking a simple example how to receive and send packets. The l2fwd is overly complicated because it supports an arbitrary number of interfaces, bi-directional operation and an arbitrary number of threads. To remedy this situation, add l2fwd_simple which is a single-threaded unidirectional variant of l2fwd for exactly two interfaces. l2fwd_simple can be used as an example application when learning how to use ODP. The focus when developing l2fwd_simple was to reduce the code line count to as small value as possible, and it turned out it requires 165 lines of code. For unidirectional traffic in single-threaded use cases, l2fwd_simple performs actually better than l2fwd with single thread, because l2fwd_simple does not need to poll two interfaces in a single thread. Signed-off-by: Juha-Matti Tilli <juha-matti.tilli@nokia.com> Reviewed-by: Petri Savolainen <petri.savolainen@nokia.com> Signed-off-by: Maxim Uvarov <maxim.uvarov@linaro.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 5fb0bd4f5..d88532a4c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -333,6 +333,7 @@ AC_CONFIG_FILES([Makefile
example/time/Makefile
example/timer/Makefile
example/traffic_mgmt/Makefile
+ example/l2fwd_simple/Makefile
helper/Makefile
helper/test/Makefile
pkgconfig/libodp.pc