aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAnders Roxell <anders.roxell@linaro.org>2016-03-29 20:23:27 +0200
committerMaxim Uvarov <maxim.uvarov@linaro.org>2016-03-30 16:19:05 +0300
commitd657f6b62d24d15776a433b449f5d1f0069413a8 (patch)
tree5e6dc4a8314a5e6519f8141b1f744ec6a32ac0db /configure.ac
parentd0480b8d607063ca8f5fcbb9c56a2e58a861f338 (diff)
configure: group AM_CONDITIONAL
Signed-off-by: Anders Roxell <anders.roxell@linaro.org> Tested-and-reviewed-by: Mike Holmes <mike.holmes@linaro.org> Signed-off-by: Maxim Uvarov <maxim.uvarov@linaro.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 10 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index 5c4332a44..75d846e99 100644
--- a/configure.ac
+++ b/configure.ac
@@ -93,13 +93,8 @@ else
fi
##########################################################################
-# Set conditionals as computed within platform specific files
+# Set SDK install path
##########################################################################
-AM_CONDITIONAL([netmap_support], [test x$netmap_support = xyes ])
-AM_CONDITIONAL([PKTIO_DPDK], [test x$pktio_dpdk_support = xyes ])
-AM_CONDITIONAL([HAVE_PCAP], [test $have_pcap = yes])
-
-
AC_ARG_WITH([sdk-install-path],
AC_HELP_STRING([--with-sdk-install-path=DIR path to external libs and headers],
[(or in the default path if not specified).]),
@@ -107,8 +102,6 @@ AC_HELP_STRING([--with-sdk-install-path=DIR path to external libs and headers],
AC_SUBST(SDK_INSTALL_PATH)
-AM_CONDITIONAL([SDK_INSTALL_PATH_], [test "x${SDK_INSTALL_PATH_}" = "x1"])
-
##########################################################################
# Set the install directory for test binaries/scripts
##########################################################################
@@ -120,7 +113,6 @@ AC_ARG_WITH([testdir],
testdir=$withval
fi], [])
AC_SUBST([testdir])
-AM_CONDITIONAL([test_installdir], [test "$testdir" != ""])
##########################################################################
# Enable/disable Unit tests
@@ -134,6 +126,15 @@ AC_ARG_ENABLE([cunit_support],
##########################################################################
+# Set conditionals as computed within platform specific files
+##########################################################################
+AM_CONDITIONAL([netmap_support], [test x$netmap_support = xyes ])
+AM_CONDITIONAL([PKTIO_DPDK], [test x$pktio_dpdk_support = xyes ])
+AM_CONDITIONAL([HAVE_PCAP], [test $have_pcap = yes])
+AM_CONDITIONAL([SDK_INSTALL_PATH_], [test "x${SDK_INSTALL_PATH_}" = "x1"])
+AM_CONDITIONAL([test_installdir], [test "$testdir" != ""])
+
+##########################################################################
# Setup doxygen documentation
##########################################################################
DX_HTML_FEATURE(ON)