aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMike Holmes <mike.holmes@linaro.org>2016-04-15 12:45:28 -0400
committerMaxim Uvarov <maxim.uvarov@linaro.org>2016-04-19 10:23:22 +0300
commitd2ff457a07cd808131e748e493795900394e9244 (patch)
treefdfc0d94557ab836cc3e496d648849f5b16bd2e8 /configure.ac
parent1f58a8fd51ab0304c0ae767e225abfec8448ac0b (diff)
configure: default ODP_DEPUG_PRINT to false
As we approach a production stable release and we package for distribution inclusion, the default debug should be for the majority of users to build a performance image rather than a debug one. Signed-off-by: Mike Holmes <mike.holmes@linaro.org> Reviewed-by: Bill Fischofer <bill.fischofer@linaro.org> Reviewed-by: Ricardo Salveti <ricardo.salveti@linaro.org> Signed-off-by: Maxim Uvarov <maxim.uvarov@linaro.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 9665d1d5f..a10e0f626 100644
--- a/configure.ac
+++ b/configure.ac
@@ -156,10 +156,12 @@ DX_INIT_DOXYGEN($PACKAGE_NAME, ${srcdir}/doc/application-api-guide/doxygen.cfg,
##########################################################################
# Enable/disable ODP_DEBUG_PRINT
##########################################################################
-ODP_DEBUG_PRINT=1
+ODP_DEBUG_PRINT=0
AC_ARG_ENABLE([debug-print],
[ --enable-debug-print display debugging information],
- [if ! test "x$enableval" = "xyes"; then
+ [if test "x$enableval" = "xyes"; then
+ ODP_DEBUG_PRINT=1
+ else
ODP_DEBUG_PRINT=0
fi])
ODP_CFLAGS="$ODP_CFLAGS -DODP_DEBUG_PRINT=$ODP_DEBUG_PRINT"