aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMaxim Uvarov <maxim.uvarov@linaro.org>2016-04-07 17:12:48 +0300
committerMaxim Uvarov <maxim.uvarov@linaro.org>2016-04-07 18:07:06 +0300
commit6c83e1e1310b3b7b72f53cfccf1b8a5a952f1a93 (patch)
tree50a2489a825f7c1f0ef278995c237cb9d448f34d /configure.ac
parent8b87bcf374aafe2d22bbb8f2ce7ffd9ed2ae10e3 (diff)
validation: configure: move cflags guards to test/m4
Move cflags guards to test/m4 to fix cunit library search. This fixes build failure with --with-cunit-path= option. https://bugs.linaro.org/show_bug.cgi?id=2161 Reported-by: Brian Brooks <brian.brooks@linaro.org> Suggested-by: Anders Roxell <anders.roxell@linaro.org> Reviewed-by: Anders Roxell <anders.roxell@linaro.org> Signed-off-by: Maxim Uvarov <maxim.uvarov@linaro.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 0 insertions, 14 deletions
diff --git a/configure.ac b/configure.ac
index 712d2414c..9665d1d5f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -176,20 +176,6 @@ AC_ARG_ENABLE([debug],
ODP_CFLAGS="$ODP_CFLAGS -DODP_DEBUG=$ODP_DEBUG"
##########################################################################
-# Save and set temporary compilation flags
-##########################################################################
-OLD_LDFLAGS=$LDFLAGS
-OLD_CPPFLAGS=$CPPFLAGS
-LDFLAGS="$AM_LDFLAGS $LDFLAGS"
-CPPFLAGS="$AM_CPPFLAGS $CPPFLAGS"
-
-##########################################################################
-# Restore old saved variables
-##########################################################################
-LDFLAGS=$OLD_LDFLAGS
-CPPFLAGS=$OLD_CPPFLAGS
-
-##########################################################################
# Default warning setup
##########################################################################
ODP_CFLAGS="$ODP_CFLAGS -W -Wall -Werror -Wstrict-prototypes -Wmissing-prototypes"