aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMike Holmes <mike.holmes@linaro.org>2016-04-15 11:55:32 -0400
committerMaxim Uvarov <maxim.uvarov@linaro.org>2016-04-20 23:00:59 +0300
commit69d0a401c92807852b503418612812242ba9f8f2 (patch)
tree41e57edf67a1eb8419b03ec35dde93c09bebb0d9 /configure.ac
parentb2bf50d86e5bb8beff3d51665566e2dc844a4bf8 (diff)
configure: default ODP_DEBUG to false
As we approach a production stable release and we package for distribution inclusion, the default debug should be for the majority of users to build a performance image rather than a debug one. Suggested-by: Anders Roxell <anders.roxell@linaro.org> Signed-off-by: Mike Holmes <mike.holmes@linaro.org> Reviewed-by: Ricardo Salveti <ricardo.salveti@linaro.org> Signed-off-by: Maxim Uvarov <maxim.uvarov@linaro.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index a10e0f626..3cf6d5664 100644
--- a/configure.ac
+++ b/configure.ac
@@ -169,10 +169,12 @@ ODP_CFLAGS="$ODP_CFLAGS -DODP_DEBUG_PRINT=$ODP_DEBUG_PRINT"
##########################################################################
# Enable/disable ODP_DEBUG
##########################################################################
-ODP_DEBUG=1
+ODP_DEBUG=0
AC_ARG_ENABLE([debug],
[ --enable-debug include additional code],
- [if ! test "x$enableval" = "xyes"; then
+ [if test "x$enableval" = "xyes"; then
+ ODP_DEBUG=1
+ else
ODP_DEBUG=0
fi])
ODP_CFLAGS="$ODP_CFLAGS -DODP_DEBUG=$ODP_DEBUG"