aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMaxim Uvarov <maxim.uvarov@linaro.org>2016-04-21 21:28:55 +0300
committerMaxim Uvarov <maxim.uvarov@linaro.org>2016-04-21 21:28:55 +0300
commit407b0fa7f3105d63b102ff90b344851251b7c801 (patch)
treef8055be6219d4841aceae44540b3ed99a859e59d /configure.ac
parent05a38e81740816f072b39871ed7f898a4e08dc54 (diff)
parentec964bb3d07b13c4c325a73bfaecf6c159d973e2 (diff)
Merge branch 'master' into api-next
Signed-off-by: Maxim Uvarov <maxim.uvarov@linaro.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 9 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 5c8647830..0b1034429 100644
--- a/configure.ac
+++ b/configure.ac
@@ -12,7 +12,7 @@ AM_SILENT_RULES([yes])
##########################################################################
# Set correct platform library version
##########################################################################
-ODP_LIBSO_VERSION=108:0:0
+ODP_LIBSO_VERSION=109:0:0
AC_SUBST(ODP_LIBSO_VERSION)
# Checks for programs.
@@ -157,10 +157,12 @@ DX_INIT_DOXYGEN($PACKAGE_NAME, ${srcdir}/doc/application-api-guide/doxygen.cfg,
##########################################################################
# Enable/disable ODP_DEBUG_PRINT
##########################################################################
-ODP_DEBUG_PRINT=1
+ODP_DEBUG_PRINT=0
AC_ARG_ENABLE([debug-print],
[ --enable-debug-print display debugging information],
- [if ! test "x$enableval" = "xyes"; then
+ [if test "x$enableval" = "xyes"; then
+ ODP_DEBUG_PRINT=1
+ else
ODP_DEBUG_PRINT=0
fi])
ODP_CFLAGS="$ODP_CFLAGS -DODP_DEBUG_PRINT=$ODP_DEBUG_PRINT"
@@ -168,10 +170,12 @@ ODP_CFLAGS="$ODP_CFLAGS -DODP_DEBUG_PRINT=$ODP_DEBUG_PRINT"
##########################################################################
# Enable/disable ODP_DEBUG
##########################################################################
-ODP_DEBUG=1
+ODP_DEBUG=0
AC_ARG_ENABLE([debug],
[ --enable-debug include additional code],
- [if ! test "x$enableval" = "xyes"; then
+ [if test "x$enableval" = "xyes"; then
+ ODP_DEBUG=1
+ else
ODP_DEBUG=0
fi])
ODP_CFLAGS="$ODP_CFLAGS -DODP_DEBUG=$ODP_DEBUG"