aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAnders Roxell <anders.roxell@linaro.org>2016-03-29 20:23:28 +0200
committerMaxim Uvarov <maxim.uvarov@linaro.org>2016-03-30 16:19:05 +0300
commit1d773441e56b9c9a97347b90bd9b7c14bc77eb58 (patch)
treec34f2b4d20e019483c0d62151671db2ef70622c8 /configure.ac
parentd657f6b62d24d15776a433b449f5d1f0069413a8 (diff)
configure: move test_perf to its own m4 file
Signed-off-by: Anders Roxell <anders.roxell@linaro.org> Tested-and-reviewed-by: Mike Holmes <mike.holmes@linaro.org> Signed-off-by: Maxim Uvarov <maxim.uvarov@linaro.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 6 insertions, 13 deletions
diff --git a/configure.ac b/configure.ac
index 75d846e99..cc6a38b7c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -82,6 +82,11 @@ AC_SUBST([platform_with_platform], ["platform/${with_platform}"])
AC_SUBST([platform_with_platform_test], ["platform/${with_platform}/test"])
##########################################################################
+# Include m4 files
+##########################################################################
+m4_include([./test/m4/configure.m4])
+
+##########################################################################
# Run platform specific checks and settings
##########################################################################
if test "${with_platform}" == "linux-generic";
@@ -133,6 +138,7 @@ AM_CONDITIONAL([PKTIO_DPDK], [test x$pktio_dpdk_support = xyes ])
AM_CONDITIONAL([HAVE_PCAP], [test $have_pcap = yes])
AM_CONDITIONAL([SDK_INSTALL_PATH_], [test "x${SDK_INSTALL_PATH_}" = "x1"])
AM_CONDITIONAL([test_installdir], [test "$testdir" != ""])
+AM_CONDITIONAL([test_perf], [test x$test_perf = xyes ])
##########################################################################
# Setup doxygen documentation
@@ -155,18 +161,6 @@ AC_ARG_ENABLE([test_vald],
AM_CONDITIONAL([test_vald], [test x$test_vald = xyes ])
##########################################################################
-# Enable/disable test-perf
-##########################################################################
-test_perf=no
-AC_ARG_ENABLE([test-perf],
- [ --enable-test-perf run test in test/performance],
- [if test "x$enableval" = "xyes"; then
- test_perf=yes
- fi])
-
-AM_CONDITIONAL([test_perf], [test x$test_perf = xyes ])
-
-##########################################################################
# Enable/disable test-helper
##########################################################################
test_helper=no
@@ -325,7 +319,6 @@ AC_CONFIG_FILES([Makefile
m4_include([./doc/m4/configure.m4])
m4_include([./example/m4/configure.m4])
-m4_include([./test/m4/configure.m4])
AC_SEARCH_LIBS([timer_create],[rt posix4])