summaryrefslogtreecommitdiff
path: root/include
diff options
context:
space:
mode:
Diffstat (limited to 'include')
-rw-r--r--include/libvirt/Makefile.in2
-rw-r--r--include/libvirt/libvirt-common.h2
-rw-r--r--include/libvirt/libvirt-domain.h128
3 files changed, 118 insertions, 14 deletions
diff --git a/include/libvirt/Makefile.in b/include/libvirt/Makefile.in
index 713d18cea..23107eb27 100644
--- a/include/libvirt/Makefile.in
+++ b/include/libvirt/Makefile.in
@@ -1783,7 +1783,6 @@ mandir = @mandir@
mkdir_p = @mkdir_p@
oldincludedir = @oldincludedir@
pdfdir = @pdfdir@
-plugindir = @plugindir@
prefix = @prefix@
program_transform_name = @program_transform_name@
psdir = @psdir@
@@ -1796,6 +1795,7 @@ target_alias = @target_alias@
top_build_prefix = @top_build_prefix@
top_builddir = @top_builddir@
top_srcdir = @top_srcdir@
+ws_plugindir = @ws_plugindir@
virincdir = $(includedir)/libvirt
allheaders = $(wildcard $(srcdir)/*.h)
virinc_HEADERS = $(filter-out $(srcdir)/libvirt-common.h, \
diff --git a/include/libvirt/libvirt-common.h b/include/libvirt/libvirt-common.h
index ca944e41d..efea36719 100644
--- a/include/libvirt/libvirt-common.h
+++ b/include/libvirt/libvirt-common.h
@@ -73,7 +73,7 @@ extern "C" {
* version * 1,000,000 + minor * 1000 + micro
*/
-# define LIBVIR_VERSION_NUMBER 2003000
+# define LIBVIR_VERSION_NUMBER 2004000
/**
* LIBVIR_CHECK_VERSION:
diff --git a/include/libvirt/libvirt-domain.h b/include/libvirt/libvirt-domain.h
index f1c35d97f..5f5066074 100644
--- a/include/libvirt/libvirt-domain.h
+++ b/include/libvirt/libvirt-domain.h
@@ -1707,6 +1707,7 @@ typedef enum {
/* Additionally, these flags may be bitwise-OR'd in. */
VIR_DOMAIN_VCPU_MAXIMUM = (1 << 2), /* Max rather than current count */
VIR_DOMAIN_VCPU_GUEST = (1 << 3), /* Modify state of the cpu in the guest */
+ VIR_DOMAIN_VCPU_HOTPLUGGABLE = (1 << 4), /* Make vcpus added hot(un)pluggable */
} virDomainVcpuFlags;
int virDomainSetVcpus (virDomainPtr domain,
@@ -2007,7 +2008,8 @@ void virDomainStatsRecordListFree(virDomainStatsRecordPtr *stats);
* VIR_PERF_PARAM_CPU_CYCLES:
*
* Macro for typed parameter name that represents cpu_cycles perf event
- * which can be used to measure how many cpu cycles one instruction needs.
+ * describing the total/elapsed cpu cycles. This can be used to measure
+ * how many cpu cycles one instruction needs.
* It corresponds to the "perf.cpu_cycles" field in the *Stats APIs.
*/
# define VIR_PERF_PARAM_CPU_CYCLES "cpu_cycles"
@@ -2321,6 +2323,54 @@ int virDomainBlockCommit(virDomainPtr dom, const char *disk, const char *base,
# define VIR_DOMAIN_BLOCK_IOTUNE_WRITE_IOPS_SEC_MAX "write_iops_sec_max"
/**
+ * VIR_DOMAIN_BLOCK_IOTUNE_TOTAL_BYTES_SEC_MAX_LENGTH:
+ *
+ * Macro for the BlockIoTune tunable weight: it represents the duration in
+ * seconds for the burst allowed by total_bytes_sec_max, as a ullong.
+ */
+# define VIR_DOMAIN_BLOCK_IOTUNE_TOTAL_BYTES_SEC_MAX_LENGTH "total_bytes_sec_max_length"
+
+/**
+ * VIR_DOMAIN_BLOCK_IOTUNE_READ_BYTES_SEC_MAX_LENGTH:
+ *
+ * Macro for the BlockIoTune tunable weight: it represents the duration in
+ * seconds for the burst allowed by read_bytes_sec_max, as a ullong.
+ */
+# define VIR_DOMAIN_BLOCK_IOTUNE_READ_BYTES_SEC_MAX_LENGTH "read_bytes_sec_max_length"
+
+/**
+ * VIR_DOMAIN_BLOCK_IOTUNE_WRITE_BYTES_SEC_MAX_LENGTH:
+ *
+ * Macro for the BlockIoTune tunable weight: it represents the duration in
+ * seconds for the burst allowed by write_bytes_sec_max, as a ullong.
+ */
+# define VIR_DOMAIN_BLOCK_IOTUNE_WRITE_BYTES_SEC_MAX_LENGTH "write_bytes_sec_max_length"
+
+/**
+ * VIR_DOMAIN_BLOCK_IOTUNE_TOTAL_IOPS_SEC_MAX_LENGTH:
+ *
+ * Macro for the BlockIoTune tunable weight: it represents the duration in
+ * seconds for the burst allowed by total_iops_sec_max, as a ullong.
+ */
+# define VIR_DOMAIN_BLOCK_IOTUNE_TOTAL_IOPS_SEC_MAX_LENGTH "total_iops_sec_max_length"
+
+/**
+ * VIR_DOMAIN_BLOCK_IOTUNE_READ_IOPS_SEC_MAX_LENGTH:
+ *
+ * Macro for the BlockIoTune tunable weight: it represents the duration in
+ * seconds for the burst allowed by read_iops_sec_max, as a ullong.
+ */
+# define VIR_DOMAIN_BLOCK_IOTUNE_READ_IOPS_SEC_MAX_LENGTH "read_iops_sec_max_length"
+
+/**
+ * VIR_DOMAIN_BLOCK_IOTUNE_WRITE_IOPS_SEC_MAX_LENGTH:
+ *
+ * Macro for the BlockIoTune tunable weight: it represents the duration in
+ * seconds for the burst allowed by write_iops_sec_max, as a ullong.
+ */
+# define VIR_DOMAIN_BLOCK_IOTUNE_WRITE_IOPS_SEC_MAX_LENGTH "write_iops_sec_max_length"
+
+/**
* VIR_DOMAIN_BLOCK_IOTUNE_SIZE_IOPS_SEC:
* Macro for the BlockIoTune tunable weight: it represents the size
* I/O operations per second permitted through a block device, as a ullong.
@@ -3695,7 +3745,7 @@ typedef void (*virConnectDomainEventJobCompletedCallback)(virConnectPtr conn,
/**
* VIR_DOMAIN_TUNABLE_BLKDEV_TOTAL_BYTES_SEC:
*
- * Marco represents the total throughput limit in bytes per second,
+ * Macro represents the total throughput limit in bytes per second,
* as VIR_TYPED_PARAM_ULLONG.
*/
# define VIR_DOMAIN_TUNABLE_BLKDEV_TOTAL_BYTES_SEC "blkdeviotune.total_bytes_sec"
@@ -3703,7 +3753,7 @@ typedef void (*virConnectDomainEventJobCompletedCallback)(virConnectPtr conn,
/**
* VIR_DOMAIN_TUNABLE_BLKDEV_READ_BYTES_SEC:
*
- * Marco represents the read throughput limit in bytes per second,
+ * Macro represents the read throughput limit in bytes per second,
* as VIR_TYPED_PARAM_ULLONG.
*/
# define VIR_DOMAIN_TUNABLE_BLKDEV_READ_BYTES_SEC "blkdeviotune.read_bytes_sec"
@@ -3743,31 +3793,31 @@ typedef void (*virConnectDomainEventJobCompletedCallback)(virConnectPtr conn,
/**
* VIR_DOMAIN_TUNABLE_BLKDEV_TOTAL_BYTES_SEC_MAX:
*
- * Marco represents the total throughput limit in maximum bytes per second,
- * as VIR_TYPED_PARAM_ULLONG.
+ * Macro represents the total throughput limit during bursts in
+ * maximum bytes per second, as VIR_TYPED_PARAM_ULLONG.
*/
# define VIR_DOMAIN_TUNABLE_BLKDEV_TOTAL_BYTES_SEC_MAX "blkdeviotune.total_bytes_sec_max"
/**
* VIR_DOMAIN_TUNABLE_BLKDEV_READ_BYTES_SEC_MAX:
*
- * Marco represents the read throughput limit in maximum bytes per second,
- * as VIR_TYPED_PARAM_ULLONG.
+ * Macro represents the read throughput limit during bursts in
+ * maximum bytes per second, as VIR_TYPED_PARAM_ULLONG.
*/
# define VIR_DOMAIN_TUNABLE_BLKDEV_READ_BYTES_SEC_MAX "blkdeviotune.read_bytes_sec_max"
/**
* VIR_DOMAIN_TUNABLE_BLKDEV_WRITE_BYTES_SEC_MAX:
*
- * Macro represents the write throughput limit in maximum bytes per second,
- * as VIR_TYPED_PARAM_ULLONG.
+ * Macro represents the write throughput limit during bursts in
+ * maximum bytes per second, as VIR_TYPED_PARAM_ULLONG.
*/
# define VIR_DOMAIN_TUNABLE_BLKDEV_WRITE_BYTES_SEC_MAX "blkdeviotune.write_bytes_sec_max"
/**
* VIR_DOMAIN_TUNABLE_BLKDEV_TOTAL_IOPS_SEC_MAX:
*
- * Macro represents the total maximum I/O operations per second,
+ * Macro represents the total maximum I/O operations per second during bursts,
* as VIR_TYPED_PARAM_ULLONG.
*/
# define VIR_DOMAIN_TUNABLE_BLKDEV_TOTAL_IOPS_SEC_MAX "blkdeviotune.total_iops_sec_max"
@@ -3775,7 +3825,7 @@ typedef void (*virConnectDomainEventJobCompletedCallback)(virConnectPtr conn,
/**
* VIR_DOMAIN_TUNABLE_BLKDEV_READ_IOPS_SEC_MAX:
*
- * Macro represents the read maximum I/O operations per second,
+ * Macro represents the read maximum I/O operations per second during bursts,
* as VIR_TYPED_PARAM_ULLONG.
*/
# define VIR_DOMAIN_TUNABLE_BLKDEV_READ_IOPS_SEC_MAX "blkdeviotune.read_iops_sec_max"
@@ -3783,7 +3833,7 @@ typedef void (*virConnectDomainEventJobCompletedCallback)(virConnectPtr conn,
/**
* VIR_DOMAIN_TUNABLE_BLKDEV_WRITE_IOPS_SEC_MAX:
*
- * Macro represents the write maximum I/O operations per second,
+ * Macro represents the write maximum I/O operations per second during bursts,
* as VIR_TYPED_PARAM_ULLONG.
*/
# define VIR_DOMAIN_TUNABLE_BLKDEV_WRITE_IOPS_SEC_MAX "blkdeviotune.write_iops_sec_max"
@@ -3797,6 +3847,60 @@ typedef void (*virConnectDomainEventJobCompletedCallback)(virConnectPtr conn,
# define VIR_DOMAIN_TUNABLE_BLKDEV_SIZE_IOPS_SEC "blkdeviotune.size_iops_sec"
/**
+ * VIR_DOMAIN_TUNABLE_BLKDEV_TOTAL_BYTES_SEC_MAX_LENGTH:
+ *
+ * Macro represents the length in seconds allowed for a burst period
+ * for the blkdeviotune.total_bytes_sec_max,
+ * as VIR_TYPED_PARAM_ULLONG.
+ */
+# define VIR_DOMAIN_TUNABLE_BLKDEV_TOTAL_BYTES_SEC_MAX_LENGTH "blkdeviotune.total_bytes_sec_max_length"
+
+/**
+ * VIR_DOMAIN_TUNABLE_BLKDEV_READ_BYTES_SEC_MAX_LENGTH:
+ *
+ * Macro represents the length in seconds allowed for a burst period
+ * for the blkdeviotune.read_bytes_sec_max
+ * as VIR_TYPED_PARAM_ULLONG.
+ */
+# define VIR_DOMAIN_TUNABLE_BLKDEV_READ_BYTES_SEC_MAX_LENGTH "blkdeviotune.read_bytes_sec_max_length"
+
+/**
+ * VIR_DOMAIN_TUNABLE_BLKDEV_WRITE_BYTES_SEC_MAX_LENGTH:
+ *
+ * Macro represents the length in seconds allowed for a burst period
+ * for the blkdeviotune.write_bytes_sec_max
+ * as VIR_TYPED_PARAM_ULLONG.
+ */
+# define VIR_DOMAIN_TUNABLE_BLKDEV_WRITE_BYTES_SEC_MAX_LENGTH "blkdeviotune.write_bytes_sec_max_length"
+
+/**
+ * VIR_DOMAIN_TUNABLE_BLKDEV_TOTAL_IOPS_SEC_MAX_LENGTH:
+ *
+ * Macro represents the length in seconds allowed for a burst period
+ * for the blkdeviotune.total_iops_sec_max
+ * as VIR_TYPED_PARAM_ULLONG.
+ */
+# define VIR_DOMAIN_TUNABLE_BLKDEV_TOTAL_IOPS_SEC_MAX_LENGTH "blkdeviotune.total_iops_sec_max_length"
+
+/**
+ * VIR_DOMAIN_TUNABLE_BLKDEV_READ_IOPS_SEC_MAX_LENGTH:
+ *
+ * Macro represents the length in seconds allowed for a burst period
+ * for the blkdeviotune.read_iops_sec_max
+ * as VIR_TYPED_PARAM_ULLONG.
+ */
+# define VIR_DOMAIN_TUNABLE_BLKDEV_READ_IOPS_SEC_MAX_LENGTH "blkdeviotune.read_iops_sec_max_length"
+
+/**
+ * VIR_DOMAIN_TUNABLE_BLKDEV_WRITE_IOPS_SEC_MAX_LENGTH:
+ *
+ * Macro represents the length in seconds allowed for a burst period
+ * for the blkdeviotune.write_iops_sec_max
+ * as VIR_TYPED_PARAM_ULLONG.
+ */
+# define VIR_DOMAIN_TUNABLE_BLKDEV_WRITE_IOPS_SEC_MAX_LENGTH "blkdeviotune.write_iops_sec_max_length"
+
+/**
* virConnectDomainEventTunableCallback:
* @conn: connection object
* @dom: domain on which the event occurred