summaryrefslogtreecommitdiff
path: root/daemon
diff options
context:
space:
mode:
Diffstat (limited to 'daemon')
-rw-r--r--daemon/Makefile.in2
-rw-r--r--daemon/libvirtd.c10
2 files changed, 6 insertions, 6 deletions
diff --git a/daemon/Makefile.in b/daemon/Makefile.in
index 4def75c80..71b6462e7 100644
--- a/daemon/Makefile.in
+++ b/daemon/Makefile.in
@@ -1896,7 +1896,6 @@ mandir = @mandir@
mkdir_p = @mkdir_p@
oldincludedir = @oldincludedir@
pdfdir = @pdfdir@
-plugindir = @plugindir@
prefix = @prefix@
program_transform_name = @program_transform_name@
psdir = @psdir@
@@ -1909,6 +1908,7 @@ target_alias = @target_alias@
top_build_prefix = @top_build_prefix@
top_builddir = @top_builddir@
top_srcdir = @top_srcdir@
+ws_plugindir = @ws_plugindir@
INCLUDES = \
-I$(top_builddir)/gnulib/lib -I$(top_srcdir)/gnulib/lib \
-I$(top_srcdir) \
diff --git a/daemon/libvirtd.c b/daemon/libvirtd.c
index 95c1b1c13..fbba9cc4e 100644
--- a/daemon/libvirtd.c
+++ b/daemon/libvirtd.c
@@ -691,10 +691,10 @@ daemonSetupLogging(struct daemonConfig *config,
virLogSetFromEnv();
if (virLogGetNbFilters() == 0)
- virLogParseFilters(config->log_filters);
+ virLogSetFilters(config->log_filters);
- if (virLogGetNbOutputs() == 0)
- virLogParseOutputs(config->log_outputs);
+ if (config->log_outputs && virLogGetNbOutputs() == 0)
+ virLogSetOutputs(config->log_outputs);
/*
* Command line override for --verbose
@@ -721,7 +721,7 @@ daemonSetupLogging(struct daemonConfig *config,
if (virAsprintf(&tmp, "%d:journald", priority) < 0)
goto error;
- virLogParseOutputs(tmp);
+ virLogSetOutputs(tmp);
VIR_FREE(tmp);
}
}
@@ -764,7 +764,7 @@ daemonSetupLogging(struct daemonConfig *config,
if (virAsprintf(&tmp, "%d:stderr", virLogGetDefaultPriority()) < 0)
goto error;
}
- virLogParseOutputs(tmp);
+ virLogSetOutputs(tmp);
VIR_FREE(tmp);
}