summaryrefslogtreecommitdiff
path: root/tests
diff options
context:
space:
mode:
authorGuido Günther <agx@sigxcpu.org>2014-09-30 19:28:00 +0200
committerGuido Günther <agx@sigxcpu.org>2014-09-30 19:28:00 +0200
commit8707039d5fcb05230d3ad5b21de4113ccf86cf1c (patch)
tree7cf3e7847d0ff1ecbfdcc1d10a77406159a9ee84 /tests
parent063cc84dcfb5112e1e1ead25123fe13a6f0ac201 (diff)
New upstream version 1.2.9~rc2
Diffstat (limited to 'tests')
-rw-r--r--tests/Makefile.in2
-rw-r--r--tests/qemuxml2argvdata/qemuxml2argv-hugepages-memaccess-invalid.xml45
-rw-r--r--tests/qemuxml2argvtest.c1
3 files changed, 48 insertions, 0 deletions
diff --git a/tests/Makefile.in b/tests/Makefile.in
index 39dc85c26..8af7d9089 100644
--- a/tests/Makefile.in
+++ b/tests/Makefile.in
@@ -2688,6 +2688,8 @@ PACKAGE_STRING = @PACKAGE_STRING@
PACKAGE_TARNAME = @PACKAGE_TARNAME@
PACKAGE_URL = @PACKAGE_URL@
PACKAGE_VERSION = @PACKAGE_VERSION@
+PARALLELS_SDK_CFLAGS = @PARALLELS_SDK_CFLAGS@
+PARALLELS_SDK_LIBS = @PARALLELS_SDK_LIBS@
PARTED = @PARTED@
PATH_SEPARATOR = @PATH_SEPARATOR@
PCIACCESS_CFLAGS = @PCIACCESS_CFLAGS@
diff --git a/tests/qemuxml2argvdata/qemuxml2argv-hugepages-memaccess-invalid.xml b/tests/qemuxml2argvdata/qemuxml2argv-hugepages-memaccess-invalid.xml
new file mode 100644
index 000000000..83b8ac235
--- /dev/null
+++ b/tests/qemuxml2argvdata/qemuxml2argv-hugepages-memaccess-invalid.xml
@@ -0,0 +1,45 @@
+<domain type='qemu'>
+ <name>QEMUGuest1</name>
+ <uuid>c7a5fdbd-edaf-9455-926a-d65c16db1809</uuid>
+ <memory unit='KiB'>4194304</memory>
+ <currentMemory unit='KiB'>4194304</currentMemory>
+ <memoryBacking>
+ <hugepages>
+ <page size='2048' unit='KiB' nodeset='1'/>
+ <page size='1048576' unit='KiB' nodeset='0,2-3'/>
+ </hugepages>
+ </memoryBacking>
+ <vcpu placement='static'>4</vcpu>
+ <numatune>
+ <memory mode='strict' nodeset='0-3'/>
+ <memnode cellid='3' mode='strict' nodeset='3'/>
+ </numatune>
+ <os>
+ <type arch='i686' machine='pc'>hvm</type>
+ <boot dev='hd'/>
+ </os>
+ <cpu>
+ <numa>
+ <cell id='0' cpus='0' memory='1048576'/>
+ <cell id='1' cpus='1' memory='1048576' memAccess='invalid'/>
+ <cell id='2' cpus='2' memory='1048576' memAccess='private'/>
+ <cell id='3' cpus='3' memory='1048576'/>
+ </numa>
+ </cpu>
+ <clock offset='utc'/>
+ <on_poweroff>destroy</on_poweroff>
+ <on_reboot>restart</on_reboot>
+ <on_crash>destroy</on_crash>
+ <devices>
+ <emulator>/usr/bin/qemu</emulator>
+ <disk type='block' device='disk'>
+ <source dev='/dev/HostVG/QEMUGuest1'/>
+ <target dev='hda' bus='ide'/>
+ <address type='drive' controller='0' bus='0' target='0' unit='0'/>
+ </disk>
+ <controller type='usb' index='0'/>
+ <controller type='ide' index='0'/>
+ <controller type='pci' index='0' model='pci-root'/>
+ <memballoon model='virtio'/>
+ </devices>
+</domain>
diff --git a/tests/qemuxml2argvtest.c b/tests/qemuxml2argvtest.c
index 4c85bfe54..b380fd86c 100644
--- a/tests/qemuxml2argvtest.c
+++ b/tests/qemuxml2argvtest.c
@@ -691,6 +691,7 @@ mymain(void)
QEMU_CAPS_OBJECT_MEMORY_FILE);
DO_TEST("hugepages-shared", QEMU_CAPS_MEM_PATH, QEMU_CAPS_OBJECT_MEMORY_RAM,
QEMU_CAPS_OBJECT_MEMORY_FILE);
+ DO_TEST_PARSE_ERROR("hugepages-memaccess-invalid", NONE);
DO_TEST_FAILURE("hugepages-pages4", QEMU_CAPS_MEM_PATH,
QEMU_CAPS_OBJECT_MEMORY_RAM, QEMU_CAPS_OBJECT_MEMORY_FILE);
DO_TEST("hugepages-pages5", QEMU_CAPS_MEM_PATH);