summaryrefslogtreecommitdiff
path: root/maint.mk
diff options
context:
space:
mode:
authorLaurent Léonard <laurent@open-minds.org>2010-11-14 00:11:17 +0100
committerLaurent Léonard <laurent@open-minds.org>2010-11-14 00:11:17 +0100
commit802e65869571c43bff4dd6431f8f6d6811e0d5e9 (patch)
tree55c6c548b24cc5ea3758e3702cbfca7ae75dff3a /maint.mk
parent49a581bba85a74041977c0222b3b54ca840c63df (diff)
Imported Upstream version 0.8.5
Diffstat (limited to 'maint.mk')
-rw-r--r--maint.mk15
1 files changed, 9 insertions, 6 deletions
diff --git a/maint.mk b/maint.mk
index 59e9cb58e..f6b600348 100644
--- a/maint.mk
+++ b/maint.mk
@@ -668,8 +668,9 @@ sc_prohibit_always_true_header_tests:
@or=$(gl_header_upper_case_or_); \
re="HAVE_($$or)_H"; \
prohibit='\<'"$$re"'\>' \
- halt='do not test the above HAVE_<header>_H symbol(s);\n'\
-' with the corresponding gnulib module, they are always true' \
+ halt=$$(printf '%s\n' \
+ 'do not test the above HAVE_<header>_H symbol(s);' \
+ ' with the corresponding gnulib module, they are always true') \
$(_sc_search_regexp)
# ==================================================================
@@ -915,6 +916,7 @@ sc_po_check:
test -r $$file || continue; \
case $$file in \
*.m4|*.mk) continue ;; \
+ *.html|*.html.in) continue ;; \
*.?|*.??) ;; \
*) continue;; \
esac; \
@@ -954,7 +956,7 @@ writable-files:
test "$$fail" && exit 1 || : ; \
fi
-v_etc_file = lib/version-etc.c
+v_etc_file = $(gnulib_dir)/lib/version-etc.c
sample-test = tests/sample-test
texi = doc/$(PACKAGE).texi
# Make sure that the copyright date in $(v_etc_file) is up to date.
@@ -1012,9 +1014,10 @@ sc_Wundef_boolean:
sc_vulnerable_makefile_CVE-2009-4029:
@prohibit='perm -777 -exec chmod a\+rwx|chmod 777 \$$\(distdir\)' \
in_files=$$(find $(srcdir) -name Makefile.in) \
- halt='the above files are vulnerable; beware of running\n'\
-'"make dist*" rules, and upgrade to fixed automake\n'\
-'see http://bugzilla.redhat.com/542609 for details' \
+ halt=$$(printf '%s\n' \
+ 'the above files are vulnerable; beware of running' \
+ ' "make dist*" rules, and upgrade to fixed automake' \
+ ' see http://bugzilla.redhat.com/542609 for details') \
$(_sc_search_regexp)
vc-diff-check: