summaryrefslogtreecommitdiff
path: root/maint.mk
diff options
context:
space:
mode:
authorGuido Günther <agx@sigxcpu.org>2012-05-13 19:07:53 +0200
committerGuido Günther <agx@sigxcpu.org>2012-05-13 19:07:53 +0200
commit721a2d8dbb3b43a2cc3efdfe0824c369db84142a (patch)
treee2d4d61e57857ae018abb322e0237024897c727f /maint.mk
parent34aa61bdb7ec355095df144171dd17c19a8a2d84 (diff)
New upstream version 0.9.12~rc2
Diffstat (limited to 'maint.mk')
-rw-r--r--maint.mk9
1 files changed, 8 insertions, 1 deletions
diff --git a/maint.mk b/maint.mk
index 2228a378b..1c7af0365 100644
--- a/maint.mk
+++ b/maint.mk
@@ -932,8 +932,15 @@ sc_prohibit_doubled_word:
# A regular expression matching undesirable combinations of words like
# "can not"; this matches them even when the two words appear on different
# lines, but not when there is an intervening delimiter like "#" or "*".
+# Similarly undesirable, "See @xref{...}", since an @xref should start
+# a sentence. Explicitly prohibit any prefix of "see" or "also".
+# Also prohibit a prefix matching "\w+ +".
+# @pxref gets the same see/also treatment and should be parenthesized;
+# presume it must *not* start a sentence.
+bad_xref_re_ ?= (?:[\w,:;] +|(?:see|also)\s+)\@xref\{
+bad_pxref_re_ ?= (?:[.!?]|(?:see|also))\s+\@pxref\{
prohibit_undesirable_word_seq_RE_ ?= \
- /\bcan\s+not\b/gims
+ /(?:\bcan\s+not\b|$(bad_xref_re_)|$(bad_pxref_re_))/gims
prohibit_undesirable_word_seq_ = \
-e 'while ($(prohibit_undesirable_word_seq_RE_))' \
$(perl_filename_lineno_text_)