summaryrefslogtreecommitdiff
path: root/maint.mk
diff options
context:
space:
mode:
authorGuido Günther <agx@sigxcpu.org>2015-03-31 09:47:14 +0200
committerGuido Günther <agx@sigxcpu.org>2015-03-31 09:47:14 +0200
commit46cb100a8da11de1bf4583fd0de142c59ea5a27d (patch)
treefe3166d9f5c2513f6a03f9a30f727859e25f5285 /maint.mk
parent5a5a046f4bfde76f03f11232043a8a49f3596b25 (diff)
New upstream version 1.2.14-rc2
Diffstat (limited to 'maint.mk')
-rw-r--r--maint.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/maint.mk b/maint.mk
index d21931f1b..b6ec1b5e1 100644
--- a/maint.mk
+++ b/maint.mk
@@ -1648,14 +1648,14 @@ _gl_tight_scope: $(bin_PROGRAMS)
perl -lne \
'$(_gl_TS_function_match) and print "^$$1\$$"' $$hdr; \
) | sort -u > $$t; \
- nm -e $(_gl_TS_obj_files)|$(SED) -n 's/.* T //p'|grep -Ev -f $$t \
+ nm -g $(_gl_TS_obj_files)|$(SED) -n 's/.* T //p'|grep -Ev -f $$t \
&& { echo the above functions should have static scope >&2; \
exit 1; } || : ; \
( printf '^%s$$\n' '__.*' $(_gl_TS_unmarked_extern_vars); \
perl -lne '$(_gl_TS_var_match) and print "^$$1\$$"' \
$$hdr $(_gl_TS_other_headers) \
) | sort -u > $$t; \
- nm -e $(_gl_TS_obj_files) | $(SED) -n 's/.* [BCDGRS] //p' \
+ nm -g $(_gl_TS_obj_files) | $(SED) -n 's/.* [BCDGRS] //p' \
| sort -u | grep -Ev -f $$t \
&& { echo the above variables should have static scope >&2; \
exit 1; } || :