summaryrefslogtreecommitdiff
path: root/maint.mk
diff options
context:
space:
mode:
authorGuido Günther <agx@sigxcpu.org>2012-04-03 20:08:57 +0200
committerGuido Günther <agx@sigxcpu.org>2012-04-03 20:08:57 +0200
commit34aa61bdb7ec355095df144171dd17c19a8a2d84 (patch)
tree5714eded536c6059fee5aa37eb1989c97c9edb04 /maint.mk
parent049b63bda2c0ad4fa76e4adb17b6b1e331daff7a (diff)
New upstream version 0.9.11
Diffstat (limited to 'maint.mk')
-rw-r--r--maint.mk7
1 files changed, 4 insertions, 3 deletions
diff --git a/maint.mk b/maint.mk
index 4cbd5f400..2228a378b 100644
--- a/maint.mk
+++ b/maint.mk
@@ -279,7 +279,7 @@ define _sc_search_regexp
if test -n "$$files"; then \
if test -n "$$prohibit"; then \
grep $$with_grep_options $(_ignore_case) -nE "$$prohibit" $$files \
- | grep -vE "$${exclude-^$$}" \
+ | grep -vE "$${exclude:-^$$}" \
&& { msg="$$halt" $(_sc_say_and_exit) } || :; \
else \
grep $$with_grep_options $(_ignore_case) -LE "$$require" $$files \
@@ -455,7 +455,8 @@ sc_prohibit_quotearg_without_use:
# Don't include quote.h unless you use one of its functions.
sc_prohibit_quote_without_use:
- @h='quote.h' re='\<quote(_n)? *\(' $(_sc_header_without_use)
+ @h='quote.h' re='\<quote((_n)? *\(|_quoting_options\>)' \
+ $(_sc_header_without_use)
# Don't include this header unless you use one of its functions.
sc_prohibit_long_options_without_use:
@@ -1332,7 +1333,7 @@ alpha beta stable: $(local-check) writable-files $(submodule-checks)
$(MAKE) vc-diff-check
$(MAKE) news-check
$(MAKE) distcheck
- $(MAKE) dist XZ_OPT=-9ev
+ $(MAKE) dist
$(MAKE) $(release-prep-hook) RELEASE_TYPE=$@
$(MAKE) -s emit_upload_commands RELEASE_TYPE=$@