summaryrefslogtreecommitdiff
path: root/libvirt.spec.in
diff options
context:
space:
mode:
authorGuido Günther <agx@sigxcpu.org>2011-06-08 14:46:57 +0200
committerGuido Günther <agx@sigxcpu.org>2011-06-08 14:46:57 +0200
commitc6187ec7076136e0b687f455dc4e9c69ae7a0cf0 (patch)
tree7f228a3d3f92ae1e408f7681e665534e5edc24c7 /libvirt.spec.in
parent1546b8c2d80477aa28e78875be0199ebec2f9c16 (diff)
New upstream version 0.9.2
Diffstat (limited to 'libvirt.spec.in')
-rw-r--r--libvirt.spec.in47
1 files changed, 46 insertions, 1 deletions
diff --git a/libvirt.spec.in b/libvirt.spec.in
index 8a6912ff2..c7ef8d01b 100644
--- a/libvirt.spec.in
+++ b/libvirt.spec.in
@@ -76,6 +76,7 @@
%define with_audit 0%{!?_without_audit:0}
%define with_dtrace 0%{!?_without_dtrace:0}
%define with_cgconfig 0%{!?_without_cgconfig:0}
+%define with_sanlock 0%{!?_without_sanlock:0}
# Non-server/HV driver defaults which are always enabled
%define with_python 0%{!?_without_python:1}
@@ -162,6 +163,11 @@
%define with_yajl 0%{!?_without_yajl:%{server_drivers}}
%endif
+# Enable sanlock library for lock management with QEMU
+%if 0%{?fedora} >= 15 || 0%{?rhel} >= 6
+%define with_sanlock 0%{!?_without_sanlock:%{server_drivers}}
+%endif
+
# Enable libpcap library
%if %{with_qemu}
%define with_nwfilter 0%{!?_without_nwfilter:%{server_drivers}}
@@ -332,6 +338,9 @@ BuildRequires: libpciaccess-devel >= 0.10.9
%if %{with_yajl}
BuildRequires: yajl-devel
%endif
+%if %{with_sanlock}
+BuildRequires: sanlock-devel
+%endif
%if %{with_libpcap}
BuildRequires: libpcap-devel
%endif
@@ -483,6 +492,18 @@ Requires: xen-devel
Includes and documentations for the C library providing an API to use
the virtualization capabilities of recent versions of Linux (and other OSes).
+%if %{with_sanlock}
+%package lock-sanlock
+Summary: Sanlock lock manager plugin for QEMU driver
+Group: Development/Libraries
+Requires: sanlock
+Requires: %{name} = %{version}-%{release}
+
+%description lock-sanlock
+Includes the Sanlock lock manager plugin for the QEMU
+driver
+%endif
+
%if %{with_python}
%package python
Summary: Python bindings for the libvirt library
@@ -620,6 +641,10 @@ of recent versions of Linux (and other OSes).
%define _without_yajl --without-yajl
%endif
+%if ! %{with_sanlock}
+%define _without_sanlock --without-sanlock
+%endif
+
%if ! %{with_libpcap}
%define _without_libpcap --without-libpcap
%endif
@@ -673,6 +698,7 @@ of recent versions of Linux (and other OSes).
%{?_without_hal} \
%{?_without_udev} \
%{?_without_yajl} \
+ %{?_without_sanlock} \
%{?_without_libpcap} \
%{?_without_macvtap} \
%{?_without_audit} \
@@ -698,6 +724,8 @@ rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
rm -f $RPM_BUILD_ROOT%{_libdir}/*.a
rm -f $RPM_BUILD_ROOT%{_libdir}/python*/site-packages/*.la
rm -f $RPM_BUILD_ROOT%{_libdir}/python*/site-packages/*.a
+rm -f $RPM_BUILD_ROOT%{_libdir}/libvirt/lock-driver/*.la
+rm -f $RPM_BUILD_ROOT%{_libdir}/libvirt/lock-driver/*.a
%if %{with_network}
install -d -m 0755 $RPM_BUILD_ROOT%{_datadir}/lib/libvirt/dnsmasq/
@@ -932,7 +960,7 @@ fi
%dir %attr(0711, root, root) %{_localstatedir}/lib/libvirt/images/
%dir %attr(0711, root, root) %{_localstatedir}/lib/libvirt/boot/
-%dir %attr(0700, root, root) %{_localstatedir}/cache/libvirt/
+%dir %attr(0711, root, root) %{_localstatedir}/cache/libvirt/
%if %{with_qemu}
%dir %attr(0700, root, root) %{_localstatedir}/run/libvirt/qemu/
@@ -993,6 +1021,12 @@ fi
%doc docs/*.xml
%endif
+%if %{with_sanlock}
+%files lock-sanlock
+%defattr(-, root, root)
+%attr(0755, root, root) %{_libdir}/libvirt/lock-driver/sanlock.so
+%endif
+
%files client -f %{name}.lang
%defattr(-, root, root)
%doc AUTHORS ChangeLog.gz NEWS README COPYING.LIB TODO
@@ -1067,6 +1101,17 @@ fi
%endif
%changelog
+* Mon Jun 6 2011 Daniel Veillard <veillard@redhat.com> - 0.9.2-1
+- Framework for lock manager plugins
+- API for network config change transactions
+- flags for setting memory parameters
+- virDomainGetState public API
+- qemu: allow blkstat/blkinfo calls during migration
+- Introduce migration v3 API
+- Defining the Screenshot public API
+- public API for NMI injection
+- Various improvements and bug fixes
+
* Thu May 5 2011 Daniel Veillard <veillard@redhat.com> - 0.9.1-1
- support various persistent domain updates
- improvements on memory APIs