summaryrefslogtreecommitdiff
path: root/include
diff options
context:
space:
mode:
authorGuido Günther <agx@sigxcpu.org>2013-06-06 13:22:19 +0200
committerGuido Günther <agx@sigxcpu.org>2013-06-06 13:22:19 +0200
commit3a2c75c79b9650a7a8ecf0f80fc8caaf68d2693d (patch)
tree15d088a81bf55d5c8d65f355de79039947746c5c /include
parent6e8a971f88fe50eee0af81e317bcbf2ab60124e0 (diff)
New upstream version 1.0.6
Diffstat (limited to 'include')
-rw-r--r--include/Makefile.am17
-rw-r--r--include/Makefile.in6
-rw-r--r--include/libvirt/Makefile.am17
-rw-r--r--include/libvirt/Makefile.in6
-rw-r--r--include/libvirt/libvirt.h16
-rw-r--r--include/libvirt/libvirt.h.in14
-rw-r--r--include/libvirt/virterror.h2
7 files changed, 55 insertions, 23 deletions
diff --git a/include/Makefile.am b/include/Makefile.am
index 426762cec..80361a76a 100644
--- a/include/Makefile.am
+++ b/include/Makefile.am
@@ -1,6 +1,19 @@
## Process this file with automake to produce Makefile.in
-## Copyright (C) 2005-2011 Red Hat, Inc.
-## See COPYING.LIB for the License of this software
+## Copyright (C) 2005-2011, 2013 Red Hat, Inc.
+##
+## This library is free software; you can redistribute it and/or
+## modify it under the terms of the GNU Lesser General Public
+## License as published by the Free Software Foundation; either
+## version 2.1 of the License, or (at your option) any later version.
+##
+## This library is distributed in the hope that it will be useful,
+## but WITHOUT ANY WARRANTY; without even the implied warranty of
+## MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+## Lesser General Public License for more details.
+##
+## You should have received a copy of the GNU Lesser General Public
+## License along with this library. If not, see
+## <http://www.gnu.org/licenses/>.
SUBDIRS=libvirt
diff --git a/include/Makefile.in b/include/Makefile.in
index ee23caebd..48885f976 100644
--- a/include/Makefile.in
+++ b/include/Makefile.in
@@ -152,6 +152,7 @@ am__aclocal_m4_deps = $(top_srcdir)/gnulib/m4/00gnulib.m4 \
$(top_srcdir)/gnulib/m4/md5.m4 \
$(top_srcdir)/gnulib/m4/memchr.m4 \
$(top_srcdir)/gnulib/m4/mgetgroups.m4 \
+ $(top_srcdir)/gnulib/m4/mkdtemp.m4 \
$(top_srcdir)/gnulib/m4/mkostemp.m4 \
$(top_srcdir)/gnulib/m4/mkostemps.m4 \
$(top_srcdir)/gnulib/m4/mktime.m4 \
@@ -160,6 +161,7 @@ am__aclocal_m4_deps = $(top_srcdir)/gnulib/m4/00gnulib.m4 \
$(top_srcdir)/gnulib/m4/msvc-inval.m4 \
$(top_srcdir)/gnulib/m4/msvc-nothrow.m4 \
$(top_srcdir)/gnulib/m4/multiarch.m4 \
+ $(top_srcdir)/gnulib/m4/nanosleep.m4 \
$(top_srcdir)/gnulib/m4/net_if_h.m4 \
$(top_srcdir)/gnulib/m4/netdb_h.m4 \
$(top_srcdir)/gnulib/m4/netinet_in_h.m4 \
@@ -426,7 +428,7 @@ DLLTOOL = @DLLTOOL@
DLOPEN_LIBS = @DLOPEN_LIBS@
DMSETUP = @DMSETUP@
DNSMASQ = @DNSMASQ@
-DRIVER_MODULE_CFLAGS = @DRIVER_MODULE_CFLAGS@
+DRIVER_MODULE_LDFLAGS = @DRIVER_MODULE_LDFLAGS@
DRIVER_MODULE_LIBS = @DRIVER_MODULE_LIBS@
DSYMUTIL = @DSYMUTIL@
DTRACE = @DTRACE@
@@ -1272,6 +1274,7 @@ LIBXML_LIBS = @LIBXML_LIBS@
LIB_CLOCK_GETTIME = @LIB_CLOCK_GETTIME@
LIB_EXECINFO = @LIB_EXECINFO@
LIB_FDATASYNC = @LIB_FDATASYNC@
+LIB_NANOSLEEP = @LIB_NANOSLEEP@
LIB_POLL = @LIB_POLL@
LIB_PTHREAD = @LIB_PTHREAD@
LIB_PTHREAD_SIGMASK = @LIB_PTHREAD_SIGMASK@
@@ -1707,7 +1710,6 @@ VGS = @VGS@
VGSCAN = @VGSCAN@
VIRSH_LIBS = @VIRSH_LIBS@
WARN_CFLAGS = @WARN_CFLAGS@
-WARN_LDFLAGS = @WARN_LDFLAGS@
WARN_PYTHON_CFLAGS = @WARN_PYTHON_CFLAGS@
WCHAR_T_SUFFIX = @WCHAR_T_SUFFIX@
WIN32_EXTRA_CFLAGS = @WIN32_EXTRA_CFLAGS@
diff --git a/include/libvirt/Makefile.am b/include/libvirt/Makefile.am
index 0ec7f04a8..5638890c4 100644
--- a/include/libvirt/Makefile.am
+++ b/include/libvirt/Makefile.am
@@ -1,7 +1,20 @@
## Process this file with automake to produce Makefile.in
-## Copyright (C) 2005-2011 Red Hat, Inc.
-## See COPYING.LIB for the License of this software
+## Copyright (C) 2005-2011, 2013 Red Hat, Inc.
+##
+## This library is free software; you can redistribute it and/or
+## modify it under the terms of the GNU Lesser General Public
+## License as published by the Free Software Foundation; either
+## version 2.1 of the License, or (at your option) any later version.
+##
+## This library is distributed in the hope that it will be useful,
+## but WITHOUT ANY WARRANTY; without even the implied warranty of
+## MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+## Lesser General Public License for more details.
+##
+## You should have received a copy of the GNU Lesser General Public
+## License along with this library. If not, see
+## <http://www.gnu.org/licenses/>.
virincdir = $(includedir)/libvirt
diff --git a/include/libvirt/Makefile.in b/include/libvirt/Makefile.in
index 18cd72739..51e39d1f2 100644
--- a/include/libvirt/Makefile.in
+++ b/include/libvirt/Makefile.in
@@ -154,6 +154,7 @@ am__aclocal_m4_deps = $(top_srcdir)/gnulib/m4/00gnulib.m4 \
$(top_srcdir)/gnulib/m4/md5.m4 \
$(top_srcdir)/gnulib/m4/memchr.m4 \
$(top_srcdir)/gnulib/m4/mgetgroups.m4 \
+ $(top_srcdir)/gnulib/m4/mkdtemp.m4 \
$(top_srcdir)/gnulib/m4/mkostemp.m4 \
$(top_srcdir)/gnulib/m4/mkostemps.m4 \
$(top_srcdir)/gnulib/m4/mktime.m4 \
@@ -162,6 +163,7 @@ am__aclocal_m4_deps = $(top_srcdir)/gnulib/m4/00gnulib.m4 \
$(top_srcdir)/gnulib/m4/msvc-inval.m4 \
$(top_srcdir)/gnulib/m4/msvc-nothrow.m4 \
$(top_srcdir)/gnulib/m4/multiarch.m4 \
+ $(top_srcdir)/gnulib/m4/nanosleep.m4 \
$(top_srcdir)/gnulib/m4/net_if_h.m4 \
$(top_srcdir)/gnulib/m4/netdb_h.m4 \
$(top_srcdir)/gnulib/m4/netinet_in_h.m4 \
@@ -419,7 +421,7 @@ DLLTOOL = @DLLTOOL@
DLOPEN_LIBS = @DLOPEN_LIBS@
DMSETUP = @DMSETUP@
DNSMASQ = @DNSMASQ@
-DRIVER_MODULE_CFLAGS = @DRIVER_MODULE_CFLAGS@
+DRIVER_MODULE_LDFLAGS = @DRIVER_MODULE_LDFLAGS@
DRIVER_MODULE_LIBS = @DRIVER_MODULE_LIBS@
DSYMUTIL = @DSYMUTIL@
DTRACE = @DTRACE@
@@ -1265,6 +1267,7 @@ LIBXML_LIBS = @LIBXML_LIBS@
LIB_CLOCK_GETTIME = @LIB_CLOCK_GETTIME@
LIB_EXECINFO = @LIB_EXECINFO@
LIB_FDATASYNC = @LIB_FDATASYNC@
+LIB_NANOSLEEP = @LIB_NANOSLEEP@
LIB_POLL = @LIB_POLL@
LIB_PTHREAD = @LIB_PTHREAD@
LIB_PTHREAD_SIGMASK = @LIB_PTHREAD_SIGMASK@
@@ -1700,7 +1703,6 @@ VGS = @VGS@
VGSCAN = @VGSCAN@
VIRSH_LIBS = @VIRSH_LIBS@
WARN_CFLAGS = @WARN_CFLAGS@
-WARN_LDFLAGS = @WARN_LDFLAGS@
WARN_PYTHON_CFLAGS = @WARN_PYTHON_CFLAGS@
WCHAR_T_SUFFIX = @WCHAR_T_SUFFIX@
WIN32_EXTRA_CFLAGS = @WIN32_EXTRA_CFLAGS@
diff --git a/include/libvirt/libvirt.h b/include/libvirt/libvirt.h
index 5efc899a4..e09b5a9c6 100644
--- a/include/libvirt/libvirt.h
+++ b/include/libvirt/libvirt.h
@@ -1363,7 +1363,7 @@ VIR_EXPORT_VAR virConnectAuthPtr virConnectAuthPtrDefault;
* version * 1,000,000 + minor * 1000 + micro
*/
-#define LIBVIR_VERSION_NUMBER 1000005
+#define LIBVIR_VERSION_NUMBER 1000006
int virGetVersion (unsigned long *libVer,
const char *type,
@@ -4504,8 +4504,8 @@ typedef enum {
*/
struct _virDomainEventGraphicsAddress {
int family; /* Address family, virDomainEventGraphicsAddressType */
- const char *node; /* Address of node (eg IP address, or UNIX path) */
- const char *service; /* Service name/number (eg TCP port, or NULL) */
+ char *node; /* Address of node (eg IP address, or UNIX path) */
+ char *service; /* Service name/number (eg TCP port, or NULL) */
};
typedef struct _virDomainEventGraphicsAddress virDomainEventGraphicsAddress;
typedef virDomainEventGraphicsAddress *virDomainEventGraphicsAddressPtr;
@@ -4520,8 +4520,8 @@ typedef virDomainEventGraphicsAddress *virDomainEventGraphicsAddressPtr;
* some examples are 'x509dname' and 'saslUsername'.
*/
struct _virDomainEventGraphicsSubjectIdentity {
- const char *type; /* Type of identity */
- const char *name; /* Identity value */
+ char *type; /* Type of identity */
+ char *name; /* Identity value */
};
typedef struct _virDomainEventGraphicsSubjectIdentity virDomainEventGraphicsSubjectIdentity;
typedef virDomainEventGraphicsSubjectIdentity *virDomainEventGraphicsSubjectIdentityPtr;
@@ -4560,10 +4560,10 @@ typedef virDomainEventGraphicsSubject *virDomainEventGraphicsSubjectPtr;
typedef void (*virConnectDomainEventGraphicsCallback)(virConnectPtr conn,
virDomainPtr dom,
int phase,
- virDomainEventGraphicsAddressPtr local,
- virDomainEventGraphicsAddressPtr remote,
+ const virDomainEventGraphicsAddressPtr local,
+ const virDomainEventGraphicsAddressPtr remote,
const char *authScheme,
- virDomainEventGraphicsSubjectPtr subject,
+ const virDomainEventGraphicsSubjectPtr subject,
void *opaque);
/**
diff --git a/include/libvirt/libvirt.h.in b/include/libvirt/libvirt.h.in
index 693b83440..1804c93bc 100644
--- a/include/libvirt/libvirt.h.in
+++ b/include/libvirt/libvirt.h.in
@@ -4504,8 +4504,8 @@ typedef enum {
*/
struct _virDomainEventGraphicsAddress {
int family; /* Address family, virDomainEventGraphicsAddressType */
- const char *node; /* Address of node (eg IP address, or UNIX path) */
- const char *service; /* Service name/number (eg TCP port, or NULL) */
+ char *node; /* Address of node (eg IP address, or UNIX path) */
+ char *service; /* Service name/number (eg TCP port, or NULL) */
};
typedef struct _virDomainEventGraphicsAddress virDomainEventGraphicsAddress;
typedef virDomainEventGraphicsAddress *virDomainEventGraphicsAddressPtr;
@@ -4520,8 +4520,8 @@ typedef virDomainEventGraphicsAddress *virDomainEventGraphicsAddressPtr;
* some examples are 'x509dname' and 'saslUsername'.
*/
struct _virDomainEventGraphicsSubjectIdentity {
- const char *type; /* Type of identity */
- const char *name; /* Identity value */
+ char *type; /* Type of identity */
+ char *name; /* Identity value */
};
typedef struct _virDomainEventGraphicsSubjectIdentity virDomainEventGraphicsSubjectIdentity;
typedef virDomainEventGraphicsSubjectIdentity *virDomainEventGraphicsSubjectIdentityPtr;
@@ -4560,10 +4560,10 @@ typedef virDomainEventGraphicsSubject *virDomainEventGraphicsSubjectPtr;
typedef void (*virConnectDomainEventGraphicsCallback)(virConnectPtr conn,
virDomainPtr dom,
int phase,
- virDomainEventGraphicsAddressPtr local,
- virDomainEventGraphicsAddressPtr remote,
+ const virDomainEventGraphicsAddressPtr local,
+ const virDomainEventGraphicsAddressPtr remote,
const char *authScheme,
- virDomainEventGraphicsSubjectPtr subject,
+ const virDomainEventGraphicsSubjectPtr subject,
void *opaque);
/**
diff --git a/include/libvirt/virterror.h b/include/libvirt/virterror.h
index 3864a31b3..cd7e3b31e 100644
--- a/include/libvirt/virterror.h
+++ b/include/libvirt/virterror.h
@@ -313,6 +313,8 @@ void virResetLastError (void);
void virResetError (virErrorPtr err);
void virFreeError (virErrorPtr err);
+const char * virGetLastErrorMessage (void);
+
virErrorPtr virConnGetLastError (virConnectPtr conn);
void virConnResetLastError (virConnectPtr conn);
int virCopyLastError (virErrorPtr to);