summaryrefslogtreecommitdiff
path: root/gnulib
diff options
context:
space:
mode:
authorGuido Günther <agx@sigxcpu.org>2016-06-05 13:12:20 +0200
committerGuido Günther <agx@sigxcpu.org>2016-06-05 13:12:20 +0200
commitca01064235e35db95bfbdbc65fc0ec9d6a99681d (patch)
treec9d4fa7576e05e134a235d541262665cb1f5a6a8 /gnulib
parentd0b310ef8986c26f62a551353c3be435174c474e (diff)
New upstream version 1.3.5
Diffstat (limited to 'gnulib')
-rw-r--r--gnulib/lib/Makefile.in14
-rw-r--r--gnulib/lib/gnulib.mk11
-rw-r--r--gnulib/lib/unsetenv.c (renamed from gnulib/tests/unsetenv.c)8
-rw-r--r--gnulib/tests/Makefile.in10
-rw-r--r--gnulib/tests/gnulib.mk9
5 files changed, 26 insertions, 26 deletions
diff --git a/gnulib/lib/Makefile.in b/gnulib/lib/Makefile.in
index 9d2f8b07a..14fb9e777 100644
--- a/gnulib/lib/Makefile.in
+++ b/gnulib/lib/Makefile.in
@@ -35,7 +35,7 @@
# the same distribution terms as the rest of that program.
#
# Generated by gnulib-tool.
-# Reproduce by: gnulib-tool --import --local-dir=gnulib/local --lib=libgnu --source-base=gnulib/lib --m4-base=m4 --doc-base=doc --tests-base=gnulib/tests --aux-dir=build-aux --with-tests --avoid=pt_chown --avoid=lock-tests --lgpl=2 --makefile-name=gnulib.mk --no-conditional-dependencies --libtool --macro-prefix=gl accept areadlink autobuild base64 bind bitrotate byteswap c-ctype c-strcase c-strcasestr calloc-posix canonicalize-lgpl chown clock-time close configmake connect count-leading-zeros count-one-bits crypto/md5 crypto/sha256 dirname-lgpl environ execinfo fclose fcntl fcntl-h fdatasync ffs ffsl fnmatch fsync func getaddrinfo getcwd-lgpl gethostname getpass getpeername getsockname gettext-h gettimeofday gitlog-to-changelog gnumakefile ignore-value inet_pton intprops ioctl isatty largefile ldexp listen localeconv maintainer-makefile manywarnings mgetgroups mkdtemp mkostemp mkostemps mktempd net_if netdb nonblocking openpty passfd perror physmem pipe-posix pipe2 poll posix-shell pthread pthread_sigmask random_r recv regex sched secure_getenv send setenv setsockopt sigaction sigpipe snprintf socket stat-time stdarg stpcpy strchrnul strdup-posix strerror strerror_r-posix strndup strptime strsep strtok_r sys_stat sys_wait termios time_r timegm ttyname_r uname useless-if-before-free usleep vasprintf vc-list-files verify vsnprintf waitpid warnings
+# Reproduce by: gnulib-tool --import --local-dir=gnulib/local --lib=libgnu --source-base=gnulib/lib --m4-base=m4 --doc-base=doc --tests-base=gnulib/tests --aux-dir=build-aux --with-tests --avoid=pt_chown --avoid=lock-tests --lgpl=2 --makefile-name=gnulib.mk --no-conditional-dependencies --libtool --macro-prefix=gl accept areadlink autobuild base64 bind bitrotate byteswap c-ctype c-strcase c-strcasestr calloc-posix canonicalize-lgpl chown clock-time close configmake connect count-leading-zeros count-one-bits crypto/md5 crypto/sha256 dirname-lgpl environ execinfo fclose fcntl fcntl-h fdatasync ffs ffsl fnmatch fsync func getaddrinfo getcwd-lgpl gethostname getpass getpeername getsockname gettext-h gettimeofday gitlog-to-changelog gnumakefile ignore-value inet_pton intprops ioctl isatty largefile ldexp listen localeconv maintainer-makefile manywarnings mgetgroups mkdtemp mkostemp mkostemps mktempd net_if netdb nonblocking openpty passfd perror physmem pipe-posix pipe2 poll posix-shell pthread pthread_sigmask random_r recv regex sched secure_getenv send setenv setsockopt sigaction sigpipe snprintf socket stat-time stdarg stpcpy strchrnul strdup-posix strerror strerror_r-posix strndup strptime strsep strtok_r sys_stat sys_wait termios time_r timegm ttyname_r uname unsetenv useless-if-before-free usleep vasprintf vc-list-files verify vsnprintf waitpid warnings
VPATH = @srcdir@
am__is_gnu_make = { \
@@ -1917,8 +1917,9 @@ EXTRA_DIST = accept.c w32sock.h alloca.c alloca.in.h allocator.h \
sys_uio.in.h sys_utsname.in.h sys_wait.in.h tempname.h \
termios.in.h $(top_srcdir)/build-aux/config.rpath time.in.h \
time_r.c mktime-internal.h timegm.c ttyname_r.c uname.c \
- unistd.in.h $(top_srcdir)/build-aux/useless-if-before-free \
- usleep.c asnprintf.c float+.h printf-args.c printf-args.h \
+ unistd.in.h unsetenv.c \
+ $(top_srcdir)/build-aux/useless-if-before-free usleep.c \
+ asnprintf.c float+.h printf-args.c printf-args.h \
printf-parse.c printf-parse.h vasnprintf.c vasnprintf.h \
asprintf.c vasprintf.c $(top_srcdir)/build-aux/vc-list-files \
verify.h vsnprintf.c waitpid.c wchar.in.h wcrtomb.c \
@@ -1979,9 +1980,9 @@ EXTRA_libgnu_la_SOURCES = accept.c alloca.c bind.c btowc.c calloc.c \
strcasecmp.c strncasecmp.c strchrnul.c strdup.c strerror.c \
strerror-override.c strerror_r.c strndup.c strnlen.c \
strptime.c strsep.c strtok_r.c time_r.c timegm.c ttyname_r.c \
- uname.c usleep.c asnprintf.c printf-args.c printf-parse.c \
- vasnprintf.c asprintf.c vasprintf.c vsnprintf.c waitpid.c \
- wcrtomb.c
+ uname.c unsetenv.c usleep.c asnprintf.c printf-args.c \
+ printf-parse.c vasnprintf.c asprintf.c vasprintf.c vsnprintf.c \
+ waitpid.c wcrtomb.c
libgnu_la_LDFLAGS = $(AM_LDFLAGS) -no-undefined $(GETADDRINFO_LIB) \
$(GETHOSTNAME_LIB) $(HOSTENT_LIB) $(INET_NTOP_LIB) \
$(INET_PTON_LIB) $(LDEXP_LIBM) $(LIBSOCKET) \
@@ -2226,6 +2227,7 @@ distclean-compile:
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/ttyname_r.Plo@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/uname.Plo@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/unistd.Plo@am__quote@
+@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/unsetenv.Plo@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/usleep.Plo@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/vasnprintf.Plo@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/vasprintf.Plo@am__quote@
diff --git a/gnulib/lib/gnulib.mk b/gnulib/lib/gnulib.mk
index dd8dc7a8a..701d041ff 100644
--- a/gnulib/lib/gnulib.mk
+++ b/gnulib/lib/gnulib.mk
@@ -21,7 +21,7 @@
# the same distribution terms as the rest of that program.
#
# Generated by gnulib-tool.
-# Reproduce by: gnulib-tool --import --local-dir=gnulib/local --lib=libgnu --source-base=gnulib/lib --m4-base=m4 --doc-base=doc --tests-base=gnulib/tests --aux-dir=build-aux --with-tests --avoid=pt_chown --avoid=lock-tests --lgpl=2 --makefile-name=gnulib.mk --no-conditional-dependencies --libtool --macro-prefix=gl accept areadlink autobuild base64 bind bitrotate byteswap c-ctype c-strcase c-strcasestr calloc-posix canonicalize-lgpl chown clock-time close configmake connect count-leading-zeros count-one-bits crypto/md5 crypto/sha256 dirname-lgpl environ execinfo fclose fcntl fcntl-h fdatasync ffs ffsl fnmatch fsync func getaddrinfo getcwd-lgpl gethostname getpass getpeername getsockname gettext-h gettimeofday gitlog-to-changelog gnumakefile ignore-value inet_pton intprops ioctl isatty largefile ldexp listen localeconv maintainer-makefile manywarnings mgetgroups mkdtemp mkostemp mkostemps mktempd net_if netdb nonblocking openpty passfd perror physmem pipe-posix pipe2 poll posix-shell pthread pthread_sigmask random_r recv regex sched secure_getenv send setenv setsockopt sigaction sigpipe snprintf socket stat-time stdarg stpcpy strchrnul strdup-posix strerror strerror_r-posix strndup strptime strsep strtok_r sys_stat sys_wait termios time_r timegm ttyname_r uname useless-if-before-free usleep vasprintf vc-list-files verify vsnprintf waitpid warnings
+# Reproduce by: gnulib-tool --import --local-dir=gnulib/local --lib=libgnu --source-base=gnulib/lib --m4-base=m4 --doc-base=doc --tests-base=gnulib/tests --aux-dir=build-aux --with-tests --avoid=pt_chown --avoid=lock-tests --lgpl=2 --makefile-name=gnulib.mk --no-conditional-dependencies --libtool --macro-prefix=gl accept areadlink autobuild base64 bind bitrotate byteswap c-ctype c-strcase c-strcasestr calloc-posix canonicalize-lgpl chown clock-time close configmake connect count-leading-zeros count-one-bits crypto/md5 crypto/sha256 dirname-lgpl environ execinfo fclose fcntl fcntl-h fdatasync ffs ffsl fnmatch fsync func getaddrinfo getcwd-lgpl gethostname getpass getpeername getsockname gettext-h gettimeofday gitlog-to-changelog gnumakefile ignore-value inet_pton intprops ioctl isatty largefile ldexp listen localeconv maintainer-makefile manywarnings mgetgroups mkdtemp mkostemp mkostemps mktempd net_if netdb nonblocking openpty passfd perror physmem pipe-posix pipe2 poll posix-shell pthread pthread_sigmask random_r recv regex sched secure_getenv send setenv setsockopt sigaction sigpipe snprintf socket stat-time stdarg stpcpy strchrnul strdup-posix strerror strerror_r-posix strndup strptime strsep strtok_r sys_stat sys_wait termios time_r timegm ttyname_r uname unsetenv useless-if-before-free usleep vasprintf vc-list-files verify vsnprintf waitpid warnings
MOSTLYCLEANFILES += core *.stackdump
@@ -3151,6 +3151,15 @@ EXTRA_DIST += unistd.in.h
## end gnulib module unistd
+## begin gnulib module unsetenv
+
+
+EXTRA_DIST += unsetenv.c
+
+EXTRA_libgnu_la_SOURCES += unsetenv.c
+
+## end gnulib module unsetenv
+
## begin gnulib module useless-if-before-free
diff --git a/gnulib/tests/unsetenv.c b/gnulib/lib/unsetenv.c
index 836874475..306b6484f 100644
--- a/gnulib/tests/unsetenv.c
+++ b/gnulib/lib/unsetenv.c
@@ -2,16 +2,16 @@
This file is part of the GNU C Library.
This program is free software: you can redistribute it and/or modify
- it under the terms of the GNU General Public License as published by
- the Free Software Foundation; either version 3 of the License, or
+ it under the terms of the GNU Lesser General Public License as published by
+ the Free Software Foundation; either version 2.1 of the License, or
(at your option) any later version.
This program is distributed in the hope that it will be useful,
but WITHOUT ANY WARRANTY; without even the implied warranty of
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- GNU General Public License for more details.
+ GNU Lesser General Public License for more details.
- You should have received a copy of the GNU General Public License
+ You should have received a copy of the GNU Lesser General Public License
along with this program. If not, see <http://www.gnu.org/licenses/>. */
/* Don't use __attribute__ __nonnull__ in this compilation unit. Otherwise gcc
diff --git a/gnulib/tests/Makefile.in b/gnulib/tests/Makefile.in
index b43ae2ffa..e9f5e41c1 100644
--- a/gnulib/tests/Makefile.in
+++ b/gnulib/tests/Makefile.in
@@ -3501,9 +3501,9 @@ EXTRA_DIST = test-accept.c signature.h macros.h test-alloca-opt.c \
test-init.sh test-thread_self.c test-thread_create.c macros.h \
test-time.c test-ttyname_r.c signature.h macros.h test-uname.c \
signature.h macros.h test-unistd.c unlockpt.c test-unlockpt.c \
- signature.h macros.h unsetenv.c test-unsetenv.c signature.h \
- macros.h test-usleep.c signature.h macros.h test-vasnprintf.c \
- macros.h test-vasprintf.c signature.h macros.h \
+ signature.h macros.h test-unsetenv.c signature.h macros.h \
+ test-usleep.c signature.h macros.h test-vasnprintf.c macros.h \
+ test-vasprintf.c signature.h macros.h \
test-vc-list-files-git.sh test-vc-list-files-cvs.sh \
test-verify.c test-verify.sh test-vsnprintf.c signature.h \
macros.h test-wchar.c test-wcrtomb.sh test-wcrtomb.c \
@@ -3568,8 +3568,7 @@ EXTRA_libtests_a_SOURCES = dup.c error.c fdopen.c ftruncate.c \
spawn_faction_init.c spawnattr_destroy.c spawnattr_init.c \
spawnattr_setflags.c spawnattr_setsigmask.c spawnp.c ptsname.c \
ptsname_r.c putenv.c read.c setlocale.c signbitd.c signbitf.c \
- signbitl.c symlink.c unlockpt.c unsetenv.c wctob.c wctomb.c \
- write.c
+ signbitl.c symlink.c unlockpt.c wctob.c wctomb.c write.c
AM_LIBTOOLFLAGS = --preserve-dup-deps
test_accept_LDADD = $(LDADD) @LIBSOCKET@
test_bind_LDADD = $(LDADD) @LIBSOCKET@ $(INET_PTON_LIB)
@@ -4711,7 +4710,6 @@ distclean-compile:
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/test-write.Po@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/test-xalloc-die.Po@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/unlockpt.Po@am__quote@
-@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/unsetenv.Po@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/wait-process.Po@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/wctob.Po@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/wctomb.Po@am__quote@
diff --git a/gnulib/tests/gnulib.mk b/gnulib/tests/gnulib.mk
index 02641f04d..7b60efbb3 100644
--- a/gnulib/tests/gnulib.mk
+++ b/gnulib/tests/gnulib.mk
@@ -2320,15 +2320,6 @@ EXTRA_DIST += test-unlockpt.c signature.h macros.h
## end gnulib module unlockpt-tests
-## begin gnulib module unsetenv
-
-
-EXTRA_DIST += unsetenv.c
-
-EXTRA_libtests_a_SOURCES += unsetenv.c
-
-## end gnulib module unsetenv
-
## begin gnulib module unsetenv-tests
GNULIB_TESTS += test-unsetenv