summaryrefslogtreecommitdiff
path: root/daemon
diff options
context:
space:
mode:
authorGuido Günther <agx@sigxcpu.org>2013-10-01 13:18:55 +0200
committerGuido Günther <agx@sigxcpu.org>2013-10-01 13:18:55 +0200
commit6ec841fadc026efa7f358e93929fa4884af6264c (patch)
tree519623eea9b71d5992e16f17da544847696f0b61 /daemon
parent20cacffd38862928f8fb3e53b99369d67bcda7df (diff)
New upstream version 1.1.3
Diffstat (limited to 'daemon')
-rw-r--r--daemon/Makefile.am1
-rw-r--r--daemon/Makefile.in1
-rw-r--r--daemon/remote.c6
-rw-r--r--daemon/stream.c2
4 files changed, 9 insertions, 1 deletions
diff --git a/daemon/Makefile.am b/daemon/Makefile.am
index eb58de92d..46c766c00 100644
--- a/daemon/Makefile.am
+++ b/daemon/Makefile.am
@@ -100,6 +100,7 @@ noinst_LTLIBRARIES = libvirtd_conf.la
libvirtd_conf_la_SOURCES = $(LIBVIRTD_CONF_SOURCES)
libvirtd_conf_la_CFLAGS = \
$(LIBXML_CFLAGS) \
+ $(XDR_CFLAGS) \
$(WARN_CFLAGS) $(PIE_CFLAGS) \
$(COVERAGE_CFLAGS) \
$(NULL)
diff --git a/daemon/Makefile.in b/daemon/Makefile.in
index cd4fabc2e..12b5ed15d 100644
--- a/daemon/Makefile.in
+++ b/daemon/Makefile.in
@@ -1999,6 +1999,7 @@ QEMU_PROTOCOL = $(top_srcdir)/src/remote/qemu_protocol.x
@WITH_LIBVIRTD_TRUE@libvirtd_conf_la_SOURCES = $(LIBVIRTD_CONF_SOURCES)
@WITH_LIBVIRTD_TRUE@libvirtd_conf_la_CFLAGS = \
@WITH_LIBVIRTD_TRUE@ $(LIBXML_CFLAGS) \
+@WITH_LIBVIRTD_TRUE@ $(XDR_CFLAGS) \
@WITH_LIBVIRTD_TRUE@ $(WARN_CFLAGS) $(PIE_CFLAGS) \
@WITH_LIBVIRTD_TRUE@ $(COVERAGE_CFLAGS) \
@WITH_LIBVIRTD_TRUE@ $(NULL)
diff --git a/daemon/remote.c b/daemon/remote.c
index 9497cc131..f3de6a0ad 100644
--- a/daemon/remote.c
+++ b/daemon/remote.c
@@ -666,8 +666,11 @@ void remoteClientFreeFunc(void *data)
/* Deregister event delivery callback */
if (priv->conn) {
+ virIdentityPtr sysident = virIdentityGetSystem();
size_t i;
+ virIdentitySetCurrent(sysident);
+
for (i = 0; i < VIR_DOMAIN_EVENT_ID_LAST; i++) {
if (priv->domainEventCallbackID[i] != -1) {
VIR_DEBUG("Deregistering to relay remote events %zu", i);
@@ -678,6 +681,9 @@ void remoteClientFreeFunc(void *data)
}
virConnectClose(priv->conn);
+
+ virIdentitySetCurrent(NULL);
+ virObjectUnref(sysident);
}
VIR_FREE(priv);
diff --git a/daemon/stream.c b/daemon/stream.c
index 87dfaf575..9e36e8a9f 100644
--- a/daemon/stream.c
+++ b/daemon/stream.c
@@ -708,7 +708,7 @@ daemonStreamHandleRead(virNetServerClientPtr client,
daemonClientStream *stream)
{
char *buffer;
- size_t bufferLen = VIR_NET_MESSAGE_PAYLOAD_MAX;
+ size_t bufferLen = VIR_NET_MESSAGE_LEGACY_PAYLOAD_MAX;
int ret;
VIR_DEBUG("client=%p, stream=%p tx=%d closed=%d",