summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGuido Günther <agx@sigxcpu.org>2014-08-30 22:57:20 +0200
committerGuido Günther <agx@sigxcpu.org>2014-08-30 22:57:20 +0200
commitdaa5c92375d7b0cd0b16b3bd316fc29a191c6e29 (patch)
treed0181c0fc183162dd2e0e475c2f20578689195e8 /configure.ac
parent65e69d34a2be25051a24faf350e9f9d84ef79f6b (diff)
New upstream version 1.2.8~rc2
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac50
1 files changed, 48 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index f37c716ae..f93c6c239 100644
--- a/configure.ac
+++ b/configure.ac
@@ -16,7 +16,7 @@ dnl You should have received a copy of the GNU Lesser General Public
dnl License along with this library. If not, see
dnl <http://www.gnu.org/licenses/>.
-AC_INIT([libvirt], [1.2.7], [libvir-list@redhat.com], [], [http://libvirt.org])
+AC_INIT([libvirt], [1.2.8], [libvir-list@redhat.com], [], [http://libvirt.org])
AC_CONFIG_SRCDIR([src/libvirt.c])
AC_CONFIG_AUX_DIR([build-aux])
AC_CONFIG_HEADERS([config.h])
@@ -967,7 +967,7 @@ AM_CONDITIONAL([WITH_XEN], [test "$with_xen" = "yes"])
AC_SUBST([XEN_CFLAGS])
AC_SUBST([XEN_LIBS])
-AM_CONDITIONAL([WITH_XENXS], [test "$with_libxl" = "yes" || test "$with_xen" = "yes"])
+AM_CONDITIONAL([WITH_XENCONFIG], [test "$with_libxl" = "yes" || test "$with_xen" = "yes"])
dnl
dnl check for kernel headers required by xen_inotify
@@ -1734,6 +1734,10 @@ AC_ARG_WITH([storage-gluster],
[AS_HELP_STRING([--with-storage-gluster],
[with Gluster backend for the storage driver @<:@default=check@:>@])],
[],[with_storage_gluster=check])
+AC_ARG_WITH([storage-zfs],
+ [AS_HELP_STRING([--with-storage-zfs],
+ [with ZFS backend for the storage driver @<:@default=check@:>@])],
+ [],[with_storage_zfs=check])
if test "$with_libvirtd" = "no"; then
with_storage_dir=no
@@ -1746,6 +1750,7 @@ if test "$with_libvirtd" = "no"; then
with_storage_rbd=no
with_storage_sheepdog=no
with_storage_gluster=no
+ with_storage_zfs=no
fi
if test "$with_storage_dir" = "yes" ; then
AC_DEFINE_UNQUOTED([WITH_STORAGE_DIR], 1, [whether directory backend for storage driver is enabled])
@@ -1963,6 +1968,43 @@ if test "$with_storage_gluster" = "yes"; then
fi
AM_CONDITIONAL([WITH_STORAGE_GLUSTER], [test "$with_storage_gluster" = "yes"])
+if test "$with_storage_zfs" = "check"; then
+ with_storage_zfs=$with_freebsd
+fi
+
+if test "$with_storage_zfs" = "yes" && test "$with_freebsd" = "no"; then
+ AC_MSG_ERROR([The ZFS storage driver can be enabled on FreeBSD only.])
+fi
+
+if test "$with_storage_zfs" = "yes" ||
+ test "$with_storage_zfs" = "check"; then
+ AC_PATH_PROG([ZFS], [zfs], [], [$PATH:/sbin:/usr/sbin])
+ AC_PATH_PROG([ZPOOL], [zpool], [], [$PATH:/sbin:/usr/sbin])
+
+ if test "$with_storage_zfs" = "yes"; then
+ if test -z "$ZFS" || test -z "$ZPOOL"; then
+ AC_MSG_ERROR([We need zfs and zpool for ZFS storage driver])
+ fi
+ else
+ if test -z "$ZFS" || test -z "$ZPOOL"; then
+ with_storage_zfs=no
+ fi
+
+ if test "$with_storage_zfs" = "check"; then
+ with_storage_zfs=yes
+ fi
+ fi
+
+ if test "$with_storage_zfs" = "yes"; then
+ AC_DEFINE_UNQUOTED([WITH_STORAGE_ZFS], 1,
+ [whether ZFS backend for storage driver is enabled])
+ AC_DEFINE_UNQUOTED([ZFS], ["$ZFS"], [Location of zfs program])
+ AC_DEFINE_UNQUOTED([ZPOOL], ["$ZPOOL"], [Location of zpool program])
+ fi
+fi
+AM_CONDITIONAL([WITH_STORAGE_ZFS],
+ [test "$with_storage_zfs" = "yes"])
+
if test "$with_storage_fs" = "yes" ||
test "$with_storage_gluster" = "yes"; then
AC_PATH_PROG([GLUSTER_CLI], [gluster], [], [$PATH:/sbin:/usr/sbin])
@@ -2131,6 +2173,9 @@ AM_CONDITIONAL([WITH_HYPERV], [test "$with_hyperv" = "yes"])
dnl Allow perl/python overrides
AC_PATH_PROGS([PYTHON], [python2 python])
AC_PATH_PROG([PERL], [perl])
+if test -z "$PERL"; then
+ AC_MSG_ERROR([Failed to find perl.])
+fi
AC_ARG_WITH([test-suite],
[AS_HELP_STRING([--with-test-suite],
@@ -2806,6 +2851,7 @@ AC_MSG_NOTICE([ Disk: $with_storage_disk])
AC_MSG_NOTICE([ RBD: $with_storage_rbd])
AC_MSG_NOTICE([Sheepdog: $with_storage_sheepdog])
AC_MSG_NOTICE([ Gluster: $with_storage_gluster])
+AC_MSG_NOTICE([ ZFS: $with_storage_zfs])
AC_MSG_NOTICE([])
AC_MSG_NOTICE([Security Drivers])
AC_MSG_NOTICE([])