summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGuido Günther <agx@sigxcpu.org>2013-07-01 23:27:12 +0200
committerGuido Günther <agx@sigxcpu.org>2013-07-01 23:27:12 +0200
commit985164b3f9a6e58010385eb5fb3cdbc9d8565468 (patch)
treee53c02caca01bf243fd83c35728d0d96d82a0c7b /configure.ac
parent3a2c75c79b9650a7a8ecf0f80fc8caaf68d2693d (diff)
New upstream version 1.1.0
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 12 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 5d1bc6b0a..a6ad6a3ed 100644
--- a/configure.ac
+++ b/configure.ac
@@ -16,7 +16,7 @@ dnl You should have received a copy of the GNU Lesser General Public
dnl License along with this library. If not, see
dnl <http://www.gnu.org/licenses/>.
-AC_INIT([libvirt], [1.0.6], [libvir-list@redhat.com], [], [http://libvirt.org])
+AC_INIT([libvirt], [1.1.0], [libvir-list@redhat.com], [], [http://libvirt.org])
AC_CONFIG_SRCDIR([src/libvirt.c])
AC_CONFIG_AUX_DIR([build-aux])
AC_CONFIG_HEADERS([config.h])
@@ -318,8 +318,6 @@ AC_PATH_PROG([DNSMASQ], [dnsmasq], [dnsmasq],
[/sbin:/usr/sbin:/usr/local/sbin:$PATH])
AC_PATH_PROG([RADVD], [radvd], [radvd],
[/sbin:/usr/sbin:/usr/local/sbin:$PATH])
-AC_PATH_PROG([BRCTL], [brctl], [brctl],
- [/sbin:/usr/sbin:/usr/local/sbin:$PATH])
AC_PATH_PROG([TC], [tc], [tc],
[/sbin:/usr/sbin:/usr/local/sbin:$PATH])
AC_PATH_PROG([UDEVADM], [udevadm], [],
@@ -2401,6 +2399,17 @@ AC_CHECK_DECLS([link_addr],
#include <net/if_dl.h>
])
+# Check for BSD approach for bridge management
+AC_CHECK_DECLS([BRDGSFD, BRDGADD, BRDGDEL],
+ [AC_DEFINE([HAVE_BSD_BRIDGE_MGMT],
+ [1],
+ [whether BSD style bridge management is available])],
+ [],
+ [#include <net/if.h>
+ #include <net/ethernet.h>
+ #include <net/if_bridgevar.h>
+ ])
+
# Detect when running under the clang static analyzer's scan-build driver
# or Coverity-prevent's cov-build. Define STATIC_ANALYSIS accordingly.
AC_CACHE_CHECK([whether this build is done by a static analysis tool],