summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGuido Günther <agx@sigxcpu.org>2014-09-30 19:28:00 +0200
committerGuido Günther <agx@sigxcpu.org>2014-09-30 19:28:00 +0200
commit8707039d5fcb05230d3ad5b21de4113ccf86cf1c (patch)
tree7cf3e7847d0ff1ecbfdcc1d10a77406159a9ee84 /configure.ac
parent063cc84dcfb5112e1e1ead25123fe13a6f0ac201 (diff)
New upstream version 1.2.9~rc2
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 13 insertions, 11 deletions
diff --git a/configure.ac b/configure.ac
index b4fb99a0d..0062d5dda 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1046,19 +1046,21 @@ dnl
dnl Checks for the Parallels driver
dnl
-if test "$with_parallels" = "check"; then
- with_parallels=$with_linux
- if test ! $host_cpu = 'x86_64'; then
- with_parallels=no
- fi
-fi
-if test "$with_parallels" = "yes" && test "$with_linux" = "no"; then
- AC_MSG_ERROR([The Parallels driver can be enabled on Linux only.])
-fi
+if test "$with_parallels" = "yes" ||
+ test "$with_parallels" = "check"; then
+ PKG_CHECK_MODULES([PARALLELS_SDK], [parallels-sdk],
+ [PARALLELS_SDK_FOUND=yes], [PARALLELS_SDK_FOUND=no])
-if test "$with_parallels" = "yes"; then
- AC_DEFINE_UNQUOTED([WITH_PARALLELS], 1, [whether Parallels driver is enabled])
+ if test "$with_parallels" = "yes" && test "$PARALLELS_SDK_FOUND" = "no"; then
+ AC_MSG_ERROR([Parallels Virtualization SDK is needed to build the Parallels driver.])
+ fi
+
+ with_parallels=$PARALLELS_SDK_FOUND
+ if test "$with_parallels" = "yes"; then
+ AC_DEFINE_UNQUOTED([WITH_PARALLELS], 1,
+ [whether Parallels driver is enabled])
+ fi
fi
AM_CONDITIONAL([WITH_PARALLELS], [test "$with_parallels" = "yes"])