summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGuido Günther <agx@sigxcpu.org>2011-11-01 18:49:31 +0100
committerGuido Günther <agx@sigxcpu.org>2011-11-01 18:49:31 +0100
commit6dba3c4e6479cc4cd2a6ba87e4375c94758d3818 (patch)
tree74d519cdf8c0669c8b783edfe43968bf7809b421 /configure.ac
parent828e4e35ea0634994eb27dc511799193068c9714 (diff)
New upstream version 0.9.7~rc1
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 4 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index df1944597..2aaed41f7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3,7 +3,7 @@ dnl Process this file with autoconf to produce a configure script.
dnl Copyright (C) 2005-2011 Red Hat, Inc.
dnl See COPYING.LIB for the License of this software
-AC_INIT([libvirt], [0.9.6], [libvir-list@redhat.com], [], [http://libvirt.org])
+AC_INIT([libvirt], [0.9.7], [libvir-list@redhat.com], [], [http://libvirt.org])
AC_CONFIG_SRCDIR([src/libvirt.c])
AC_CONFIG_AUX_DIR([build-aux])
AC_CONFIG_HEADERS([config.h])
@@ -135,12 +135,9 @@ AC_CHECK_SIZEOF([long])
dnl Availability of various common functions (non-fatal if missing),
dnl and various less common threadsafe functions
-AC_CHECK_FUNCS_ONCE([cfmakeraw fdatasync geteuid getgid getgrnam_r getmntent_r \
+AC_CHECK_FUNCS_ONCE([cfmakeraw geteuid getgid getgrnam_r getmntent_r \
getpwuid_r getuid initgroups kill mmap posix_fallocate posix_memalign \
regexec sched_getaffinity])
-if test $ac_cv_func_fdatasync = no; then
- AC_DEFINE([fdatasync], [fsync], [Define to fsync if you lack fdatasync])
-fi
dnl Availability of pthread functions (if missing, win32 threading is
dnl assumed). Because of $LIB_PTHREAD, we cannot use AC_CHECK_FUNCS_ONCE.
@@ -690,8 +687,9 @@ fi
if test "$with_lxc" = "yes" || test "$with_lxc" = "check"; then
AC_TRY_LINK([
#include <sched.h>
+ #include <linux/loop.h>
], [
- unshare (1);
+ unshare (!LO_FLAGS_AUTOCLEAR);
], [
with_lxc=yes
], [