summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGuido Günther <agx@sigxcpu.org>2013-09-26 12:17:15 +0200
committerGuido Günther <agx@sigxcpu.org>2013-09-26 12:17:15 +0200
commit20cacffd38862928f8fb3e53b99369d67bcda7df (patch)
tree7d9a0b0c18474f859afdd79302a48b7ff95e554d /configure.ac
parent7b8d517a7feb2a54cbf5ba2a5f1aa4e3a4a6ffcd (diff)
New upstream version 1.1.3~rc1
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac383
1 files changed, 253 insertions, 130 deletions
diff --git a/configure.ac b/configure.ac
index f853e0303..f168f894c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -16,13 +16,14 @@ dnl You should have received a copy of the GNU Lesser General Public
dnl License along with this library. If not, see
dnl <http://www.gnu.org/licenses/>.
-AC_INIT([libvirt], [1.1.2], [libvir-list@redhat.com], [], [http://libvirt.org])
+AC_INIT([libvirt], [1.1.3], [libvir-list@redhat.com], [], [http://libvirt.org])
AC_CONFIG_SRCDIR([src/libvirt.c])
AC_CONFIG_AUX_DIR([build-aux])
AC_CONFIG_HEADERS([config.h])
AC_CONFIG_MACRO_DIR([m4])
-dnl Make automake keep quiet about wildcards & other GNUmake-isms
-AM_INIT_AUTOMAKE([-Wno-portability tar-ustar])
+dnl Make automake keep quiet about wildcards & other GNUmake-isms; also keep
+dnl quiet about the fact that we intentionally cater to automake 1.9
+AM_INIT_AUTOMAKE([-Wno-portability -Wno-obsolete tar-ustar subdir-objects])
AM_MAINTAINER_MODE([enable])
# Maintainer note - comment this line out if you plan to rerun
@@ -30,9 +31,11 @@ AM_MAINTAINER_MODE([enable])
# Leave it uncommented for normal releases, for faster ./configure.
gl_ASSERT_NO_GNULIB_POSIXCHECK
-# Use the silent-rules feature when possible.
-m4_ifndef([AM_SILENT_RULES], [m4_define([AM_SILENT_RULES],[])])
-AM_SILENT_RULES([yes])
+# Default to using the silent-rules feature when possible. Formatting
+# chosen to bypass 'grep' checks that cause older automake to warn.
+# Users (include rpm) can still change the default at configure time.
+m4_ifndef([AM_SILENT_RULES],
+ [m4_define([AM_SILENT_RULES],[])])AM_SILENT_RULES([yes])
AC_CANONICAL_HOST
@@ -157,6 +160,50 @@ VERSION_SCRIPT_FLAGS=-Wl,--version-script=
VERSION_SCRIPT_FLAGS="-Wl,-M -Wl,"
AC_MSG_RESULT([$VERSION_SCRIPT_FLAGS])
+dnl Specify if we rely on ifconfig instead of iproute2 (e.g. in case
+dnl we're working on BSD)
+want_ifconfig=no
+
+dnl Make some notes about which OS we're compiling for, as the lxc and qemu
+dnl drivers require linux headers, and storage_mpath, dtrace, and nwfilter
+dnl are also linux specific. The "network" and storage_fs drivers are known
+dnl to not work on MacOS X presently, so we also make a note if compiling
+dnl for that
+
+with_linux=no with_osx=no with_freebsd=no
+case $host in
+ *-*-linux*) with_linux=yes ;;
+ *-*-darwin*) with_osx=yes ;;
+ *-*-freebsd*) with_freebsd=yes ;;
+esac
+
+if test $with_linux = no; then
+ if test "x$with_lxc" != xyes
+ then
+ with_lxc=no
+ fi
+ with_dtrace=no
+fi
+
+if test $with_freebsd = yes; then
+ want_ifconfig=yes
+
+ with_firewalld=no
+fi
+
+if test $with_osx = yes; then
+ with_qemu=no
+fi
+
+AM_CONDITIONAL([WITH_LINUX], [test "$with_linux" = "yes"])
+AM_CONDITIONAL([WITH_FREEBSD], [test "$with_freebsd" = "yes"])
+
+if test "$with_libvirtd" = "no" ; then
+ with_qemu=no
+fi
+
+# Check for compiler and library settings.
+
LIBVIRT_COMPILE_WARNINGS
LIBVIRT_COMPILE_PIE
LIBVIRT_LINKER_RELRO
@@ -358,11 +405,11 @@ AC_DEFINE_UNQUOTED([SCRUB],["$SCRUB"],
[Location or name of the scrub program (for wiping algorithms)])
dnl Specific dir for HTML output ?
-AC_ARG_WITH([html-dir], [AC_HELP_STRING([--with-html-dir=path],
+AC_ARG_WITH([html-dir], [AS_HELP_STRING([--with-html-dir=path],
[path to base html directory, default $datadir/doc/html])],
[HTML_DIR=$withval], [HTML_DIR='$(datadir)/doc'])
-AC_ARG_WITH([html-subdir], [AC_HELP_STRING([--with-html-subdir=path],
+AC_ARG_WITH([html-subdir], [AS_HELP_STRING([--with-html-subdir=path],
[directory used under html-dir, default $PACKAGE-$VERSION/html])],
[test "x$withval" != "x" && HTML_DIR="$HTML_DIR/$withval"],
[HTML_DIR="$HTML_DIR/\$(PACKAGE)-\$(VERSION)/html"])
@@ -370,7 +417,7 @@ AC_SUBST([HTML_DIR])
dnl Specific XML catalog file for validation of generated html
AC_ARG_WITH([xml-catalog-file],
- [AC_HELP_STRING([--with-xml-catalog-file=path],
+ [AS_HELP_STRING([--with-xml-catalog-file=path],
[path to XML catalog file for validating
generated html, default /etc/xml/catalog])],
[XML_CATALOG_FILE=$withval],
@@ -388,87 +435,80 @@ if test "$prefix" = "/usr" && test "$sysconfdir" = '${prefix}/etc' ; then
sysconfdir='/etc'
fi
-dnl Specify if we rely on ifconfig instead of iproute2 (e.g. in case
-dnl we're working on BSD)
-want_ifconfig=no
-
-dnl Make some notes about which OS we're compiling for, as the lxc and qemu
-dnl drivers require linux headers, and storage_mpath, dtrace, and nwfilter
-dnl are also linux specific. The "network" and storage_fs drivers are known
-dnl to not work on MacOS X presently, so we also make a note if compiling
-dnl for that
-
-with_linux=no with_osx=no with_freebsd=no
-case $host in
- *-*-linux*) with_linux=yes ;;
- *-*-darwin*) with_osx=yes ;;
- *-*-freebsd*) with_freebsd=yes ;;
-esac
-
-if test $with_linux = no; then
- if test "x$with_lxc" != xyes
- then
- with_lxc=no
- fi
- with_dtrace=no
-fi
-
-if test $with_freebsd = yes; then
- want_ifconfig=yes
-
- with_firewalld=no
-fi
-
-if test $with_osx = yes; then
- with_qemu=no
-fi
-
-AM_CONDITIONAL([WITH_LINUX], [test "$with_linux" = "yes"])
-AM_CONDITIONAL([WITH_FREEBSD], [test "$with_freebsd" = "yes"])
-
dnl Allow to build without Xen, QEMU/KVM, test or remote driver
AC_ARG_WITH([xen],
- AC_HELP_STRING([--with-xen], [add XEN support @<:@default=check@:>@]),[],[with_xen=check])
+ [AS_HELP_STRING([--with-xen],
+ [add XEN support @<:@default=check@:>@])])
+m4_divert_text([DEFAULTS], [with_xen=check])
AC_ARG_WITH([xen-inotify],
- AC_HELP_STRING([--with-xen-inotify], [add XEN inotify support @<:@default=check@:>@]),[],[with_xen_inotify=check])
+ [AS_HELP_STRING([--with-xen-inotify],
+ [add XEN inotify support @<:@default=check@:>@])])
+m4_divert_text([DEFAULTS], [with_xen_inotify=check])
AC_ARG_WITH([qemu],
- AC_HELP_STRING([--with-qemu], [add QEMU/KVM support @<:@default=yes@:>@]),[],[with_qemu=yes])
+ [AS_HELP_STRING([--with-qemu],
+ [add QEMU/KVM support @<:@default=yes@:>@])])
+m4_divert_text([DEFAULTS], [with_qemu=yes])
AC_ARG_WITH([uml],
- AC_HELP_STRING([--with-uml], [add UML support @<:@default=check@:>@]),[],[with_uml=check])
+ [AS_HELP_STRING([--with-uml],
+ [add UML support @<:@default=check@:>@])])
+m4_divert_text([DEFAULTS], [with_uml=check])
AC_ARG_WITH([openvz],
- AC_HELP_STRING([--with-openvz], [add OpenVZ support @<:@default=check@:>@]),[],[with_openvz=check])
+ [AS_HELP_STRING([--with-openvz],
+ [add OpenVZ support @<:@default=check@:>@])])
+m4_divert_text([DEFAULTS], [with_openvz=check])
AC_ARG_WITH([vmware],
- AC_HELP_STRING([--with-vmware], [add VMware support @<:@default=yes@:>@]),[],[with_vmware=yes])
+ [AS_HELP_STRING([--with-vmware],
+ [add VMware support @<:@default=yes@:>@])])
+m4_divert_text([DEFAULTS], [with_vmware=yes])
AC_ARG_WITH([phyp],
- AC_HELP_STRING([--with-phyp], [add PHYP support @<:@default=check@:>@]),[],[with_phyp=check])
+ [AS_HELP_STRING([--with-phyp],
+ [add PHYP support @<:@default=check@:>@])])
+m4_divert_text([DEFAULTS], [with_phyp=check])
AC_ARG_WITH([xenapi],
- AC_HELP_STRING([--with-xenapi], [add XenAPI support @<:@default=check@:>@]),[],[with_xenapi=check])
+ [AS_HELP_STRING([--with-xenapi],
+ [add XenAPI support @<:@default=check@:>@])])
+m4_divert_text([DEFAULTS], [with_xenapi=check])
AC_ARG_WITH([libxl],
- AC_HELP_STRING([--with-libxl], [add libxenlight support @<:@default=check@:>@]),[],[with_libxl=check])
+ [AS_HELP_STRING([--with-libxl],
+ [add libxenlight support @<:@default=check@:>@])])
+m4_divert_text([DEFAULTS], [with_libxl=check])
AC_ARG_WITH([vbox],
- AC_HELP_STRING([--with-vbox=@<:@PFX@:>@],
- [VirtualBox XPCOMC location @<:@default=yes@:>@]),[],
- [with_vbox=yes])
+ [AS_HELP_STRING([--with-vbox=@<:@PFX@:>@],
+ [VirtualBox XPCOMC location @<:@default=yes@:>@])])
+m4_divert_text([DEFAULTS], [with_vbox=yes])
AC_ARG_WITH([lxc],
- AC_HELP_STRING([--with-lxc], [add Linux Container support @<:@default=check@:>@]),[],[with_lxc=check])
+ [AS_HELP_STRING([--with-lxc],
+ [add Linux Container support @<:@default=check@:>@])])
+m4_divert_text([DEFAULTS], [with_lxc=check])
AC_ARG_WITH([esx],
- AC_HELP_STRING([--with-esx], [add ESX support @<:@default=check@:>@]),[],[with_esx=check])
+ [AS_HELP_STRING([--with-esx],
+ [add ESX support @<:@default=check@:>@])])
+m4_divert_text([DEFAULTS], [with_esx=check])
AC_ARG_WITH([hyperv],
- AC_HELP_STRING([--with-hyperv], [add Hyper-V support @<:@default=check@:>@]),[],[with_hyperv=check])
+ [AS_HELP_STRING([--with-hyperv],
+ [add Hyper-V support @<:@default=check@:>@])])
+m4_divert_text([DEFAULTS], [with_hyperv=check])
AC_ARG_WITH([parallels],
- AC_HELP_STRING([--with-parallels], [add Parallels Cloud Server support @<:@default=check@:>@]),[],[with_parallels=check])
+ [AS_HELP_STRING([--with-parallels],
+ [add Parallels Cloud Server support @<:@default=check@:>@])])
+m4_divert_text([DEFAULTS], [with_parallels=check])
AC_ARG_WITH([test],
- AC_HELP_STRING([--with-test], [add test driver support @<:@default=yes@:>@]),[],[with_test=yes])
+ [AS_HELP_STRING([--with-test],
+ [add test driver support @<:@default=yes@:>@])])
+m4_divert_text([DEFAULTS], [with_test=yes])
AC_ARG_WITH([remote],
- AC_HELP_STRING([--with-remote], [add remote driver support @<:@default=yes@:>@]),[],[with_remote=yes])
+ [AS_HELP_STRING([--with-remote],
+ [add remote driver support @<:@default=yes@:>@])])
+m4_divert_text([DEFAULTS], [with_remote=yes])
AC_ARG_WITH([libvirtd],
- AC_HELP_STRING([--with-libvirtd], [add libvirtd support @<:@default=yes@:>@]),[],[with_libvirtd=yes])
+ [AS_HELP_STRING([--with-libvirtd],
+ [add libvirtd support @<:@default=yes@:>@])])
+m4_divert_text([DEFAULTS], [with_libvirtd=yes])
AC_ARG_WITH([chrdev-lock-files],
- AC_HELP_STRING([--with-chrdev-lock-files],
- [location for UUCP style lock files for character devices
- (use auto for default paths on some platforms)
- @<:@default=auto@:>@]),
- [],[with_chrdev_lock_files=auto])
+ [AS_HELP_STRING([--with-chrdev-lock-files],
+ [location for UUCP style lock files for character devices
+ (use auto for default paths on some platforms) @<:@default=auto@:>@])])
+m4_divert_text([DEFAULTS], [with_chrdev_lock_files=auto])
dnl
dnl in case someone want to build static binaries
@@ -479,8 +519,9 @@ AC_SUBST([STATIC_BINARIES])
dnl --enable-debug=(yes|no)
AC_ARG_ENABLE([debug],
- [AC_HELP_STRING([--enable-debug=@<:@no|yes@:>@],
- [enable debugging output @<:@default=yes@:>@])],[],[enable_debug=yes])
+ [AS_HELP_STRING([--enable-debug=@<:@no|yes@:>@],
+ [enable debugging output @<:@default=yes@:>@])],
+ [],[enable_debug=yes])
AM_CONDITIONAL([ENABLE_DEBUG], test x"$enable_debug" = x"yes")
if test x"$enable_debug" = x"yes"; then
AC_DEFINE([ENABLE_DEBUG], [], [whether debugging is enabled])
@@ -493,9 +534,10 @@ dnl init script flavor
dnl
AC_MSG_CHECKING([for init script flavor])
AC_ARG_WITH([init-script],
- [AC_HELP_STRING([--with-init-script@<:@=STYLE@:>@],
- [Style of init script to install: redhat, systemd, systemd+redhat,
- upstart, check, none @<:@default=check@:>@])],[],[with_init_script=check])
+ [AS_HELP_STRING([--with-init-script@<:@=STYLE@:>@],
+ [Style of init script to install: redhat, systemd, systemd+redhat,
+ upstart, check, none @<:@default=check@:>@])],
+ [],[with_init_script=check])
init_redhat=no
init_systemd=no
init_upstart=no
@@ -533,9 +575,9 @@ AC_MSG_RESULT($with_init_script)
AC_MSG_CHECKING([for whether to install sysctl config])
AC_ARG_WITH([sysctl],
- [AC_HELP_STRING([--with-sysctl@<:@=yes/no@:>@],
- [Whether to install sysctl configs @<:@default=check@:>@])],
- [],[with_sysctl=check])
+ [AS_HELP_STRING([--with-sysctl@<:@=yes/no@:>@],
+ [Whether to install sysctl configs @<:@default=check@:>@])],
+ [],[with_sysctl=check])
if test "$with_sysctl" = "yes" || test "$with_sysctl" = "check"
then
@@ -557,7 +599,7 @@ AC_MSG_RESULT($with_sysctl)
dnl RHEL-5 has a peculiar version of Xen, which requires some special casing
AC_ARG_WITH([rhel5-api],
- [AC_HELP_STRING([--with-rhel5-api=@<:@ARG@:>@],
+ [AS_HELP_STRING([--with-rhel5-api=@<:@ARG@:>@],
[build for the RHEL-5 API @<:@default=no@:>@])])
if test x"$with_rhel5_api" = x"yes"; then
AC_DEFINE([WITH_RHEL5_API], [1], [whether building for the RHEL-5 API])
@@ -685,9 +727,6 @@ if test "x$with_vbox" = "xyes"; then
fi
AM_CONDITIONAL([WITH_VBOX], [test "$with_vbox" = "yes"])
-if test "$with_libvirtd" = "no" ; then
- with_qemu=no
-fi
if test "$with_qemu" = "yes" ; then
AC_DEFINE_UNQUOTED([WITH_QEMU], 1, [whether QEMU driver is enabled])
fi
@@ -921,6 +960,18 @@ if test "$with_lxc" = "yes" || test "$with_lxc" = "check"; then
AC_MSG_ERROR([Required kernel features for LXC were not found])
fi
])
+ AC_LINK_IFELSE([AC_LANG_PROGRAM(
+ [[
+ #include <sched.h>
+ #include <linux/loop.h>
+ #include <sys/epoll.h>
+ ]], [[
+ unshare(!(LOOP_CTL_GET_FREE));
+ ]])], [
+ AC_DEFINE([HAVE_DECL_LOOP_CTL_GET_FREE], [1],
+ [Define to 1 if you have the declaration of `LOOP_CTL_GET_FREE',
+ and to 0 if you don't.])
+ ])
fi
if test "$with_lxc" = "yes" ; then
AC_DEFINE_UNQUOTED([WITH_LXC], 1, [whether LXC driver is enabled])
@@ -1003,18 +1054,37 @@ dnl check for kernel headers required by src/bridge.c
dnl
if test "$with_linux" = "yes"; then
if test "$with_qemu" = "yes" || test "$with_lxc" = "yes" ; then
+ # Various kernel versions have headers that are not self-standing, but
+ # yet are incompatible with the corresponding glibc headers. In order
+ # to guarantee compilation across a wide range of versions (from RHEL 5
+ # to rawhide), we first have to probe whether glibc and kernel can be
+ # used in tandem; and if not, provide workarounds that ensure that
+ # ABI-compatible IPv6 types are present for use by the kernel headers.
+ # These probes mirror the usage in virnetdevbridge.c
+ AC_CACHE_CHECK(
+ [whether <linux/*.h> and <netinet/*.h> headers are compatible],
+ [lv_cv_netinet_linux_compatible],
+ [AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
+ #include <netinet/in.h>
+ #include <linux/in6.h>
+ ]])],
+ [lv_cv_netinet_linux_compatible=yes],
+ [lv_cv_netinet_linux_compatible=no])])
+ if test "x$lv_cv_netinet_linux_compatible" != xyes; then
+ AC_DEFINE([NETINET_LINUX_WORKAROUND], [1],
+ [define to 1 if Linux kernel headers require a workaround to avoid
+ compilation errors when mixed with glibc netinet headers])
+ fi
AC_CHECK_HEADERS([linux/param.h linux/sockios.h linux/if_bridge.h linux/if_tun.h],,
[AC_MSG_ERROR([You must install kernel-headers in order to compile libvirt with QEMU or LXC support])],
- [[/* The kernel folks broke their headers when used with particular
- * glibc versions; although the structs are ABI compatible, the
- * C type system doesn't like struct redefinitions. We work around
- * the problem here in the same manner as in virnetdevbridge.c. */
- #include <netinet/in.h>
- #define in6_addr in6_addr_
- #define sockaddr_in6 sockaddr_in6_
- #define ipv6_mreq ipv6_mreq_
- #define in6addr_any in6addr_any_
- #define in6addr_loopback in6addr_loopback_
+ [[#include <netinet/in.h>
+ #if NETINET_LINUX_WORKAROUND
+ # define in6_addr in6_addr_
+ # define sockaddr_in6 sockaddr_in6_
+ # define ipv6_mreq ipv6_mreq_
+ # define in6addr_any in6addr_any_
+ # define in6addr_loopback in6addr_loopback_
+ #endif
#include <linux/in6.h>
]])
fi
@@ -1033,7 +1103,8 @@ LIBXML_CFLAGS=""
LIBXML_LIBS=""
LIBXML_FOUND="no"
-AC_ARG_WITH([libxml], AC_HELP_STRING([--with-libxml=@<:@PFX@:>@], [libxml2 location]))
+AC_ARG_WITH([libxml], [AS_HELP_STRING([--with-libxml=@<:@PFX@:>@],
+ [libxml2 location])])
if test "x$with_libxml" = "xno" ; then
AC_MSG_CHECKING(for libxml2 libraries >= $LIBXML_REQUIRED)
AC_MSG_ERROR([libxml2 >= $LIBXML_REQUIRED is required for libvirt])
@@ -1077,7 +1148,8 @@ LIBS="$old_libs"
dnl GnuTLS library
AC_ARG_WITH([gnutls],
- AC_HELP_STRING([--with-gnutls], [use GNUTLS for encryption @<:@default=check@:>@]),
+ [AS_HELP_STRING([--with-gnutls],
+ [use GNUTLS for encryption @<:@default=check@:>@])],
[],
[with_gnutls=check])
@@ -1173,7 +1245,8 @@ POLKIT_CFLAGS=
POLKIT_LIBS=
PKCHECK_PATH=
AC_ARG_WITH([polkit],
- AC_HELP_STRING([--with-polkit], [use PolicyKit for UNIX socket access checks @<:@default=check@:>@]),
+ [AS_HELP_STRING([--with-polkit],
+ [use PolicyKit for UNIX socket access checks @<:@default=check@:>@])],
[],
[with_polkit=check])
@@ -1184,6 +1257,14 @@ if test "x$with_polkit" = "xyes" || test "x$with_polkit" = "xcheck"; then
AC_PATH_PROG([PKCHECK_PATH],[pkcheck], [], [/usr/sbin:$PATH])
if test "x$PKCHECK_PATH" != "x" ; then
AC_DEFINE_UNQUOTED([PKCHECK_PATH],["$PKCHECK_PATH"],[Location of pkcheck program])
+ AC_MSG_CHECKING([whether pkcheck supports uid value])
+ pkcheck_supports_uid=`$PKG_CONFIG --variable pkcheck_supports_uid polkit-gobject-1`
+ if test "x$pkcheck_supports_uid" = "xtrue"; then
+ AC_MSG_RESULT([yes])
+ AC_DEFINE_UNQUOTED([PKCHECK_SUPPORTS_UID], 1, [Pass uid to pkcheck])
+ else
+ AC_MSG_RESULT([no])
+ fi
AC_DEFINE_UNQUOTED([WITH_POLKIT], 1,
[use PolicyKit for UNIX socket access checks])
AC_DEFINE_UNQUOTED([WITH_POLKIT1], 1,
@@ -1231,7 +1312,8 @@ AC_SUBST([POLKIT_LIBS])
dnl firewalld
AC_ARG_WITH([firewalld],
- AC_HELP_STRING([--with-firewalld], [enable firewalld support @<:@default=check@:>@]),
+ [AS_HELP_STRING([--with-firewalld],
+ [enable firewalld support @<:@default=check@:>@])],
[],
[with_firewalld=check])
if test "x$with_firewalld" = "xcheck" ; then
@@ -1268,7 +1350,8 @@ AM_CONDITIONAL([VIR_CHRDEV_LOCK_FILE_PATH], [test "$with_chrdev_lock_files" != "
AC_ARG_WITH([secdriver-selinux],
- AC_HELP_STRING([--with-secdriver-selinux], [use SELinux security driver @<:@default=check@:>@]),
+ [AS_HELP_STRING([--with-secdriver-selinux],
+ [use SELinux security driver @<:@default=check@:>@])],
[],
[with_secdriver_selinux=check])
@@ -1307,7 +1390,8 @@ AM_CONDITIONAL([WITH_SECDRIVER_SELINUX], [test "$with_secdriver_selinux" != "no"
AC_ARG_WITH([secdriver-apparmor],
- AC_HELP_STRING([--with-secdriver-apparmor], [use AppArmor security driver @<:@default=check@:>@]),
+ [AS_HELP_STRING([--with-secdriver-apparmor],
+ [use AppArmor security driver @<:@default=check@:>@])],
[],
[with_secdriver_apparmor=check])
@@ -1327,7 +1411,8 @@ AM_CONDITIONAL([WITH_SECDRIVER_APPARMOR], [test "$with_secdriver_apparmor" != "n
dnl DTrace static probes
AC_ARG_WITH([dtrace],
- AC_HELP_STRING([--with-dtrace], [use dtrace for static probing @<:@default=check@:>@]),
+ [AS_HELP_STRING([--with-dtrace],
+ [use dtrace for static probing @<:@default=check@:>@])],
[],
[with_dtrace=check])
@@ -1351,7 +1436,8 @@ AM_CONDITIONAL([WITH_DTRACE_PROBES], [test "$with_dtrace" != "no"])
dnl numad
AC_ARG_WITH([numad],
- AC_HELP_STRING([--with-numad], [use numad to manage CPU placement dynamically @<:@default=check@:>@]),
+ [AS_HELP_STRING([--with-numad],
+ [use numad to manage CPU placement dynamically @<:@default=check@:>@])],
[],
[with_numad=check])
@@ -1388,7 +1474,8 @@ LIBPCAP_CFLAGS=""
LIBPCAP_LIBS=""
LIBPCAP_FOUND="no"
-AC_ARG_WITH([libpcap], AC_HELP_STRING([--with-libpcap=@<:@PFX@:>@], [libpcap location]))
+AC_ARG_WITH([libpcap], [AS_HELP_STRING([--with-libpcap=@<:@PFX@:>@],
+ [libpcap location])])
if test "$with_qemu" = "yes"; then
case $with_libpcap in
no) LIBPCAP_CONFIG= ;;
@@ -1510,7 +1597,9 @@ AC_SUBST([VIRSH_LIBS])
dnl check if the network driver should be compiled
AC_ARG_WITH([network],
- AC_HELP_STRING([--with-network], [with virtual network driver @<:@default=yes@:>@]),[],[with_network=yes])
+ [AS_HELP_STRING([--with-network],
+ [with virtual network driver @<:@default=yes@:>@])],
+ [],[with_network=yes])
dnl there's no use compiling the network driver without the libvirt
dnl daemon, nor compiling it for MacOS X, where it breaks the compile
@@ -1533,7 +1622,9 @@ AM_CONDITIONAL([WITH_BRIDGE], [test "$with_bridge" = "yes"])
AC_ARG_WITH([secrets],
- AC_HELP_STRING([--with-secrets], [with local secrets management driver @<:@default=yes@:>@]),[],[with_secrets=yes])
+ [AS_HELP_STRING([--with-secrets],
+ [with local secrets management driver @<:@default=yes@:>@])],
+ [],[with_secrets=yes])
if test "$with_libvirtd" = "no"; then
with_secrets=no
@@ -1545,23 +1636,42 @@ AM_CONDITIONAL([WITH_SECRETS], [test "$with_secrets" = "yes"])
AC_ARG_WITH([storage-dir],
- AC_HELP_STRING([--with-storage-dir], [with directory backend for the storage driver @<:@default=yes@:>@]),[],[with_storage_dir=yes])
+ [AS_HELP_STRING([--with-storage-dir],
+ [with directory backend for the storage driver @<:@default=yes@:>@])],
+ [],[with_storage_dir=yes])
AC_ARG_WITH([storage-fs],
- AC_HELP_STRING([--with-storage-fs], [with FileSystem backend for the storage driver @<:@default=check@:>@]),[],[with_storage_fs=check])
+ [AS_HELP_STRING([--with-storage-fs],
+ [with FileSystem backend for the storage driver @<:@default=check@:>@])],
+ [],[with_storage_fs=check])
AC_ARG_WITH([storage-lvm],
- AC_HELP_STRING([--with-storage-lvm], [with LVM backend for the storage driver @<:@default=check@:>@]),[],[with_storage_lvm=check])
+ [AS_HELP_STRING([--with-storage-lvm],
+ [with LVM backend for the storage driver @<:@default=check@:>@])],
+ [],[with_storage_lvm=check])
AC_ARG_WITH([storage-iscsi],
- AC_HELP_STRING([--with-storage-iscsi], [with iSCSI backend for the storage driver @<:@default=check@:>@]),[],[with_storage_iscsi=check])
+ [AS_HELP_STRING([--with-storage-iscsi],
+ [with iSCSI backend for the storage driver @<:@default=check@:>@])],
+ [],[with_storage_iscsi=check])
AC_ARG_WITH([storage-scsi],
- AC_HELP_STRING([--with-storage-scsi], [with SCSI backend for the storage driver @<:@default=check@:>@]),[],[with_storage_scsi=check])
+ [AS_HELP_STRING([--with-storage-scsi],
+ [with SCSI backend for the storage driver @<:@default=check@:>@])],
+ [],[with_storage_scsi=check])
AC_ARG_WITH([storage-mpath],
- AC_HELP_STRING([--with-storage-mpath], [with mpath backend for the storage driver @<:@default=check@:>@]),[],[with_storage_mpath=check])
+ [AS_HELP_STRING([--with-storage-mpath],
+ [with mpath backend for the storage driver @<:@default=check@:>@])],
+ [],[with_storage_mpath=check])
AC_ARG_WITH([storage-disk],
- AC_HELP_STRING([--with-storage-disk], [with GPartd Disk backend for the storage driver @<:@default=check@:>@]),[],[with_storage_disk=check])
+ [AS_HELP_STRING([--with-storage-disk],
+ [with GPartd Disk backend for the storage driver @<:@default=check@:>@])],
+ [],[with_storage_disk=check])
AC_ARG_WITH([storage-rbd],
- AC_HELP_STRING([--with-storage-rbd], [with RADOS Block Device backend for the storage driver @<:@default=check@:>@]),[],[with_storage_rbd=check])
+ [AS_HELP_STRING([--with-storage-rbd],
+ [with RADOS Block Device backend for the storage driver
+ @<:@default=check@:>@])],
+ [],[with_storage_rbd=check])
AC_ARG_WITH([storage-sheepdog],
- AC_HELP_STRING([--with-storage-sheepdog], [with Sheepdog backend for the storage driver @<:@default=check@:>@]),[],[with_storage_sheepdog=check])
+ [AS_HELP_STRING([--with-storage-sheepdog],
+ [with Sheepdog backend for the storage driver @<:@default=check@:>@])],
+ [],[with_storage_sheepdog=check])
if test "$with_libvirtd" = "no"; then
with_storage_dir=no
@@ -1936,7 +2046,9 @@ dnl check for python
dnl
AC_ARG_WITH([python],
- AC_HELP_STRING([--with-python], [Build python bindings @<:@default=yes@:>@]),[],[with_python=yes])
+ [AS_HELP_STRING([--with-python],
+ [Build python bindings @<:@default=yes@:>@])],
+ [],[with_python=yes])
if test "$enable_shared:$with_python" = no:yes; then
AC_MSG_WARN([Disabling shared libraries is incompatible with building Python extensions.])
@@ -2010,7 +2122,8 @@ dnl Allow perl overrides
AC_PATH_PROG([PERL], [perl])
AC_ARG_ENABLE([with-test-suite],
- AC_HELP_STRING([--with-test-suite], [build test suite by default @<:@default=check@:>@]),
+ [AS_HELP_STRING([--with-test-suite],
+ [build test suite by default @<:@default=check@:>@])],
[case "${withval}" in
yes|no|check) ;;
*) AC_MSG_ERROR([bad value ${withval} for tests option]) ;;
@@ -2029,7 +2142,7 @@ AC_MSG_RESULT([$withval])
AM_CONDITIONAL([WITH_TESTS], [test "$withval" = "yes"])
AC_ARG_ENABLE([expensive-tests],
- [AC_HELP_STRING([--enable-expensive-tests],
+ [AS_HELP_STRING([--enable-expensive-tests],
[set the default for enabling expensive tests (gnulib and long timeouts) ]
[@<:@default=check@:>@; use VIR_TEST_EXPENSIVE to override during make])],
[case $enableval in
@@ -2050,7 +2163,8 @@ AC_SUBST([VIR_TEST_EXPENSIVE_DEFAULT])
AM_CONDITIONAL([WITH_EXPENSIVE_TESTS], [test $VIR_TEST_EXPENSIVE_DEFAULT = 1])
AC_ARG_ENABLE([test-coverage],
- AC_HELP_STRING([--enable-test-coverage], [turn on code coverage instrumentation @<:@default=no@:>@]),
+ [AS_HELP_STRING([--enable-test-coverage],
+ [turn on code coverage instrumentation @<:@default=no@:>@])],
[case "${enableval}" in
yes|no) ;;
*) AC_MSG_ERROR([bad value ${enableval} for test-coverage option]) ;;
@@ -2070,7 +2184,8 @@ if test "${enable_coverage}" = yes; then
fi
AC_ARG_ENABLE([test-oom],
- AC_HELP_STRING([--enable-test-oom], [memory allocation failure checking @<:@default=no@:>@]),
+ [AS_HELP_STRING([--enable-test-oom],
+ [memory allocation failure checking @<:@default=no@:>@])],
[case "${enableval}" in
yes|no) ;;
*) AC_MSG_ERROR([bad value ${enableval} for test-oom option]) ;;
@@ -2090,7 +2205,8 @@ fi
AC_ARG_ENABLE([test-locking],
- AC_HELP_STRING([--enable-test-locking], [thread locking tests using CIL @<:@default=no@:>@]),
+ [AS_HELP_STRING([--enable-test-locking],
+ [thread locking tests using CIL @<:@default=no@:>@])],
[case "${enableval}" in
yes|no) ;;
*) AC_MSG_ERROR([bad value ${enableval} for test-locking option]) ;;
@@ -2213,8 +2329,8 @@ AM_CONDITIONAL([WITH_WIN_ICON], [test "$WINDRES" != ""])
dnl Driver-Modules library
AC_ARG_WITH([driver-modules],
- AC_HELP_STRING([--with-driver-modules],
- [build drivers as loadable modules @<:@default=check@:>@]),
+ [AS_HELP_STRING([--with-driver-modules],
+ [build drivers as loadable modules @<:@default=check@:>@])],
[],
[with_driver_modules=check])
@@ -2279,9 +2395,9 @@ AM_CONDITIONAL([WITH_NWFILTER], [test "$with_nwfilter" = "yes"])
dnl check if the interface driver should be compiled
AC_ARG_WITH([interface],
- AC_HELP_STRING([--with-interface],
- [with host interface driver @<:@default=check@:>@]), [],
- [with_interface=check])
+ [AS_HELP_STRING([--with-interface],
+ [with host interface driver @<:@default=check@:>@])],
+ [],[with_interface=check])
dnl Don't compile the interface driver without libvirtd
if test "$with_libvirtd" = "no" ; then
@@ -2311,13 +2427,15 @@ else
fi
AC_ARG_WITH([qemu-user],
- AC_HELP_STRING([--with-qemu-user],
- [username to run QEMU system instance as @<:@default=platform dependent@:>@]),
+ [AS_HELP_STRING([--with-qemu-user],
+ [username to run QEMU system instance as
+ @<:@default=platform dependent@:>@])],
[QEMU_USER=${withval}],
[QEMU_USER=${default_qemu_user}])
AC_ARG_WITH([qemu-group],
- AC_HELP_STRING([--with-qemu-group],
- [groupname to run QEMU system instance as @<:@default=platform dependent@:>@]),
+ [AS_HELP_STRING([--with-qemu-group],
+ [groupname to run QEMU system instance as
+ @<:@default=platform dependent@:>@])],
[QEMU_GROUP=${withval}],
[QEMU_GROUP=${default_qemu_group}])
AC_DEFINE_UNQUOTED([QEMU_USER], ["$QEMU_USER"], [QEMU user account])
@@ -2325,7 +2443,8 @@ AC_DEFINE_UNQUOTED([QEMU_GROUP], ["$QEMU_GROUP"], [QEMU group account])
AC_ARG_WITH([macvtap],
- AC_HELP_STRING([--with-macvtap],[enable macvtap device @<:@default=check@:>@]),
+ [AS_HELP_STRING([--with-macvtap],
+ [enable macvtap device @<:@default=check@:>@])],
[with_macvtap=${withval}],
[with_macvtap=check])
@@ -2358,7 +2477,8 @@ fi
AC_ARG_WITH([virtualport],
- AC_HELP_STRING([--with-virtualport],[enable virtual port support @<:@default=check@:>@]),
+ [AS_HELP_STRING([--with-virtualport],
+ [enable virtual port support @<:@default=check@:>@])],
[with_virtualport=${withval}],
[with_virtualport=check])
@@ -2416,6 +2536,9 @@ if test "$with_linux" = "yes"; then
fi
done
case $libnl_ldd:${LIBNL_CFLAGS+set} in
+ *libnl-3.so.*:) LIBNL_REQUIRED=3.0 ;;
+ esac
+ case $libnl_ldd:${LIBNL_CFLAGS+set} in
*libnl.so.1*:) ;;
*)
PKG_CHECK_MODULES([LIBNL], [libnl-3.0], [