summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGuido Günther <agx@sigxcpu.org>2015-08-10 16:47:00 +0200
committerGuido Günther <agx@sigxcpu.org>2015-08-10 16:47:00 +0200
commit18ffe0c1a1c126557a5788edcbc8b89dd9990604 (patch)
tree6c2a12a8b4864f7d6b2dd59dd8fa5b4f467fadfc /configure.ac
parent56eac6ed13d62b257d56575432dff7ad00e0c235 (diff)
New upstream version 1.2.18
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac58
1 files changed, 26 insertions, 32 deletions
diff --git a/configure.ac b/configure.ac
index f3ae6ca14..7c2257f2a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -16,7 +16,7 @@ dnl You should have received a copy of the GNU Lesser General Public
dnl License along with this library. If not, see
dnl <http://www.gnu.org/licenses/>.
-AC_INIT([libvirt], [1.2.17], [libvir-list@redhat.com], [], [http://libvirt.org])
+AC_INIT([libvirt], [1.2.18], [libvir-list@redhat.com], [], [http://libvirt.org])
AC_CONFIG_SRCDIR([src/libvirt.c])
AC_CONFIG_AUX_DIR([build-aux])
AC_CONFIG_HEADERS([config.h])
@@ -123,6 +123,7 @@ PARTED_REQUIRED="1.8.0"
DEVMAPPER_REQUIRED=1.0.0
LIBPCAP_REQUIRED="1.0.0"
LIBNL_REQUIRED="1.1"
+PARALLELS_SDK_REQUIRED="7.0.22"
dnl Checks for C compiler.
AC_PROG_CC
@@ -389,7 +390,7 @@ AC_CHECK_TYPE([struct ifreq],
]])
AC_CHECK_DECLS([ETH_FLAG_TXVLAN, ETH_FLAG_NTUPLE, ETH_FLAG_RXHASH, ETH_FLAG_LRO,
- ETHTOOL_GGSO, ETHTOOL_GGRO, ETHTOOL_GFLAGS],
+ ETHTOOL_GGSO, ETHTOOL_GGRO, ETHTOOL_GFLAGS, ETHTOOL_GFEATURES],
[], [], [[#include <linux/ethtool.h>
]])
@@ -401,7 +402,7 @@ AM_CONDITIONAL([HAVE_LIBTASN1], [test "x$ac_cv_header_libtasn1_h" = "xyes"])
AC_CHECK_LIB([intl],[gettext],[])
dnl Do we have rpcgen?
-AC_PATH_PROG([RPCGEN], [rpcgen], [no])
+AC_PATH_PROGS([RPCGEN], [rpcgen portable-rpcgen], [no])
AM_CONDITIONAL([HAVE_RPCGEN], [test "x$ac_cv_path_RPCGEN" != "xno"])
dnl Is this GLIBC's buggy rpcgen?
AM_CONDITIONAL([HAVE_GLIBC_RPCGEN],
@@ -562,10 +563,6 @@ AC_ARG_WITH([hyperv],
[AS_HELP_STRING([--with-hyperv],
[add Hyper-V support @<:@default=check@:>@])])
m4_divert_text([DEFAULTS], [with_hyperv=check])
-AC_ARG_WITH([vz],
- [AS_HELP_STRING([--with-vz],
- [add Virtuozzo support @<:@default=check@:>@])])
-m4_divert_text([DEFAULTS], [with_vz=check])
AC_ARG_WITH([test],
[AS_HELP_STRING([--with-test],
[add test driver support @<:@default=yes@:>@])])
@@ -1081,23 +1078,7 @@ dnl
dnl Checks for the Parallels driver
dnl
-
-if test "$with_vz" = "yes" ||
- test "$with_vz" = "check"; then
- PKG_CHECK_MODULES([PARALLELS_SDK], [parallels-sdk],
- [PARALLELS_SDK_FOUND=yes], [PARALLELS_SDK_FOUND=no])
-
- if test "$with_vz" = "yes" && test "$PARALLELS_SDK_FOUND" = "no"; then
- AC_MSG_ERROR([Parallels Virtualization SDK is needed to build the Parallels driver.])
- fi
-
- with_vz=$PARALLELS_SDK_FOUND
- if test "$with_vz" = "yes"; then
- AC_DEFINE_UNQUOTED([WITH_VZ], 1,
- [whether vz driver is enabled])
- fi
-fi
-AM_CONDITIONAL([WITH_VZ], [test "$with_vz" = "yes"])
+LIBVIRT_DRIVER_CHECK_VZ
dnl
dnl Checks for bhyve driver
@@ -1358,15 +1339,28 @@ AC_ARG_WITH([polkit],
with_polkit0=no
with_polkit1=no
if test "x$with_polkit" = "xyes" || test "x$with_polkit" = "xcheck"; then
- dnl Check for new polkit first - just a binary
+ dnl Check for new polkit first. We directly talk over DBus
+ dnl but we use existence of pkcheck binary as a sign that
+ dnl we should prefer polkit-1 over polkit-0, so we check
+ dnl for it even though we don't ultimately use it
AC_PATH_PROG([PKCHECK_PATH],[pkcheck], [], [/usr/sbin:$PATH])
if test "x$PKCHECK_PATH" != "x" ; then
- AC_DEFINE_UNQUOTED([WITH_POLKIT], 1,
- [use PolicyKit for UNIX socket access checks])
- AC_DEFINE_UNQUOTED([WITH_POLKIT1], 1,
- [use PolicyKit for UNIX socket access checks])
- with_polkit="yes"
- with_polkit1="yes"
+ dnl Found pkcheck, so ensure dbus-devel is present
+ if test "x$with_dbus" = "xyes" ; then
+ AC_DEFINE_UNQUOTED([WITH_POLKIT], 1,
+ [use PolicyKit for UNIX socket access checks])
+ AC_DEFINE_UNQUOTED([WITH_POLKIT1], 1,
+ [use PolicyKit for UNIX socket access checks])
+ with_polkit="yes"
+ with_polkit1="yes"
+ else
+ if test "x$with_polkit" = "xcheck" ; then
+ with_polkit=no
+ else
+ AC_MSG_ERROR(
+ [You must install dbus to compile libvirt with polkit-1])
+ fi
+ fi
else
dnl Check for old polkit second - library + binary
PKG_CHECK_MODULES(POLKIT, polkit-dbus >= $POLKIT_REQUIRED,
@@ -2833,7 +2827,7 @@ AC_MSG_NOTICE([ LXC: $with_lxc])
AC_MSG_NOTICE([ PHYP: $with_phyp])
AC_MSG_NOTICE([ ESX: $with_esx])
AC_MSG_NOTICE([ Hyper-V: $with_hyperv])
-AC_MSG_NOTICE([ vz: $with_vz])
+LIBVIRT_DRIVER_RESULT_VZ
LIBVIRT_DRIVER_RESULT_BHYVE
AC_MSG_NOTICE([ Test: $with_test])
AC_MSG_NOTICE([ Remote: $with_remote])