summaryrefslogtreecommitdiff
path: root/cfg.mk
diff options
context:
space:
mode:
authorGuido Günther <agx@sigxcpu.org>2012-10-26 08:31:59 +0200
committerGuido Günther <agx@sigxcpu.org>2012-10-26 08:31:59 +0200
commit51182d6cdf2e21fdecff1c203dbdc0823c848247 (patch)
tree433e368f3a1cb4831b2bb61cb4e50e70a4a68412 /cfg.mk
parent8d5672320b92b05f1fbc15c1a6813ef466e1f8fc (diff)
New upstream version 1.0.0~rc1
Diffstat (limited to 'cfg.mk')
-rw-r--r--cfg.mk18
1 files changed, 2 insertions, 16 deletions
diff --git a/cfg.mk b/cfg.mk
index bbfd4a286..d3c96bafc 100644
--- a/cfg.mk
+++ b/cfg.mk
@@ -43,7 +43,6 @@ _test_script_regex = \<\(init\|test-lib\)\.sh\>
# Tests not to run as part of "make distcheck".
local-checks-to-skip = \
changelog-check \
- check-AUTHORS \
makefile-check \
makefile_path_separator_check \
patch-check \
@@ -700,24 +699,11 @@ ifeq (0,$(MAKELEVEL))
_clean_requested = $(filter %clean,$(MAKECMDGOALS))
ifeq (1,$(_update_required)$(_clean_requested))
$(info INFO: gnulib update required; running ./autogen.sh first)
-Makefile: _autogen
+ $(shell touch $(srcdir)/AUTHORS $(srcdir)/ChangeLog)
+maint.mk Makefile: _autogen
endif
endif
-# Give credit where due:
-# Ensure that each commit author email address (possibly mapped via
-# git log's .mailmap) appears in our AUTHORS file.
-sc_check_author_list:
- @fail=0; \
- for i in $$(git log --pretty=format:%aE%n|sort -u|grep -v '^$$'); do \
- sanitized=$$(echo "$$i"|LC_ALL=C sed 's/\([^a-zA-Z0-9_@-]\)/\\\1/g'); \
- grep -iq "<$$sanitized>" $(srcdir)/AUTHORS \
- || { printf '%s\n' "$$i" >&2; fail=1; }; \
- done; \
- test $$fail = 1 \
- && echo '$(ME): committer(s) not listed in AUTHORS' >&2; \
- test $$fail = 0
-
# It is necessary to call autogen any time gnulib changes. Autogen
# reruns configure, then we regenerate all Makefiles at once.
.PHONY: _autogen