summaryrefslogtreecommitdiff
path: root/autobuild.sh
diff options
context:
space:
mode:
authorGuido Guenther <agx@sigxcpu.org>2008-09-18 15:32:46 +0200
committerGuido Guenther <agx@sigxcpu.org>2008-09-18 15:32:46 +0200
commitab8b4e637bdc17ec54786f138164d54a758213d3 (patch)
tree8150b91f46b0bd975900e79de7cd21476619816a /autobuild.sh
parent0ff1e6808a0fd3afc82d0ba4c0459f5e93b9712a (diff)
Imported Upstream version 0.4.5
Diffstat (limited to 'autobuild.sh')
-rwxr-xr-xautobuild.sh60
1 files changed, 54 insertions, 6 deletions
diff --git a/autobuild.sh b/autobuild.sh
index ed2ef74c9..50b4e0ce7 100755
--- a/autobuild.sh
+++ b/autobuild.sh
@@ -5,7 +5,7 @@ set -v
# Make things clean.
-test -n "$1" && RESULTS="$1" || RESULTS="results.log"
+test -n "$1" && RESULTS=$1 || RESULTS=results.log
test -f Makefile && make -k distclean || :
rm -rf coverage
@@ -14,16 +14,29 @@ rm -rf coverage
#mkdir build
#cd build
-./autogen.sh --prefix=$AUTOBUILD_INSTALL_ROOT \
+./autogen.sh --prefix="$AUTOBUILD_INSTALL_ROOT" \
--enable-test-coverage \
- --enable-compile-warnings=error
+ --enable-compile-warnings=error \
+ --with-xen-proxy
+
+# If the MAKEFLAGS envvar does not yet include a -j option,
+# add -jN where N depends on the number of processors.
+case $MAKEFLAGS in
+ *-j*) ;;
+ *) n=$(getconf _NPROCESSORS_ONLN 2> /dev/null)
+ test "$n" -gt 0 || n=1
+ n=$(expr $n + 1)
+ MAKEFLAGS="$MAKEFLAGS -j$n"
+ export MAKEFLAGS
+ ;;
+esac
make
make install
set -o pipefail
-make check 2>&1 | tee $RESULTS
-make syntax-check 2>&1 | tee -a $RESULTS
+make check 2>&1 | tee "$RESULTS"
+make syntax-check 2>&1 | tee -a "$RESULTS"
test -x /usr/bin/lcov && make cov
rm -f *.tar.gz
@@ -36,5 +49,40 @@ if [ -f /usr/bin/rpmbuild ]; then
NOW=`date +"%s"`
EXTRA_RELEASE=".$USER$NOW"
fi
- rpmbuild --nodeps --define "extra_release $EXTRA_RELEASE" -ta --clean *.tar.gz
+
+ rpmbuild --nodeps \
+ --define "extra_release $EXTRA_RELEASE" \
+ --define "_sourcedir `pwd`" \
+ -ba --clean libvirt.spec
+fi
+
+if [ -x /usr/bin/i686-pc-mingw32-gcc ]; then
+ make distclean
+
+ PKG_CONFIG_PATH="$AUTOBUILD_INSTALL_ROOT/i686-pc-mingw32/sys-root/mingw/lib/pkgconfig" \
+ CC="i686-pc-mingw32-gcc" \
+ ./configure \
+ --build=$(uname -m)-pc-linux \
+ --host=i686-pc-mingw32 \
+ --prefix="$AUTOBUILD_INSTALL_ROOT/i686-pc-mingw32/sys-root/mingw" \
+ --without-sasl \
+ --without-avahi \
+ --without-polkit \
+ --without-python \
+ --without-xen \
+ --without-qemu \
+ --without-lxc \
+ --without-openvz \
+ --without-libvirtd
+
+ make
+ make install
+
+ #set -o pipefail
+ #make check 2>&1 | tee "$RESULTS"
+
+ rpmbuild --nodeps \
+ --define "extra_release $EXTRA_RELEASE" \
+ --define "_sourcedir `pwd`" \
+ -ba --clean mingw-libvirt.spec
fi