summaryrefslogtreecommitdiff
path: root/autobuild.sh
diff options
context:
space:
mode:
authorGuido Günther <agx@sigxcpu.org>2013-09-26 12:17:15 +0200
committerGuido Günther <agx@sigxcpu.org>2013-09-26 12:17:15 +0200
commit20cacffd38862928f8fb3e53b99369d67bcda7df (patch)
tree7d9a0b0c18474f859afdd79302a48b7ff95e554d /autobuild.sh
parent7b8d517a7feb2a54cbf5ba2a5f1aa4e3a4a6ffcd (diff)
New upstream version 1.1.3~rc1
Diffstat (limited to 'autobuild.sh')
-rwxr-xr-xautobuild.sh11
1 files changed, 9 insertions, 2 deletions
diff --git a/autobuild.sh b/autobuild.sh
index e5aa35ca3..3109b492e 100755
--- a/autobuild.sh
+++ b/autobuild.sh
@@ -8,6 +8,13 @@ set -v
test -n "$1" && RESULTS=$1 || RESULTS=results.log
: ${AUTOBUILD_INSTALL_ROOT=$HOME/builder}
+# If run under the autobuilder, we must use --nodeps with rpmbuild;
+# but this can lead to odd error diagnosis for normal development.
+nodeps=
+if test "${AUTOBUILD_COUNTER+set}"; then
+ nodeps=--nodeps
+fi
+
test -f Makefile && make -k distclean || :
rm -rf coverage
@@ -60,7 +67,7 @@ else
fi
if test -f /usr/bin/rpmbuild ; then
- rpmbuild --nodeps \
+ rpmbuild $nodeps \
--define "extra_release $EXTRA_RELEASE" \
--define "_sourcedir `pwd`" \
-ba --clean libvirt.spec
@@ -111,7 +118,7 @@ fi
if test -x /usr/bin/i686-w64-mingw32-gcc && test -x /usr/bin/x86_64-w64-mingw32-gcc ; then
if test -f /usr/bin/rpmbuild ; then
- rpmbuild --nodeps \
+ rpmbuild $nodeps \
--define "extra_release $EXTRA_RELEASE" \
--define "_sourcedir `pwd`" \
-ba --clean mingw-libvirt.spec