summaryrefslogtreecommitdiff
path: root/Makefile.in
diff options
context:
space:
mode:
authorLaurent Léonard <laurent@open-minds.org>2010-11-30 23:29:02 +0100
committerLaurent Léonard <laurent@open-minds.org>2010-11-30 23:29:02 +0100
commit3b7b682de1f743acab5daf6e987289c7da539386 (patch)
tree979d57ac25b146f3c63108787fe52b8c064597fa /Makefile.in
parent802e65869571c43bff4dd6431f8f6d6811e0d5e9 (diff)
Imported Upstream version 0.8.6
Diffstat (limited to 'Makefile.in')
-rw-r--r--Makefile.in41
1 files changed, 33 insertions, 8 deletions
diff --git a/Makefile.in b/Makefile.in
index 15c1381d4..26cf78041 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -90,6 +90,7 @@ am__aclocal_m4_deps = $(top_srcdir)/gnulib/m4/00gnulib.m4 \
$(top_srcdir)/gnulib/m4/md5.m4 \
$(top_srcdir)/gnulib/m4/memchr.m4 \
$(top_srcdir)/gnulib/m4/mkstemp.m4 \
+ $(top_srcdir)/gnulib/m4/mkstemps.m4 \
$(top_srcdir)/gnulib/m4/mktime.m4 \
$(top_srcdir)/gnulib/m4/mmap-anon.m4 \
$(top_srcdir)/gnulib/m4/multiarch.m4 \
@@ -480,6 +481,7 @@ GNULIB_STRCASESTR = @GNULIB_STRCASESTR@
GNULIB_STRCHRNUL = @GNULIB_STRCHRNUL@
GNULIB_STRDUP = @GNULIB_STRDUP@
GNULIB_STRERROR = @GNULIB_STRERROR@
+GNULIB_STRERROR_R = @GNULIB_STRERROR_R@
GNULIB_STRNCAT = @GNULIB_STRNCAT@
GNULIB_STRNDUP = @GNULIB_STRNDUP@
GNULIB_STRNLEN = @GNULIB_STRNLEN@
@@ -556,6 +558,7 @@ HAVE_DECL_MEMRCHR = @HAVE_DECL_MEMRCHR@
HAVE_DECL_OBSTACK_PRINTF = @HAVE_DECL_OBSTACK_PRINTF@
HAVE_DECL_SNPRINTF = @HAVE_DECL_SNPRINTF@
HAVE_DECL_STRDUP = @HAVE_DECL_STRDUP@
+HAVE_DECL_STRERROR_R = @HAVE_DECL_STRERROR_R@
HAVE_DECL_STRNCASECMP = @HAVE_DECL_STRNCASECMP@
HAVE_DECL_STRNDUP = @HAVE_DECL_STRNDUP@
HAVE_DECL_STRNLEN = @HAVE_DECL_STRNLEN@
@@ -839,6 +842,8 @@ PCIACCESS_CFLAGS = @PCIACCESS_CFLAGS@
PCIACCESS_LIBS = @PCIACCESS_LIBS@
PKCHECK_PATH = @PKCHECK_PATH@
PKG_CONFIG = @PKG_CONFIG@
+PKG_CONFIG_LIBDIR = @PKG_CONFIG_LIBDIR@
+PKG_CONFIG_PATH = @PKG_CONFIG_PATH@
POLKIT_AUTH = @POLKIT_AUTH@
POLKIT_CFLAGS = @POLKIT_CFLAGS@
POLKIT_LIBS = @POLKIT_LIBS@
@@ -942,6 +947,7 @@ REPLACE_STPNCPY = @REPLACE_STPNCPY@
REPLACE_STRCASESTR = @REPLACE_STRCASESTR@
REPLACE_STRDUP = @REPLACE_STRDUP@
REPLACE_STRERROR = @REPLACE_STRERROR@
+REPLACE_STRERROR_R = @REPLACE_STRERROR_R@
REPLACE_STRNCAT = @REPLACE_STRNCAT@
REPLACE_STRNDUP = @REPLACE_STRNDUP@
REPLACE_STRNLEN = @REPLACE_STRNLEN@
@@ -1091,7 +1097,7 @@ top_builddir = @top_builddir@
top_srcdir = @top_srcdir@
LCOV = lcov
GENHTML = genhtml
-SUBDIRS = gnulib/lib include src daemon tools proxy docs gnulib/tests \
+SUBDIRS = gnulib/lib include src daemon tools docs gnulib/tests \
python tests po examples/domain-events/events-c examples/hellolibvirt \
examples/dominfo examples/domsuspend examples/python examples/apparmor \
examples/xml/nwfilter examples/openauth examples/systemtap
@@ -1101,17 +1107,16 @@ XML_EXAMPLES = \
$(patsubst $(srcdir)/%,%,$(wildcard $(addprefix $(srcdir)/examples/xml/, \
test/*.xml storage/*.xml)))
-EXTRA_DIST = \
- ChangeLog-old \
- libvirt.spec libvirt.spec.in \
- mingw32-libvirt.spec.in \
- libvirt.pc libvirt.pc.in \
- autobuild.sh \
+syntax_check_exceptions = \
.x-sc_avoid_ctype_macros \
.x-sc_avoid_if_before_free \
.x-sc_avoid_write \
+ .x-sc_bindtextdomain \
.x-sc_m4_quote_check \
+ .x-sc_po_check \
+ .x-sc_prohibit_always_true_header_tests \
.x-sc_prohibit_asprintf \
+ .x-sc_prohibit_close \
.x-sc_prohibit_empty_lines_at_EOF \
.x-sc_prohibit_gethostby \
.x-sc_prohibit_gethostname \
@@ -1119,17 +1124,29 @@ EXTRA_DIST = \
.x-sc_prohibit_have_config_h \
.x-sc_prohibit_HAVE_MBRTOWC \
.x-sc_prohibit_nonreentrant \
+ .x-sc_prohibit_readlink \
+ .x-sc_prohibit_sprintf \
.x-sc_prohibit_strcmp \
- .x-sc_prohibit_strcmp_and_strncmp \
+ .x-sc_prohibit_strncmp \
.x-sc_prohibit_strncpy \
.x-sc_prohibit_test_minus_ao \
.x-sc_prohibit_VIR_ERR_NO_MEMORY \
+ .x-sc_prohibit_xmlGetProp \
.x-sc_require_config_h \
.x-sc_require_config_h_first \
.x-sc_trailing_blank \
+ .x-sc_unmarked_diagnostics
+
+EXTRA_DIST = \
+ ChangeLog-old \
+ libvirt.spec libvirt.spec.in \
+ mingw32-libvirt.spec.in \
+ libvirt.pc libvirt.pc.in \
+ autobuild.sh \
Makefile.nonreentrant \
autogen.sh \
examples/domain-events/events-python \
+ $(syntax_check_exceptions) \
$(XML_EXAMPLES)
pkgconfigdir = $(libdir)/pkgconfig
@@ -1669,6 +1686,14 @@ NEWS: $(top_srcdir)/docs/news.xsl $(top_srcdir)/docs/news.html.in
| perl -pe 's/[ \t]+$$//' \
> $@-t && mv $@-t $@ ; fi );
+$(top_srcdir)/HACKING: $(top_srcdir)/docs/hacking1.xsl $(top_srcdir)/docs/hacking2.xsl \
+ $(top_srcdir)/docs/wrapstring.xsl $(top_srcdir)/docs/hacking.html.in
+ -@(if [ -x $(XSLTPROC) ] ; then \
+ $(XSLTPROC) --nonet $(top_srcdir)/docs/hacking1.xsl $(top_srcdir)/docs/hacking.html.in | \
+ $(XSLTPROC) --nonet $(top_srcdir)/docs/hacking2.xsl - \
+ | perl -0777 -pe 's/\n\n+$$/\n/' \
+ > $@-t && mv $@-t $@ ; fi );
+
rpm: clean
@(unset CDPATH ; $(MAKE) dist && rpmbuild -ta $(distdir).tar.gz)