summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorGuido Guenther <agx@sigxcpu.org>2007-12-21 13:32:04 +0100
committerGuido Guenther <agx@sigxcpu.org>2007-12-21 13:32:04 +0100
commite53abad65647872a01cd0848f0c986d5f537d41e (patch)
treedd9629f6535d5fef5c6b4dce674d9e8be104bdfd /Makefile.am
parent289456a92fb60b336602a4667d251007b054bb0a (diff)
Imported upstream version 0.4.0
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 7 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index e1e688416..34a1eb507 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,8 +1,9 @@
## Process this file with automake to produce Makefile.in
-SUBDIRS = src qemud proxy include docs @PYTHON_SUBDIR@ tests po m4 scripts
+SUBDIRS = gnulib/lib include src qemud proxy docs gnulib/tests \
+ python tests po scripts
-ACLOCAL_AMFLAGS = -I m4
+ACLOCAL_AMFLAGS = -I m4 -I gnulib/m4
EXTRA_DIST = libvirt.spec.in libvirt.spec COPYING.LIB \
libvirt.pc.in libvirt.pc TODO AUTHORS ChangeLog \
@@ -20,7 +21,7 @@ check-local: all tests
tests:
@(cd docs/examples ; $(MAKE) MAKEFLAGS+=--silent tests)
- @(if [ "@PYTHON_SUBDIR@" != "" ] ; then cd python ; \
+ @(if [ "$(pythondir)" != "" ] ; then cd python ; \
$(MAKE) MAKEFLAGS+=--silent tests ; fi)
cov: cov-recursive cov-am
@@ -41,3 +42,6 @@ cov-am:
> $(top_builddir)/coverage/index.html
for i in $(top_builddir)/src/*.gcov ; do o=`echo $$i | sed -e 's,$(top_builddir)/src,coverage,'` ; \
perl $(srcdir)/scripts/coverage-report-entry.pl $$i > $$o.html ; done
+
+# disable this check
+distuninstallcheck: