summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorGuido Guenther <agx@sigxcpu.org>2008-06-26 19:14:13 +0200
committerGuido Guenther <agx@sigxcpu.org>2008-06-26 19:14:13 +0200
commit0ff1e6808a0fd3afc82d0ba4c0459f5e93b9712a (patch)
tree8e66099219865d43be7e29dca39a07addfe36045 /Makefile.am
parent200fc7b0d0672de4a84368d94f5f57f1bc5400cb (diff)
Imported Upstream version 0.4.4
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am30
1 files changed, 13 insertions, 17 deletions
diff --git a/Makefile.am b/Makefile.am
index e32033a4d..b5082d6a7 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,7 +1,10 @@
## Process this file with automake to produce Makefile.in
+LCOV = lcov
+GENHTML = genhtml
+
SUBDIRS = gnulib/lib include src qemud proxy docs gnulib/tests \
- python tests po scripts
+ python tests po
ACLOCAL_AMFLAGS = -I m4 -I gnulib/m4
@@ -10,7 +13,9 @@ EXTRA_DIST = \
libvirt.pc libvirt.pc.in \
$(man_MANS) autobuild.sh \
.x-sc_avoid_if_before_free \
- .x-sc_require_config_h
+ .x-sc_prohibit_strcmp \
+ .x-sc_require_config_h \
+ autogen.sh
man_MANS = virsh.1
@@ -27,24 +32,15 @@ tests:
@(if [ "$(pythondir)" != "" ] ; then cd python ; \
$(MAKE) MAKEFLAGS+=--silent tests ; fi)
-cov: cov-recursive cov-am
+cov: clean-cov
+ mkdir $(top_builddir)/coverage
+ $(LCOV) -c -o $(top_builddir)/coverage/libvirt.info.tmp -d $(top_srcdir)/src -d $(top_srcdir)/qemud -d $(top_srcdir)/tests
+ $(LCOV) -r $(top_builddir)/coverage/libvirt.info.tmp -o $(top_builddir)/coverage/libvirt.info *usr*
+ rm $(top_builddir)/coverage/libvirt.info.tmp
+ $(GENHTML) -s -t "libvirt" -o $(top_builddir)/coverage --legend $(top_builddir)/coverage/libvirt.info
clean-cov:
rm -rf $(top_builddir)/coverage
- cd src && $(MAKE) $(AM_MAKEFLAGS) clean-cov
-
-cov-recursive:
- cd src && $(MAKE) $(AM_MAKEFLAGS) cov
-
-cov-am:
- rm -rf $(top_builddir)/coverage
- mkdir $(top_builddir)/coverage
- perl $(srcdir)/scripts/coverage-report.pl src/*.cov > $(top_builddir)/coverage/index.xml
- xsltproc $(srcdir)/scripts/coverage-report.xsl \
- $(top_builddir)/coverage/index.xml \
- > $(top_builddir)/coverage/index.html
- for i in $(top_builddir)/src/*.gcov ; do o=`echo $$i | sed -e 's,$(top_builddir)/src,coverage,'` ; \
- perl $(srcdir)/scripts/coverage-report-entry.pl $$i > $$o.html ; done
# disable this check
distuninstallcheck: