summaryrefslogtreecommitdiff
path: root/GNUmakefile
diff options
context:
space:
mode:
authorLaurent Léonard <laurent@open-minds.org>2010-04-13 02:17:59 +0200
committerLaurent Léonard <laurent@open-minds.org>2010-04-13 02:17:59 +0200
commit01e95348403c03d119888a76c9d51d70399a3d99 (patch)
tree0227f42fea4bbeb3ada469a3962504afb2324080 /GNUmakefile
parentf944460b569c4499da0e0090b9130356d7517d88 (diff)
Imported Upstream version 0.8.0
Diffstat (limited to 'GNUmakefile')
-rw-r--r--GNUmakefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/GNUmakefile b/GNUmakefile
index 40ccc061d..daba47ae2 100644
--- a/GNUmakefile
+++ b/GNUmakefile
@@ -49,7 +49,7 @@ include $(srcdir)/maint.mk
# Allow cfg.mk to override these.
_build-aux ?= build-aux
-_autoreconf ?= autoreconf
+_autoreconf ?= autoreconf -v
# Ensure that $(VERSION) is up to date for dist-related targets, but not
# for others: rerunning autoreconf and recompiling everything isn't cheap.
@@ -78,7 +78,8 @@ ifeq ($(_have-git-version-gen)0,yes$(MAKELEVEL))
$(info run '$(MAKE) _version' to fix it)
else
$(info INFO: running autoreconf for new version string: $(_curr-ver))
- _dummy := $(shell $(MAKE) $(AM_MAKEFLAGS) _version)
+GNUmakefile: _version
+ touch GNUmakefile
endif
endif
endif
@@ -88,6 +89,7 @@ endif
.PHONY: _version
_version:
cd $(srcdir) && rm -rf autom4te.cache .version && $(_autoreconf)
+ $(MAKE) $(AM_MAKEFLAGS) Makefile
else