summaryrefslogtreecommitdiff
path: root/ChangeLog
diff options
context:
space:
mode:
authorGuido Günther <agx@sigxcpu.org>2016-04-01 15:37:12 +0200
committerGuido Günther <agx@sigxcpu.org>2016-04-01 15:37:12 +0200
commitaec93e0ec1a86d01aab1407dae3d54abddc08d2c (patch)
tree4e9afb2db2641eba061f3751448428a396c2cc3c /ChangeLog
parent51c7ba3a0e307f31745254cb8c134a90519d9eb3 (diff)
New upstream version 1.3.3~rc2
Diffstat (limited to 'ChangeLog')
-rw-r--r--ChangeLog187
1 files changed, 187 insertions, 0 deletions
diff --git a/ChangeLog b/ChangeLog
index d975ee8a3..c132498b0 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,190 @@
+2016-04-01 Jim Fehlig <jfehlig@suse.com>
+
+ libxl: fix net device detach
+ Chunyan sent a nice cleanup patch for libxlDomainDetachNetDevice
+
+ https://www.redhat.com/archives/libvir-list/2016-March/msg00926.html
+
+ which I incorrectly modified before pushing as commit b5534e53. My
+ modification caused network devices of type hostdev to no longer
+ be removed. This patch changes b5534e53 to resemble Chunyan's
+ original, correct patch.
+
+2016-04-01 Jim Fehlig <jfehlig@suse.com>
+
+ libxl: fix attaching net device of type hostdev
+ Chunyan sent a correct patch to fix a resource leak on error in
+ libxlDomainAttachNetDevice
+
+ https://www.redhat.com/archives/libvir-list/2016-March/msg00924.html
+
+ I made what was thought to be an improvement and pushed the patch as
+ commit e6336442. As it turns out, my change broke adding net devices
+ that are actually hostdevs to the list of nets in virDomainDef. This
+ patch changes e6336442 to resemble Chunyan's original, correct
+ patch.
+
+2016-03-31 Fabiano Fidêncio <fidencio@redhat.com>
+
+ build: workaround broken SASL header (again)
+ Compilation for xdg-app failed due to a buggy SASL headers present on
+ the used runtime (org.gnome.Sdk 3.18).
+
+ In file included from rpc/virnetsaslcontext.h:24:0,
+ from rpc/virnetsaslcontext.c:25:
+ /usr/include/sasl/sasl.h:230:38: error: unknown type name 'size_t'
+ typedef void *sasl_realloc_t(void *, size_t);
+ ^
+ /usr/include/sasl/sasl.h:235:5: error: unknown type name 'sasl_realloc_t'
+ sasl_realloc_t *,
+
+ Use the same workaround as commit 1be3dfd did.
+
+2016-03-31 Michal Privoznik <mprivozn@redhat.com>
+
+ qemuProcessVerifyGuestCPU: Avoid coverity false positive
+ We use _LAST items in enums to mark the last position in given
+ enum. Now, if and enum is passed to switch(), compiler checks
+ that all the values from enum occur in 'case' enumeration.
+ Including _LAST. But coverity spots it's a dead code. And it
+ really is. So to resolve this, we tend to put a comment just
+ above 'case ..._LAST' notifying coverity that we know this is a
+ dead code but we want to have it that way.
+
+ virPerfReadEvent: Prefer saferead over read
+ Do I really need to explain why?
+ Well, if read() is interrupted int the middle of reading, we will
+ never read the rest (even though it's highly unlikely as we are
+ reading just 8 bytes).
+
+2016-03-31 Andrea Bolognani <abologna@redhat.com>
+
+ docs: Make most headers a bit smaller
+ Headers are bold already, so the font doesn't need to be that
+ big to draw attention.
+
+ docs: Use bold text for all headers
+ All headers except for <h1> were already bold: make it bold as
+ well to increase visual consistency.
+
+ docs: Don't use bold text for menu entries
+ The menu should not take the focus away from the actual contents.
+
+ docs: Make menu entries smaller
+ The menu should not take the focus away from the actual contents.
+
+ docs: Don't use <strong> in headers
+ There's only one instance of that happening, and it looks
+ kinda off. Get rid of it, along with the corresponding
+ CSS rules.
+
+ docs: Remove empty CSS rule
+
+ docs: Adjust vertical whitespace in CSS
+ Ensure all CSS rules are separated with a single blank line.
+
+2016-03-31 Martin Kletzander <mkletzan@redhat.com>
+
+ remote: Add flags to remote_protocol-structs
+ Caused by 3b6c8185328f.
+
+2016-03-31 Michal Privoznik <mprivozn@redhat.com>
+
+ virDomain{Get,Set}PerfEvents: Grab job
+ Even though we have the machine locked throughout whole APIs we
+ are querying/modifying domain internal state. We should grab a
+ job whilst doing that.
+
+ virDomain{Get,Set}PerfEvents: support --config --live --current
+ Now that we have @flags we can support changing perf events just
+ in active or inactive configuration regardless of the other.
+ Previously, calling virDomainSetPerfEvents set events in both
+ active and inactive configuration at once. Even though we allow
+ users to set perf events that are to be enabled once domain is
+ started up. The virDomainGetPerfEvents API was flawed too. It
+ returned just runtime info.
+
+ virsh: Make perf accept event list separated by commas
+ Everywhere else we use a comma separated list. There's no good
+ reason to make 'perf' command an exception. Currently, it accepts
+ string list separated by '|'.
+
+ virsh: Prefer VIRSH_COMMON_OPT_DOMAIN_FULL over full enumeration
+ We have a macro that does exactly what is done via full
+ enumeration.
+
+ virDomain{Get,Set}PerfEvents: Add @flags argument
+ I've noticed that these APIs are missing @flags argument. Even
+ though we don't have a use for them, it's our policy that every
+ new API must have @flags.
+
+ remoteDomainGetPerfEvents: Re-indent
+ There are few lines off the indentation.
+
+2016-03-30 Peter Krempa <pkrempa@redhat.com>
+
+ qemu: command: Split up formatting of -numa and memory devices
+ They recently were extracted to a separate function. They don't belong
+ together though. Since -numa formatting is pretty compact, move it to
+ the main function and rename qemuBuildNumaCommandLine to
+ qemuBuildMemoryDeviceCommandLine.
+
+2016-03-30 Peter Krempa <pkrempa@redhat.com>
+
+ qemu: command: Pass numad nodeset when formatting memory devices at boot
+ When starting up a VM libvirtd asks numad to place the VM in case of
+ automatic nodeset. The nodeset would not be passed to the memory device
+ formatter and the user would get an error.
+
+ Resolves: https://bugzilla.redhat.com/show_bug.cgi?id=1269715
+
+2016-03-30 Pavel Hrdina <phrdina@redhat.com>
+
+ qemu_process: add check for hyperv features
+ Commit 7068b56c introduced several hyperv features. Not all hyperv
+ features are supported by old enough kernels and we shouldn't allow to
+ start a guest if kernel doesn't support any of the hyperv feature.
+
+ There is one exception, for backward compatibility we cannot error out
+ if one of the RELAXED, VAPIC or SPINLOCKS isn't supported, for the same
+ reason we ignore invtsc, to not break restoring saved domains with older
+ libvirt.
+
+2016-03-30 Pavel Hrdina <phrdina@redhat.com>
+
+ qemu_process: skip only cpu features
+ This check is there to allow restore saved domain with older libvirt
+ where we included invtsc by default for host-passthrough model. Don't
+ skip the whole function, but only the part that checks for invtsc.
+
+ docs: fix qemu version for hyperv features
+
+2016-03-30 Andrea Bolognani <abologna@redhat.com>
+
+ host-validate: Fix suggestion for missing cpu cgroup
+ If the cpu cgroup is not found when validating an host for
+ LXC support, virt-host-validate will suggest to enable the
+ CONFIG_CGROUP_SCHED kconfig option.
+
+ The appropriate option is really CONFIG_CGROUP_CPU. The
+ QEMU checks already get that right, so no changes needed.
+
+2016-03-30 Roman Bogorodskiy <bogorodskiy@gmail.com>
+
+ nss: FreeBSD support
+ * tools/nss/libvirt_nss.[ch]: add BSD-comptabile wrappers and
+ register via the nss_module_register() interface
+ * m4/virt-nss.m4: add checks if we're building NSS for FreeBSD
+ * tools/Makefile.am: handle target library name differences, as
+ Linux needs libnss_libvirt.so.2 and FreeBSD needs
+ nss_libvirt.so.1. Also, different syms files have to be used
+ as Linux needs to export all the methods while FreeBSD
+ only needs to have nss_module_register()
+ * tests/nsstest.c, tests/nssmock.c: s/__linux__/NSS/
+ * tests/nssmock.c: pass int instead of mode_t to va_arg() to please
+ gcc 4.8
+ * libvirt_nss_bsd.syms: FreeBSD syms file
+
2016-03-30 Jim Fehlig <jfehlig@suse.com>
libxl: only disable domain death events in libxlDomainCleanup