aboutsummaryrefslogtreecommitdiff
path: root/bigtop-packages/src
diff options
context:
space:
mode:
authorRoman Shaposhnik <rvs@cloudera.com>2013-04-03 09:30:55 -0700
committerRoman Shaposhnik <rvs@cloudera.com>2013-04-21 20:15:12 -0700
commit7b2f77dd253a5f70545b35dbfb224791bf51b1f2 (patch)
tree03b685856e3768000ba4943ab80b64eacb785cde /bigtop-packages/src
parent860dff60b8768eb3a04992d47cdf666db55b3a54 (diff)
BIGTOP-832. Bump version of Hue to 2.3.0
Diffstat (limited to 'bigtop-packages/src')
-rw-r--r--bigtop-packages/src/common/hue/do-component-build2
-rw-r--r--bigtop-packages/src/common/hue/install_hue.sh6
-rw-r--r--bigtop-packages/src/deb/hue/control18
-rw-r--r--bigtop-packages/src/deb/hue/hue-app.prerm.tpl2
-rw-r--r--bigtop-packages/src/deb/hue/hue-pig.install1
-rwxr-xr-xbigtop-packages/src/deb/hue/rules5
-rw-r--r--bigtop-packages/src/rpm/hue/SPECS/hue.spec42
7 files changed, 39 insertions, 37 deletions
diff --git a/bigtop-packages/src/common/hue/do-component-build b/bigtop-packages/src/common/hue/do-component-build
index c4b3cb28..eafb4e2b 100644
--- a/bigtop-packages/src/common/hue/do-component-build
+++ b/bigtop-packages/src/common/hue/do-component-build
@@ -16,8 +16,6 @@
set -ex
-mvn -f maven/pom.xml clean install "$@"
-
make apps
# Make the entire tree relocatable
diff --git a/bigtop-packages/src/common/hue/install_hue.sh b/bigtop-packages/src/common/hue/install_hue.sh
index b1ff0655..a3e327d1 100644
--- a/bigtop-packages/src/common/hue/install_hue.sh
+++ b/bigtop-packages/src/common/hue/install_hue.sh
@@ -136,12 +136,6 @@ sed -i -e '/\[\[database\]\]/a\
name=/var/lib/hue/desktop.db' $PREFIX/${CONF_DIR}/conf.empty/hue.ini
sed -i -e '/\[\[yarn_clusters\]\]/,+20s@## submit_to=False@submit_to=True@' \
$PREFIX/${CONF_DIR}/conf.empty/hue.ini
-# Fix a redirection, since by default beeswax is not installed
-sed -i -e '/meta http-equiv="refresh"/s#/beeswax#/about#' \
- $PREFIX/$LIB_DIR/desktop/core/src/desktop/templates/index.mako
-# FIXME: HUE-1097
-sed -i -e '/impala.conf/d' \
- $PREFIX/$LIB_DIR/apps/beeswax/src/beeswax/server/dbms.py
# Relink logs subdirectory just in case
install -d -m 0755 $PREFIX/$LOG_DIR
diff --git a/bigtop-packages/src/deb/hue/control b/bigtop-packages/src/deb/hue/control
index a30f05a1..582ee816 100644
--- a/bigtop-packages/src/deb/hue/control
+++ b/bigtop-packages/src/deb/hue/control
@@ -29,17 +29,9 @@ Description: A browser-based desktop interface for Hadoop
Hue is a browser-based desktop interface for interacting with Hadoop.
It supports a file browser, job tracker interface, cluster health monitor, and more.
-# FIXME: Hue plugins don't yet quite work with Hadoop 2.X
-#Package: hue-plugins
-#Architecture: all
-#Depends: hadoop, bigtop-utils (>= 0.6)
-#Description: Plug-ins for Hadoop to enable integration with Hue
-# These plug-ins enable the Hadoop Daemons to communicate with Hue.
-# This package must be installed on every node in the Hadoop cluster.
-
Package: hue
Architecture: all
-Depends: hue-common (= ${source:Version}), hue-server (= ${source:Version}), hue-beeswax (= ${source:Version}), hue-oozie (= ${source:Version})
+Depends: hue-common (= ${source:Version}), hue-server (= ${source:Version}), hue-beeswax (= ${source:Version}), hue-oozie (= ${source:Version}), hue-pig (= ${source:Version})
Description: The hue metapackage
Hue is a browser-based desktop interface for interacting with Hadoop.
It supports a file browser, job tracker interface, cluster health monitor, and more.
@@ -67,3 +59,11 @@ Description: A UI for Oozie on Hue
.
It allows users to construct and run Oozie workflows without explicitly managing the XML specification.
+Package: hue-pig
+Architecture: all
+Depends: ${shlibs:Depends}, ${misc:Depends}, python (>= 2.4), python (<< 3), make (>= 3.8), hue-common (= ${source:Version})
+Description: A UI for Pig on Hue
+ A web interface for Pig.
+ .
+ It allows users to construct and run Pig jobs.
+
diff --git a/bigtop-packages/src/deb/hue/hue-app.prerm.tpl b/bigtop-packages/src/deb/hue/hue-app.prerm.tpl
index 4b96c040..a61c8389 100644
--- a/bigtop-packages/src/deb/hue/hue-app.prerm.tpl
+++ b/bigtop-packages/src/deb/hue/hue-app.prerm.tpl
@@ -43,7 +43,7 @@ case "$1" in
fi
find $APP_DIR -name \*.py[co] -exec rm -f {} \; ||:
find $APP_DIR -name \*.egg-info -prune -exec rm -Rf {} \; ||:
- chown -R hue:hue /var/log/hue /var/lib/hue
+ chown -R hue:hue /var/log/hue /var/lib/hue || :
;;
failed-upgrade)
diff --git a/bigtop-packages/src/deb/hue/hue-pig.install b/bigtop-packages/src/deb/hue/hue-pig.install
new file mode 100644
index 00000000..7ec7a317
--- /dev/null
+++ b/bigtop-packages/src/deb/hue/hue-pig.install
@@ -0,0 +1 @@
+/usr/lib/hue/apps/pig
diff --git a/bigtop-packages/src/deb/hue/rules b/bigtop-packages/src/deb/hue/rules
index f15b80f3..a4fbd4c7 100755
--- a/bigtop-packages/src/deb/hue/rules
+++ b/bigtop-packages/src/deb/hue/rules
@@ -23,7 +23,7 @@
# Implicit targets
SHELL := /bin/bash
-APPS=beeswax oozie
+APPS=beeswax oozie pig
$(APPS:%=debian/hue-%.postinst): debian/hue-app.postinst.tpl
sed -e 's#@APP@#$(patsubst debian/hue-%.postinst,%,$@)#' < $< > $@
@@ -44,3 +44,6 @@ override_dh_auto_install: build $(APPS:%=debian/hue-%.postinst) $(APPS:%=debian/
override_dh_installinit:
dh_installinit --name=hue
+
+override_dh_auto_test:
+ @echo Tests are disabled
diff --git a/bigtop-packages/src/rpm/hue/SPECS/hue.spec b/bigtop-packages/src/rpm/hue/SPECS/hue.spec
index 783544be..355f910a 100644
--- a/bigtop-packages/src/rpm/hue/SPECS/hue.spec
+++ b/bigtop-packages/src/rpm/hue/SPECS/hue.spec
@@ -31,6 +31,7 @@ Requires: %{name}-common = %{version}-%{release}
Requires: %{name}-server = %{version}-%{release}
Requires: %{name}-beeswax = %{version}-%{release}
Requires: %{name}-oozie = %{version}-%{release}
+Requires: %{name}-pig = %{version}-%{release}
################ RPM CUSTOMIZATION ##############################
# Disable automatic Provides generation - otherwise we will claim to provide all of the
@@ -76,6 +77,8 @@ AutoReqProv: no
%define about_app_dir %{hue_dir}/apps/about
%define beeswax_app_dir %{hue_dir}/apps/beeswax
%define oozie_app_dir %{hue_dir}/apps/oozie
+%define pig_app_dir %{hue_dir}/apps/pig
+%define catalog_app_dir %{hue_dir}/apps/catalog
%define filebrowser_app_dir %{hue_dir}/apps/filebrowser
%define help_app_dir %{hue_dir}/apps/help
%define jobbrowser_app_dir %{hue_dir}/apps/jobbrowser
@@ -116,7 +119,7 @@ if [ "$1" = 0 ] ; then \
find %{apps_dir}/%1 -name \*.egg-info -type f -print0 | xargs -0 /bin/rm -fR \
fi \
find %{apps_dir}/%1 -iname \*.py[co] -type f -print0 | xargs -0 /bin/rm -f \
-chown -R hue:hue /var/log/hue /var/lib/hue
+chown -R hue:hue /var/log/hue /var/lib/hue || :
%description
Hue is a browser-based desktop interface for interacting with Hadoop.
@@ -260,6 +263,7 @@ fi
%{proxy_app_dir}
%{useradmin_app_dir}
%{shell_app_dir}
+%{catalog_app_dir}
%attr(4750,root,hue) %{shell_app_dir}/src/shell/build/setuid
%attr(0755,%{username},%{username}) /var/log/hue
%attr(0755,%{username},%{username}) /var/lib/hue
@@ -267,8 +271,7 @@ fi
# beeswax, oozie are packaged as a plugin app
%exclude %{beeswax_app_dir}
%exclude %{oozie_app_dir}
-
-# %exclude %{hadoop_lib}
+%exclude %{pig_app_dir}
############################################################
# No-arch packages - plugins and conf
@@ -307,21 +310,6 @@ if [ $1 -ge 1 ]; then
service %{name} condrestart >/dev/null 2>&1
fi
-#### PLUGINS ######
-# FIXME: Hue plugins don't quite work with Hadoop 2.X
-# %package -n %{name}-plugins
-# Summary: Hadoop plugins for Hue
-# Requires: hadoop, bigtop-utils >= 0.6
-# Group: Applications/Engineering
-# %description -n %{name}-plugins
-# Plugins for Hue
-#
-# This package should be installed on each node in the Hadoop cluster.
-#
-# %files -n %{name}-plugins
-# %{hadoop_lib}/
-
-
#### HUE-BEESWAX PLUGIN ######
%package -n %{name}-beeswax
Summary: A UI for Hive on Hue
@@ -359,3 +347,21 @@ managing the XML specification.
%files -n %{name}-oozie
%{oozie_app_dir}
+
+#### HUE-PIG PLUGIN ######
+%package -n %{name}-pig
+Summary: A UI for Pig on Hue
+Group: Applications/Engineering
+Requires: make
+Requires: %{name}-common = %{version}-%{release}
+
+%description -n %{name}-pig
+A web interface for Pig.
+
+It allows users to construct and run Pig jobs.
+
+%app_post_macro pig
+%app_preun_macro pig
+
+%files -n %{name}-pig
+%{pig_app_dir}