aboutsummaryrefslogtreecommitdiff
path: root/bigtop-packages/src
diff options
context:
space:
mode:
authorRoman Shaposhnik <rvs@cloudera.com>2013-09-18 16:30:37 -0700
committerRoman Shaposhnik <rvs@cloudera.com>2013-09-18 16:30:37 -0700
commit127921e5807fd1cbd0ed347968d0b529b37e379c (patch)
treea10755a21c4f0715c4f0fcf68b23d9e7f8de6649 /bigtop-packages/src
parentaba85e0765d5db91a74dbdf3d61ebc6141fe5777 (diff)
BIGTOP-1074. Bump version of Hue to 2.5.0
Diffstat (limited to 'bigtop-packages/src')
-rw-r--r--bigtop-packages/src/common/hue/do-component-build5
-rw-r--r--bigtop-packages/src/common/hue/install_hue.sh4
-rw-r--r--bigtop-packages/src/deb/hue/control24
-rw-r--r--bigtop-packages/src/deb/hue/docs2
-rw-r--r--bigtop-packages/src/deb/hue/hue-common.install2
-rw-r--r--bigtop-packages/src/deb/hue/hue-hbase.install1
-rw-r--r--bigtop-packages/src/deb/hue/hue-search.install1
-rw-r--r--bigtop-packages/src/deb/hue/hue-sqoop.install1
-rwxr-xr-xbigtop-packages/src/deb/hue/rules2
-rw-r--r--bigtop-packages/src/rpm/hue/SPECS/hue.spec70
10 files changed, 102 insertions, 10 deletions
diff --git a/bigtop-packages/src/common/hue/do-component-build b/bigtop-packages/src/common/hue/do-component-build
index 9edc99a8..e4cdeca3 100644
--- a/bigtop-packages/src/common/hue/do-component-build
+++ b/bigtop-packages/src/common/hue/do-component-build
@@ -16,7 +16,10 @@
set -ex
-make apps
+#FIXME: this needs to be fixed upstream
+sed -i -e 's#2.5.0-SNAPSHOT#'${HUE_VERSION}'#g' `grep -lR 2.5.0-SNAPSHOT .`
+
+make MAVEN_VERSION='$(DESKTOP_VERSION)' apps
# Make the entire tree relocatable
bash tools/relocatable.sh
diff --git a/bigtop-packages/src/common/hue/install_hue.sh b/bigtop-packages/src/common/hue/install_hue.sh
index 4ae0b5f0..7ae70160 100644
--- a/bigtop-packages/src/common/hue/install_hue.sh
+++ b/bigtop-packages/src/common/hue/install_hue.sh
@@ -99,7 +99,7 @@ HADOOP_DIR=${HADOOP_DIR:-/usr/lib/hadoop/lib}
BUNDLED_BUILD_DIR=$PREFIX/$LIB_DIR/build
# Install all the files
-(cd $BUILD_DIR ; PREFIX=`dirname $PREFIX/$LIB_DIR` make install)
+(cd $BUILD_DIR ; PREFIX=`dirname $PREFIX/$LIB_DIR` MAVEN_OPTIONS="-Dmaven.repo.local=${PWD}/.m2/repository" make install MAVEN_VERSION='$(DESKTOP_VERSION)')
# Install plugins
install -d -m 0755 $PREFIX/$HADOOP_DIR
@@ -129,7 +129,7 @@ mv $PREFIX/$LIB_DIR/desktop/desktop.db $PREFIX/$VAR_DIR
# Install conf files
install -d -m 0755 $PREFIX/$CONF_DIR
-mv -f $PREFIX/$LIB_DIR/desktop/conf $PREFIX/${CONF_DIR}/conf.empty
+cp -r ${BUILD_DIR}/desktop/conf.dist $PREFIX/${CONF_DIR}/conf.empty
ln -fs $CONF_DIR/conf $PREFIX/$LIB_DIR/desktop/conf
sed -i -e '/\[\[database\]\]/a\
engine=sqlite3\
diff --git a/bigtop-packages/src/deb/hue/control b/bigtop-packages/src/deb/hue/control
index c1cfaeb2..20edf6a4 100644
--- a/bigtop-packages/src/deb/hue/control
+++ b/bigtop-packages/src/deb/hue/control
@@ -31,7 +31,7 @@ Description: A browser-based desktop interface for Hadoop
Package: hue
Architecture: all
-Depends: hue-common (= ${source:Version}), hue-server (= ${source:Version}), hue-beeswax (= ${source:Version}), hue-pig (= ${source:Version})
+Depends: hue-common (= ${source:Version}), hue-server (= ${source:Version}), hue-beeswax (= ${source:Version}), hue-pig (= ${source:Version}), hue-hbase (= ${source:Version}), hue-search (= ${source:Version}), hue-sqoop (= ${source:Version})
Description: The hue metapackage
Hue is a browser-based desktop interface for interacting with Hadoop.
It supports a file browser, job tracker interface, cluster health monitor, and more.
@@ -59,3 +59,25 @@ Description: A UI for Pig on Hue
.
It allows users to construct and run Pig jobs.
+Package: hue-hbase
+Architecture: all
+Depends: ${shlibs:Depends}, ${misc:Depends}, python (>= 2.4), python (<< 3), make (>= 3.8), hue-common (= ${source:Version})
+Description: A UI for HBase on Hue
+ A web interface for HBase.
+ .
+ It allows users to run HBase queries
+
+Package: hue-sqoop
+Architecture: all
+Depends: ${shlibs:Depends}, ${misc:Depends}, python (>= 2.4), python (<< 3), make (>= 3.8), hue-common (= ${source:Version})
+Description: A UI for Sqoop on Hue
+ A web interface to Sqoop.
+
+Package: hue-search
+Architecture: all
+Depends: ${shlibs:Depends}, ${misc:Depends}, python (>= 2.4), python (<< 3), make (>= 3.8), hue-common (= ${source:Version})
+Description: A UI for Search on Hue
+ A web interface to Search.
+ .
+ It allows users to interact with Solr
+
diff --git a/bigtop-packages/src/deb/hue/docs b/bigtop-packages/src/deb/hue/docs
index e845566c..a1320b1b 100644
--- a/bigtop-packages/src/deb/hue/docs
+++ b/bigtop-packages/src/deb/hue/docs
@@ -1 +1 @@
-README
+README.rst
diff --git a/bigtop-packages/src/deb/hue/hue-common.install b/bigtop-packages/src/deb/hue/hue-common.install
index 43cc567a..6e645e3a 100644
--- a/bigtop-packages/src/deb/hue/hue-common.install
+++ b/bigtop-packages/src/deb/hue/hue-common.install
@@ -8,7 +8,7 @@
/usr/lib/hue/Makefile.sdk
/usr/lib/hue/Makefile.vars
/usr/lib/hue/Makefile.vars.priv
-/usr/lib/hue/README
+/usr/lib/hue/README.rst
/usr/lib/hue/tools
/usr/lib/hue/VERSION
/usr/lib/hue/build/env/bin/*
diff --git a/bigtop-packages/src/deb/hue/hue-hbase.install b/bigtop-packages/src/deb/hue/hue-hbase.install
new file mode 100644
index 00000000..a95b4a1c
--- /dev/null
+++ b/bigtop-packages/src/deb/hue/hue-hbase.install
@@ -0,0 +1 @@
+/usr/lib/hue/apps/hbase
diff --git a/bigtop-packages/src/deb/hue/hue-search.install b/bigtop-packages/src/deb/hue/hue-search.install
new file mode 100644
index 00000000..28ca6d06
--- /dev/null
+++ b/bigtop-packages/src/deb/hue/hue-search.install
@@ -0,0 +1 @@
+/usr/lib/hue/apps/search
diff --git a/bigtop-packages/src/deb/hue/hue-sqoop.install b/bigtop-packages/src/deb/hue/hue-sqoop.install
new file mode 100644
index 00000000..54beea8b
--- /dev/null
+++ b/bigtop-packages/src/deb/hue/hue-sqoop.install
@@ -0,0 +1 @@
+/usr/lib/hue/apps/sqoop
diff --git a/bigtop-packages/src/deb/hue/rules b/bigtop-packages/src/deb/hue/rules
index c96d421f..5c959ab4 100755
--- a/bigtop-packages/src/deb/hue/rules
+++ b/bigtop-packages/src/deb/hue/rules
@@ -23,7 +23,7 @@
# Implicit targets
SHELL := /bin/bash
-APPS=beeswax pig
+APPS=beeswax pig hbase sqoop search
$(APPS:%=debian/hue-%.postinst): debian/hue-app.postinst.tpl
sed -e 's#@APP@#$(patsubst debian/hue-%.postinst,%,$@)#' < $< > $@
diff --git a/bigtop-packages/src/rpm/hue/SPECS/hue.spec b/bigtop-packages/src/rpm/hue/SPECS/hue.spec
index cc2aeef0..58288fb4 100644
--- a/bigtop-packages/src/rpm/hue/SPECS/hue.spec
+++ b/bigtop-packages/src/rpm/hue/SPECS/hue.spec
@@ -31,6 +31,10 @@ Requires: %{name}-common = %{version}-%{release}
Requires: %{name}-server = %{version}-%{release}
Requires: %{name}-beeswax = %{version}-%{release}
Requires: %{name}-pig = %{version}-%{release}
+Requires: %{name}-hbase = %{version}-%{release}
+Requires: %{name}-sqoop = %{version}-%{release}
+Requires: %{name}-search = %{version}-%{release}
+
################ RPM CUSTOMIZATION ##############################
# Disable automatic Provides generation - otherwise we will claim to provide all of the
@@ -77,7 +81,7 @@ AutoReqProv: no
%define beeswax_app_dir %{hue_dir}/apps/beeswax
%define oozie_app_dir %{hue_dir}/apps/oozie
%define pig_app_dir %{hue_dir}/apps/pig
-%define catalog_app_dir %{hue_dir}/apps/catalog
+%define metastore_app_dir %{hue_dir}/apps/metastore
%define filebrowser_app_dir %{hue_dir}/apps/filebrowser
%define help_app_dir %{hue_dir}/apps/help
%define jobbrowser_app_dir %{hue_dir}/apps/jobbrowser
@@ -86,6 +90,10 @@ AutoReqProv: no
%define shell_app_dir %{hue_dir}/apps/shell
%define useradmin_app_dir %{hue_dir}/apps/useradmin
%define etc_hue /etc/hue/conf
+%define hbase_app_dir %{hue_dir}/apps/hbase
+%define sqoop_app_dir %{hue_dir}/apps/sqoop
+%define search_app_dir %{hue_dir}/apps/search
+
# Path to the HADOOP_HOME to build against - these
# are not substituted into the build products anywhere!
@@ -243,7 +251,7 @@ fi
%{hue_dir}/Makefile.sdk
%{hue_dir}/Makefile.vars
%{hue_dir}/Makefile.vars.priv
-%{hue_dir}/README
+%{hue_dir}/README.rst
%{hue_dir}/tools
%{hue_dir}/VERSION
%{hue_dir}/build/env/bin/*
@@ -262,7 +270,7 @@ fi
%{proxy_app_dir}
%{useradmin_app_dir}
%{shell_app_dir}
-%{catalog_app_dir}
+%{metastore_app_dir}
%{oozie_app_dir}
%attr(4750,root,hue) %{shell_app_dir}/src/shell/build/setuid
%attr(0755,%{username},%{username}) /var/log/hue
@@ -271,6 +279,10 @@ fi
# beeswax and pig are packaged as a plugin app
%exclude %{beeswax_app_dir}
%exclude %{pig_app_dir}
+%exclude %{hbase_app_dir}
+%exclude %{sqoop_app_dir}
+%exclude %{search_app_dir}
+
############################################################
# No-arch packages - plugins and conf
@@ -345,3 +357,55 @@ It allows users to construct and run Pig jobs.
%files -n %{name}-pig
%{pig_app_dir}
+
+#### HUE-HBASE PLUGIN ######
+%package -n %{name}-hbase
+Summary: A UI for HBase on Hue
+Group: Applications/Engineering
+Requires: %{name}-common = %{version}-%{release}
+
+%description -n %{name}-hbase
+A web interface for HBase.
+
+It allows users to construct and run HBase queries.
+
+%app_post_macro hbase
+%app_preun_macro hbase
+
+%files -n %{name}-hbase
+%defattr(-, %{username}, %{username})
+%{hbase_app_dir}
+
+#### HUE-SQOOP PLUGIN ######
+%package -n %{name}-sqoop
+Summary: A UI for Sqoop on Hue
+Group: Applications/Engineering
+Requires: %{name}-common = %{version}-%{release}
+
+%description -n %{name}-sqoop
+A web interface for Sqoop.
+
+%app_post_macro sqoop
+%app_preun_macro sqoop
+
+%files -n %{name}-sqoop
+%defattr(-, %{username}, %{username})
+%{sqoop_app_dir}
+
+#### HUE-SEARCH PLUGIN ######
+%package -n %{name}-search
+Summary: A UI for Search on Hue
+Group: Applications/Engineering
+Requires: %{name}-common = %{version}-%{release}
+
+%description -n %{name}-search
+A web interface for Search.
+
+It allows users to interact with Solr
+
+%app_post_macro search
+%app_preun_macro search
+
+%files -n %{name}-search
+%defattr(-, %{username}, %{username})
+%{search_app_dir}