aboutsummaryrefslogtreecommitdiff
path: root/bigtop-packages/src/deb/hue
diff options
context:
space:
mode:
authorRoman Shaposhnik <rvs@cloudera.com>2013-09-18 16:30:37 -0700
committerRoman Shaposhnik <rvs@cloudera.com>2013-09-18 16:30:37 -0700
commit127921e5807fd1cbd0ed347968d0b529b37e379c (patch)
treea10755a21c4f0715c4f0fcf68b23d9e7f8de6649 /bigtop-packages/src/deb/hue
parentaba85e0765d5db91a74dbdf3d61ebc6141fe5777 (diff)
BIGTOP-1074. Bump version of Hue to 2.5.0
Diffstat (limited to 'bigtop-packages/src/deb/hue')
-rw-r--r--bigtop-packages/src/deb/hue/control24
-rw-r--r--bigtop-packages/src/deb/hue/docs2
-rw-r--r--bigtop-packages/src/deb/hue/hue-common.install2
-rw-r--r--bigtop-packages/src/deb/hue/hue-hbase.install1
-rw-r--r--bigtop-packages/src/deb/hue/hue-search.install1
-rw-r--r--bigtop-packages/src/deb/hue/hue-sqoop.install1
-rwxr-xr-xbigtop-packages/src/deb/hue/rules2
7 files changed, 29 insertions, 4 deletions
diff --git a/bigtop-packages/src/deb/hue/control b/bigtop-packages/src/deb/hue/control
index c1cfaeb2..20edf6a4 100644
--- a/bigtop-packages/src/deb/hue/control
+++ b/bigtop-packages/src/deb/hue/control
@@ -31,7 +31,7 @@ Description: A browser-based desktop interface for Hadoop
Package: hue
Architecture: all
-Depends: hue-common (= ${source:Version}), hue-server (= ${source:Version}), hue-beeswax (= ${source:Version}), hue-pig (= ${source:Version})
+Depends: hue-common (= ${source:Version}), hue-server (= ${source:Version}), hue-beeswax (= ${source:Version}), hue-pig (= ${source:Version}), hue-hbase (= ${source:Version}), hue-search (= ${source:Version}), hue-sqoop (= ${source:Version})
Description: The hue metapackage
Hue is a browser-based desktop interface for interacting with Hadoop.
It supports a file browser, job tracker interface, cluster health monitor, and more.
@@ -59,3 +59,25 @@ Description: A UI for Pig on Hue
.
It allows users to construct and run Pig jobs.
+Package: hue-hbase
+Architecture: all
+Depends: ${shlibs:Depends}, ${misc:Depends}, python (>= 2.4), python (<< 3), make (>= 3.8), hue-common (= ${source:Version})
+Description: A UI for HBase on Hue
+ A web interface for HBase.
+ .
+ It allows users to run HBase queries
+
+Package: hue-sqoop
+Architecture: all
+Depends: ${shlibs:Depends}, ${misc:Depends}, python (>= 2.4), python (<< 3), make (>= 3.8), hue-common (= ${source:Version})
+Description: A UI for Sqoop on Hue
+ A web interface to Sqoop.
+
+Package: hue-search
+Architecture: all
+Depends: ${shlibs:Depends}, ${misc:Depends}, python (>= 2.4), python (<< 3), make (>= 3.8), hue-common (= ${source:Version})
+Description: A UI for Search on Hue
+ A web interface to Search.
+ .
+ It allows users to interact with Solr
+
diff --git a/bigtop-packages/src/deb/hue/docs b/bigtop-packages/src/deb/hue/docs
index e845566c..a1320b1b 100644
--- a/bigtop-packages/src/deb/hue/docs
+++ b/bigtop-packages/src/deb/hue/docs
@@ -1 +1 @@
-README
+README.rst
diff --git a/bigtop-packages/src/deb/hue/hue-common.install b/bigtop-packages/src/deb/hue/hue-common.install
index 43cc567a..6e645e3a 100644
--- a/bigtop-packages/src/deb/hue/hue-common.install
+++ b/bigtop-packages/src/deb/hue/hue-common.install
@@ -8,7 +8,7 @@
/usr/lib/hue/Makefile.sdk
/usr/lib/hue/Makefile.vars
/usr/lib/hue/Makefile.vars.priv
-/usr/lib/hue/README
+/usr/lib/hue/README.rst
/usr/lib/hue/tools
/usr/lib/hue/VERSION
/usr/lib/hue/build/env/bin/*
diff --git a/bigtop-packages/src/deb/hue/hue-hbase.install b/bigtop-packages/src/deb/hue/hue-hbase.install
new file mode 100644
index 00000000..a95b4a1c
--- /dev/null
+++ b/bigtop-packages/src/deb/hue/hue-hbase.install
@@ -0,0 +1 @@
+/usr/lib/hue/apps/hbase
diff --git a/bigtop-packages/src/deb/hue/hue-search.install b/bigtop-packages/src/deb/hue/hue-search.install
new file mode 100644
index 00000000..28ca6d06
--- /dev/null
+++ b/bigtop-packages/src/deb/hue/hue-search.install
@@ -0,0 +1 @@
+/usr/lib/hue/apps/search
diff --git a/bigtop-packages/src/deb/hue/hue-sqoop.install b/bigtop-packages/src/deb/hue/hue-sqoop.install
new file mode 100644
index 00000000..54beea8b
--- /dev/null
+++ b/bigtop-packages/src/deb/hue/hue-sqoop.install
@@ -0,0 +1 @@
+/usr/lib/hue/apps/sqoop
diff --git a/bigtop-packages/src/deb/hue/rules b/bigtop-packages/src/deb/hue/rules
index c96d421f..5c959ab4 100755
--- a/bigtop-packages/src/deb/hue/rules
+++ b/bigtop-packages/src/deb/hue/rules
@@ -23,7 +23,7 @@
# Implicit targets
SHELL := /bin/bash
-APPS=beeswax pig
+APPS=beeswax pig hbase sqoop search
$(APPS:%=debian/hue-%.postinst): debian/hue-app.postinst.tpl
sed -e 's#@APP@#$(patsubst debian/hue-%.postinst,%,$@)#' < $< > $@