summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules9
1 files changed, 6 insertions, 3 deletions
diff --git a/debian/rules b/debian/rules
index c3c9111..ca0b931 100755
--- a/debian/rules
+++ b/debian/rules
@@ -2,7 +2,7 @@
SHELL := sh -e
VERSION := $(shell dpkg-parsechangelog -SVersion)
-UPSTREAM_SOURCE = RB3_firmware
+UPSTREAM_SOURCE = RB5_firmware
DIR_ORIG = $(UPSTREAM_SOURCE)_$(VERSION)
ZIP_ORIG = $(UPSTREAM_SOURCE)_$(VERSION).zip
@@ -14,13 +14,16 @@ override_dh_auto_build:
mkdir -p bdf
cp ./$(DIR_ORIG)/38-bdwlan_split/bdwlan*.* bdf
bash ./debian/ath10k_helpers/generate_board-2_json.sh bdf board-2.json
- python2 ./debian/ath10k_helpers/ath10k-bdencoder -c board-2.json -o board-2.bin
+ python3 ./debian/ath10k_helpers/ath10k-bdencoder -m ath11k -c board-2.json -o board-2.bin
- cp ./$(DIR_ORIG)/17-USB3-201-202-FW/K2026090.mem ./$(DIR_ORIG)/renesas_usb_fw.mem
+ cp ./$(DIR_ORIG)/18-adreno-fw/a650_zap.elf a650_zap.mbn
override_dh_auto_clean:
+ if [ -d $(DIR_ORIG) ] ; then chmod u+w $(DIR_ORIG) -R ; fi
rm -rf $(DIR_ORIG)
+ rm -rf bdf board-2.bin board-2.json
rm -f debian/copyright
+ rm -f a650_zap.mbn
%:
dh $@