aboutsummaryrefslogtreecommitdiff
path: root/tests/examples
diff options
context:
space:
mode:
Diffstat (limited to 'tests/examples')
-rw-r--r--tests/examples/controller/Makefile.am2
-rw-r--r--tests/examples/controller/Makefile.in2
-rw-r--r--tests/examples/helloworld/helloworld.c4
-rw-r--r--tests/examples/manual/fakesrc.c8
4 files changed, 8 insertions, 8 deletions
diff --git a/tests/examples/controller/Makefile.am b/tests/examples/controller/Makefile.am
index 4eded37..06d39ed 100644
--- a/tests/examples/controller/Makefile.am
+++ b/tests/examples/controller/Makefile.am
@@ -12,7 +12,7 @@ Android.mk: Makefile.am audio-example.c
-:TAGS eng debug \
-:REL_TOP $(top_srcdir) -:ABS_TOP $(abs_top_srcdir) \
-:SOURCES audio-example.c \
- -:CFLAGS $(DEFS) $(DEFAULT_INCLUDES) $(audio_example_CFLAGS) \
+ -:CFLAGS $(DEFS) $(DEFAULT_INCLUDES) $(AM_CFLAGS) \
-:LDFLAGS -lgstcontroller-@GST_API_VERSION@ \
$(GST_OBJ_LIBS) -ldl \
-:PASSTHROUGH LOCAL_ARM_MODE:=arm \
diff --git a/tests/examples/controller/Makefile.in b/tests/examples/controller/Makefile.in
index 2e9cc06..26737fa 100644
--- a/tests/examples/controller/Makefile.in
+++ b/tests/examples/controller/Makefile.in
@@ -733,7 +733,7 @@ Android.mk: Makefile.am audio-example.c
-:TAGS eng debug \
-:REL_TOP $(top_srcdir) -:ABS_TOP $(abs_top_srcdir) \
-:SOURCES audio-example.c \
- -:CFLAGS $(DEFS) $(DEFAULT_INCLUDES) $(audio_example_CFLAGS) \
+ -:CFLAGS $(DEFS) $(DEFAULT_INCLUDES) $(AM_CFLAGS) \
-:LDFLAGS -lgstcontroller-@GST_API_VERSION@ \
$(GST_OBJ_LIBS) -ldl \
-:PASSTHROUGH LOCAL_ARM_MODE:=arm \
diff --git a/tests/examples/helloworld/helloworld.c b/tests/examples/helloworld/helloworld.c
index 013ae4d..2d8ae3f 100644
--- a/tests/examples/helloworld/helloworld.c
+++ b/tests/examples/helloworld/helloworld.c
@@ -38,6 +38,7 @@ main (gint argc, gchar * argv[])
GstElement *playbin;
GMainLoop *loop;
GstBus *bus;
+ guint bus_watch_id;
gchar *uri;
gst_init (&argc, &argv);
@@ -65,7 +66,7 @@ main (gint argc, gchar * argv[])
loop = g_main_loop_new (NULL, FALSE);
bus = gst_element_get_bus (playbin);
- gst_bus_add_watch (bus, bus_call, loop);
+ bus_watch_id = gst_bus_add_watch (bus, bus_call, loop);
g_object_unref (bus);
/* start play back and listed to events */
@@ -75,6 +76,7 @@ main (gint argc, gchar * argv[])
/* cleanup */
gst_element_set_state (playbin, GST_STATE_NULL);
g_object_unref (playbin);
+ g_source_remove (bus_watch_id);
g_main_loop_unref (loop);
return 0;
diff --git a/tests/examples/manual/fakesrc.c b/tests/examples/manual/fakesrc.c
index 58a8458..af26255 100644
--- a/tests/examples/manual/fakesrc.c
+++ b/tests/examples/manual/fakesrc.c
@@ -36,18 +36,16 @@ main (gint argc,
pipeline = gst_pipeline_new ("pipeline");
fakesrc = gst_element_factory_make ("fakesrc", "source");
flt = gst_element_factory_make ("capsfilter", "flt");
- conv = gst_element_factory_make ("ffmpegcolorspace", "conv");
+ conv = gst_element_factory_make ("videoconvert", "conv");
videosink = gst_element_factory_make ("xvimagesink", "videosink");
/* setup */
g_object_set (G_OBJECT (flt), "caps",
- gst_caps_new_simple ("video/x-raw-rgb",
+ gst_caps_new_simple ("video/x-raw",
+ "format", G_TYPE_STRING, "RGB16",
"width", G_TYPE_INT, 384,
"height", G_TYPE_INT, 288,
"framerate", GST_TYPE_FRACTION, 1, 1,
- "bpp", G_TYPE_INT, 16,
- "depth", G_TYPE_INT, 16,
- "endianness", G_TYPE_INT, G_BYTE_ORDER,
NULL), NULL);
gst_bin_add_many (GST_BIN (pipeline), fakesrc, flt, conv, videosink, NULL);
gst_element_link_many (fakesrc, flt, conv, videosink, NULL);