aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 7 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index b11ee4c..591d79d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,16 +1,16 @@
-AC_PREREQ(2.60)
+AC_PREREQ(2.62)
dnl initialize autoconf
dnl when going to/from release please set the nano (fourth number) right !
dnl releases only do Wall, cvs and prerelease does Werror too
-AC_INIT(GStreamer libav, 0.11.90,
+AC_INIT(GStreamer libav, 0.11.91,
http://bugzilla.gnome.org/enter_bug.cgi?product=GStreamer,
gst-libav)
AG_GST_INIT
dnl initialize automake
-AM_INIT_AUTOMAKE([-Wno-portability 1.10])
+AM_INIT_AUTOMAKE([-Wno-portability 1.11 no-dist-gzip dist-xz tar-ustar])
dnl define PACKAGE_VERSION_* variables
AS_VERSION
@@ -25,7 +25,7 @@ dnl define the output header for config
AM_CONFIG_HEADER([config.h])
dnl AM_MAINTAINER_MODE only provides the option to configure to enable it
-AM_MAINTAINER_MODE
+AM_MAINTAINER_MODE([enable])
dnl sets host_* variables
AC_CANONICAL_HOST
@@ -42,12 +42,10 @@ GST_API_VERSION=1.0
AC_SUBST(GST_API_VERSION)
AG_GST_LIBTOOL_PREPARE
-
-AC_LIBTOOL_WIN32_DLL
-AM_PROG_LIBTOOL
+AS_LIBTOOL(GST, 0, 0, 0)
dnl *** required versions of GStreamer stuff ***
-GST_REQ=0.11.3
+GST_REQ=0.11.90
ORC_REQ=0.4.6
dnl *** autotools stuff ****
@@ -96,7 +94,7 @@ AG_GST_PLUGIN_DOCS([1.3],[2.1])
dnl *** checks for libraries ***
dnl check for libm, for sin()
-AC_CHECK_LIBM
+LT_LIB_M
AC_SUBST(LIBM)
dnl *** checks for header files ***