aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Dechesne <nicolas.dechesne@linaro.org>2014-05-12 15:26:21 +0000
committerNicolas Dechesne <nicolas.dechesne@linaro.org>2014-10-03 15:08:16 +0000
commit415900e0694656b529e5f13698c22571bc67605d (patch)
tree60d769c8e9f621b8a0355faa24d4d8049e2ab1d6
parentf64cbde1f7f14fcb10b2c6e04ea6a2e3dd30b13c (diff)
debian: add UCM config file for HDMI on IFC6410debian/1.0.28-1_linaro1
Signed-off-by: Nicolas Dechesne <nicolas.dechesne@linaro.org>
-rw-r--r--debian/changelog6
-rw-r--r--debian/patches/0006-Add-UCM-config-for-IFC6410-HDMI.patch97
-rw-r--r--debian/patches/series1
3 files changed, 104 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 95dfae25..1710ac6b 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+alsa-lib (1.0.28-1~linaro1) utopic; urgency=medium
+
+ * Add HDMI UCM profile for IFC6410
+
+ -- Nicolas Dechesne <nicolas.dechesne@linaro.org> Fri, 03 Oct 2014 15:07:22 +0000
+
alsa-lib (1.0.28-1) unstable; urgency=medium
[ Luke Yelavich ]
diff --git a/debian/patches/0006-Add-UCM-config-for-IFC6410-HDMI.patch b/debian/patches/0006-Add-UCM-config-for-IFC6410-HDMI.patch
new file mode 100644
index 00000000..9f7572d6
--- /dev/null
+++ b/debian/patches/0006-Add-UCM-config-for-IFC6410-HDMI.patch
@@ -0,0 +1,97 @@
+Index: alsa-lib/src/conf/ucm/apq8064-tabla-snd-card/apq8064-tabla-snd-card.conf
+===================================================================
+--- alsa-lib.orig/src/conf/ucm/apq8064-tabla-snd-card/apq8064-tabla-snd-card.conf 2014-05-12 13:59:55.075662516 +0000
++++ alsa-lib/src/conf/ucm/apq8064-tabla-snd-card/apq8064-tabla-snd-card.conf 2014-05-12 13:59:55.055641152 +0000
+@@ -6,3 +6,7 @@
+ File "VoiceCall"
+ Comment "Make a phone call"
+ }
++SectionUseCase."HDMI" {
++ File "HDMI"
++ Comment "HDMI output."
++}
+Index: alsa-lib/src/conf/ucm/apq8064-tabla-snd-card/HDMI
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ alsa-lib/src/conf/ucm/apq8064-tabla-snd-card/HDMI 2014-05-12 13:59:55.065651834 +0000
+@@ -0,0 +1,70 @@
++SectionVerb {
++ EnableSequence [
++ cdev "hw:apq8064tablasnd"
++
++ cset "name='HDMI Mixer MultiMedia1' 1"
++ # disable other paths.. probably should be disabled at
++ # boot by kernel, but that doesn't seem to be happening.
++ # which means there are probably other things we should
++ # disable too..
++ cset "name='SLIMBUS_0_RX Audio Mixer MultiMedia1' 0"
++ cset "name='MultiMedia1 Mixer SLIM_0_TX' 0"
++ ]
++
++ DisableSequence [
++ cdev "hw:apq8064tablasnd"
++
++ cset "name='HDMI Mixer MultiMedia1' 0"
++ ]
++
++ Value {
++ TQ "HiFi"
++ CapturePCM "hw:apq8064tablasnd,0"
++ PlaybackPCM "hw:apq8064tablasnd,0"
++ }
++}
++
++SectionDevice."HDMI-stereo" {
++ #Name "HDMI-stereo"
++ Comment "HDMI Digital Stereo Output"
++
++ EnableSequence [
++ cdev "hw:apq8064tablasnd"
++
++ # We need to disable this while setting up the route, else the
++ # driver will hang if the stream is open.
++ cset "name='HDMI Mixer MultiMedia1' 0"
++
++# cset "name='SLIM_0_RX Channels' One"
++# cset "name='RX1 MIX1 INP1' RX1"
++# cset "name='RX1 MIX1 INP2' RX1"
++# cset "name='RX1 Digital Volume' 68"
++# cset "name='EAR PA Gain' POS_6_DB"
++# cset "name='DAC1 Switch' 1"
++# cset "name='SLIM TX3 MUX' RMIX1"
++
++ # Route has been set up, re-enable the mixer.
++ cset "name='HDMI Mixer MultiMedia1' 1"
++ ]
++
++ DisableSequence [
++ cdev "hw:apq8064tablasnd"
++
++ # See comment in EnableSequence
++ cset "name='HDMI Mixer MultiMedia1' 0"
++
++# cset "name='RX1 MIX1 INP1' ZERO"
++# cset "name='RX1 MIX1 INP2' ZERO"
++# cset "name='RX1 Digital Volume' 68"
++# cset "name='DAC1 Switch' 0"
++# cset "name='SLIM TX3 MUX' ZERO"
++
++ # See comment in EnableSequence
++ cset "name='HDMI Mixer MultiMedia1' 1"
++ ]
++
++ Value {
++ PlaybackChannels "2"
++ }
++}
++
+Index: alsa-lib/src/conf/ucm/apq8064-tabla-snd-card/Makefile.am
+===================================================================
+--- alsa-lib.orig/src/conf/ucm/apq8064-tabla-snd-card/Makefile.am 2014-05-12 13:59:54.465010907 +0000
++++ alsa-lib/src/conf/ucm/apq8064-tabla-snd-card/Makefile.am 2014-05-12 14:00:12.494249431 +0000
+@@ -1,4 +1,4 @@
+ alsaconfigdir = @ALSA_CONFIG_DIR@
+ ucmdir = $(alsaconfigdir)/ucm/apq8064-tabla-snd-card
+-ucm_DATA = apq8064-tabla-snd-card.conf HiFi VoiceCall
++ucm_DATA = apq8064-tabla-snd-card.conf HiFi VoiceCall HDMI
+ EXTRA_DIST = $(ucm_DATA)
diff --git a/debian/patches/series b/debian/patches/series
index b61cfe58..ab7033f0 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -5,3 +5,4 @@ add-tegra-alc5632.patch
0003-Add-UCM-files-for-Nexus-7.patch
0004-Add-UCM-config-files-for-Nexus-10.patch
0005-Add-UCM-config-files-for-Nexus-5.patch
+0006-Add-UCM-config-for-IFC6410-HDMI.patch