summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorNicolas Dechesne <nicolas.dechesne@linaro.org>2015-06-18 12:47:36 +0200
committerNicolas Dechesne <nicolas.dechesne@linaro.org>2015-06-18 16:18:12 +0200
commit212004a86b0ef527c2baa767436808d1d50cb782 (patch)
tree9efa24cfb33c842814a97ba97775cb5bac31f023 /Makefile
parentffdceab7aba959514627f43180acc2f1ab70f54c (diff)
modify how variables are processed
we want to have release specific vars.mk file. in the current implementation vars.mk is sourced in the makefile and we can't have more than one. let's split the variable processing in their own shell script, so that we can have several vars.mk files. Signed-off-by: Nicolas Dechesne <nicolas.dechesne@linaro.org>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile3
1 files changed, 1 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index ad185ab..70d11aa 100644
--- a/Makefile
+++ b/Makefile
@@ -1,7 +1,6 @@
# required so that further += assignment are immediate, not defered...
TEXTILE:=
include ubuntu/boards/snapdragon/Makefile
-include vars.mk
HTML=$(subst .textile,.html,$(TEXTILE))
@@ -19,4 +18,4 @@ clean:
%.textile: %.textile.in vars.mk Makefile
@echo "Processing $< to $@"
@cp $< $@
- @perl -p -e 's/##(\w+)##/$$ENV{$$1}/eg' < $< > $@
+ @./vars.sh ./vars.mk $< $@