aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMarcin Kuzminski <marcin@python-works.com>2012-01-28 18:07:20 +0200
committerMarcin Kuzminski <marcin@python-works.com>2012-01-28 18:07:20 +0200
commit9c49a72e1c006e649e5b9c1a48f7355f70f9bf82 (patch)
tree8b9e5e74eee49286df9e085022b78a84692c10a1 /setup.py
parentd37c2a9dab8bd7110fa6414bfca80a7f08f73c7f (diff)
fixed requires files, added distinction on win vs other platforms
--HG-- branch : beta
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py9
1 files changed, 0 insertions, 9 deletions
diff --git a/setup.py b/setup.py
index 73249885..f2e4ea05 100644
--- a/setup.py
+++ b/setup.py
@@ -1,8 +1,6 @@
import sys
from rhodecode import get_version
-from rhodecode import __platform__
from rhodecode import __license__
-from rhodecode import PLATFORM_OTHERS
from rhodecode import requirements
py_version = sys.version_info
@@ -27,13 +25,6 @@ classifiers = ['Development Status :: 4 - Beta',
'Programming Language :: Python :: 2.6',
'Programming Language :: Python :: 2.7', ]
-if py_version < (2, 6):
- requirements.append("simplejson")
- requirements.append("pysqlite")
-
-if __platform__ in PLATFORM_OTHERS:
- requirements.append("py-bcrypt")
-
# additional files from project that goes somewhere in the filesystem
# relative to sys.prefix