aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMarcin Kuzminski <marcin@python-works.com>2012-01-19 06:46:25 +0200
committerMarcin Kuzminski <marcin@python-works.com>2012-01-19 06:46:25 +0200
commit7811357db46ed5ec5b12227e5553d1dbf94a126d (patch)
tree8d0f414a2e804cf65331bdb2ac13aede02ed0be7 /setup.py
parent080a9acb71b62e7d4639f5131c74952545a2057f (diff)
fixes for release 1.2.4
- docs updates - requires.txt file - changelog
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py18
1 files changed, 1 insertions, 17 deletions
diff --git a/setup.py b/setup.py
index 17af1aba..7d0a42c0 100644
--- a/setup.py
+++ b/setup.py
@@ -3,29 +3,13 @@ from rhodecode import get_version
from rhodecode import __platform__
from rhodecode import __license__
from rhodecode import PLATFORM_OTHERS
+from rhodecode import requirements
py_version = sys.version_info
if py_version < (2, 5):
raise Exception('RhodeCode requires python 2.5 or later')
-requirements = [
- "Pylons==1.0.0",
- "Beaker==1.5.4",
- "WebHelpers>=1.2",
- "formencode==1.2.4",
- "SQLAlchemy==0.7.3",
- "Mako==0.5.0",
- "pygments>=1.4",
- "mercurial>=2.0,<2.1",
- "whoosh<1.8",
- "celery>=2.2.5,<2.3",
- "babel",
- "python-dateutil>=1.5.0,<2.0.0",
- "dulwich>=0.8.0,<0.9.0",
- "vcs==0.2.2",
- "webob==1.0.8"
- ]
dependency_links = [
]