aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMarcin Kuzminski <marcin@python-works.com>2010-10-09 16:05:14 +0200
committerMarcin Kuzminski <marcin@python-works.com>2010-10-09 16:05:14 +0200
commit960c762665ca20bce29b8e1703e4794736d1b7a1 (patch)
tree4380da7625a24e1e88f116c55bf0524764c82cef /setup.py
parentf17a5cab4bb1f1b6844386d8bc65ab9e7bca006b (diff)
refactor codes and setup for python 2.5
readme update
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py6
1 files changed, 5 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index afe0ef53..99c5eb19 100644
--- a/setup.py
+++ b/setup.py
@@ -1,5 +1,6 @@
from rhodecode import get_version
import sys
+py_version = sys.version_info
requirements = [
"Pylons>=1.0.0",
@@ -9,12 +10,15 @@ requirements = [
"vcs>=0.1.7",
"pygments>=1.3.0",
"mercurial>=1.6",
- "pysqlite",
"whoosh==1.0.0",
"py-bcrypt",
"celery",
]
+if sys.version_info < (2, 6):
+ requirements.append("simplejson")
+ requirements.append("pysqlite")
+
#additional files from project that goes somewhere in the filesystem
#relative to sys.prefix
data_files = []