aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMarcin Kuzminski <marcin@python-works.com>2010-10-09 17:53:15 +0200
committerMarcin Kuzminski <marcin@python-works.com>2010-10-09 17:53:15 +0200
commit78e3b59a77367b895a2e0c7850a2cd1974001ce7 (patch)
treeacb75176ef7b75d8bfccf516810984304c3f853f /setup.py
parent960c762665ca20bce29b8e1703e4794736d1b7a1 (diff)
small fix for setup
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py11
1 files changed, 6 insertions, 5 deletions
diff --git a/setup.py b/setup.py
index 99c5eb19..6adc5628 100644
--- a/setup.py
+++ b/setup.py
@@ -5,14 +5,14 @@ py_version = sys.version_info
requirements = [
"Pylons>=1.0.0",
"SQLAlchemy>=0.6",
- "babel",
"Mako>=0.3.2",
- "vcs>=0.1.7",
+ "vcs>=0.1.8",
"pygments>=1.3.0",
"mercurial>=1.6",
"whoosh==1.0.0",
+ "celery>=2.0.0",
"py-bcrypt",
- "celery",
+ "babel",
]
if sys.version_info < (2, 6):
@@ -26,6 +26,7 @@ data_files = []
#additional files that goes into package itself
package_data = {'rhodecode': ['i18n/*/LC_MESSAGES/*.mo', ], }
+description = 'Mercurial repository serving and browsing app'
#long description
try:
readme_file = 'README.rst'
@@ -33,7 +34,7 @@ try:
except IOError, err:
sys.stderr.write("[ERROR] Cannot find file specified as "
"long_description (%s)\n" % readme_file)
- sys.exit(1)
+ long_description = description
try:
@@ -48,7 +49,7 @@ packages = find_packages(exclude=['ez_setup'])
setup(
name='RhodeCode',
version=get_version(),
- description='Mercurial repository serving and browsing app',
+ description=description,
long_description=long_description,
keywords='mercurial web hgwebdir replacement serving hgweb rhodecode',
license='BSD',