summaryrefslogtreecommitdiff
path: root/debian/qemu-user-static.postinst.in
diff options
context:
space:
mode:
Diffstat (limited to 'debian/qemu-user-static.postinst.in')
-rw-r--r--debian/qemu-user-static.postinst.in11
1 files changed, 11 insertions, 0 deletions
diff --git a/debian/qemu-user-static.postinst.in b/debian/qemu-user-static.postinst.in
new file mode 100644
index 0000000..86fb450
--- /dev/null
+++ b/debian/qemu-user-static.postinst.in
@@ -0,0 +1,11 @@
+#!/bin/sh -e
+
+BINFMT_TARGETS= # list of architectures is autogenerated from debian/rules
+
+if [ configure = "$1" ] && [ -x /usr/sbin/update-binfmts ]; then
+ for target in $BINFMT_TARGETS ; do
+ update-binfmts --import qemu-$target
+ done
+fi
+
+#DEBHELPER#