aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorJames Westby <james.westby@canonical.com>2010-09-24 16:37:48 -0400
committerJames Westby <james.westby@canonical.com>2010-09-24 16:37:48 -0400
commitc4f045c85e4eb724ed5e297693f2c9319c9c95e2 (patch)
tree7e2b8f7e5c1f72d0fc2646d05a0b451ae07b68da /debian
parent4d5b1211a33f581f46f3098cf317780ea4a26f1d (diff)
Package the hardware pack tools.
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog3
-rw-r--r--debian/control17
-rw-r--r--debian/linaro-image-tools.install2
-rw-r--r--debian/python-hwpack.install1
-rwxr-xr-xdebian/rules4
5 files changed, 22 insertions, 5 deletions
diff --git a/debian/changelog b/debian/changelog
index bb783d3..1dde6cf 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -11,8 +11,7 @@ linaro-image-tools (0.3) UNRELEASED; urgency=low
itself can run as non-root as intended.
[ James Westby ]
- * Add a linaro-hwpack-creation script for the creation of hardware packs.
- Not yet installed in the binary packages.
+ * Add a linaro-hwpack-create script for the creation of hardware packs.
-- Steve Langasek <steve.langasek@ubuntu.com> Tue, 14 Sep 2010 17:01:49 -0700
diff --git a/debian/control b/debian/control
index 324218a..79661f9 100644
--- a/debian/control
+++ b/debian/control
@@ -1,10 +1,11 @@
Source: linaro-image-tools
Section: devel
Priority: optional
-Build-Depends: debhelper (>= 7)
+Build-Depends: debhelper (>= 7.0.50~), python-all, python-apt, python-testtools
Standards-Version: 3.9.1
Maintainer: Linaro Developers <linaro-dev@lists.linaro.org>
Vcs-Bzr:
+XS-Python-Version: >=2.5
Package: linaro-image-tools
Architecture: all
@@ -13,10 +14,22 @@ Depends: ${misc:Depends},
uuid-runtime,
wget,
uboot-mkimage,
- realpath
+ realpath,
+ python,
+ python-hwpack
Description: collection of tools to work with Linaro images
This package offers a set of tools for use with Linaro images.
.
The provided linaro-media-create command allows writing Linaro images
to a SD card, or generating an image file which you can boot in QEMU.
+Package: python-hwpack
+Architecture: all
+Section: python
+Depends: ${python:Depends}, python-apt, ${misc:Depends}
+Description: python library for the creation of hardware packs
+ Hardware packs allow for the distribution of packages to be combined with
+ an image to create a root filesystem at a later date.
+ .
+ This package provides a python library to aid with the creation of hardware
+ packs.
diff --git a/debian/linaro-image-tools.install b/debian/linaro-image-tools.install
index 94ac399..8eaed4b 100644
--- a/debian/linaro-image-tools.install
+++ b/debian/linaro-image-tools.install
@@ -1 +1,3 @@
linaro-media-create usr/bin
+linaro-hwpack-install usr/bin
+linaro-hwpack-create usr/bin
diff --git a/debian/python-hwpack.install b/debian/python-hwpack.install
new file mode 100644
index 0000000..84bd86c
--- /dev/null
+++ b/debian/python-hwpack.install
@@ -0,0 +1 @@
+usr/lib/python*/dist-packages/hwpack
diff --git a/debian/rules b/debian/rules
index 8ca6034..61d75fe 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,5 +1,7 @@
#!/usr/bin/make -f
%:
- dh $*
+ dh --buildsystem=python_distutils --with-addon=python-support $*
+override_dh_auto_test:
+ python -m testtools.run hwpack.tests.test_suite