aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorLoïc Minier <lool@dooz.org>2011-01-05 11:31:41 +0100
committerLoïc Minier <lool@dooz.org>2011-01-05 11:31:41 +0100
commit9878bf5b2e74c729e3d29be565d46150262b1e52 (patch)
tree0676d038c3a8e169f7ac028744eff788ac01095e /debian
parent1ad58431ab3ff51cd3aa916870b592a37e4a33e0 (diff)
parent373f0c91bc51c7fce61069e70a41fd948a02edf2 (diff)
Merge lp:~salgado/linaro-image-tools/package-media-create; adds a
python-media-create package.
Diffstat (limited to 'debian')
-rw-r--r--debian/control11
-rw-r--r--debian/python-linaro-media-create.install1
-rwxr-xr-xdebian/rules4
3 files changed, 15 insertions, 1 deletions
diff --git a/debian/control b/debian/control
index aa0e448..9472431 100644
--- a/debian/control
+++ b/debian/control
@@ -45,3 +45,14 @@ Description: Python library for the creation of hardware packs
.
This package provides a Python library to aid with the creation of hardware
packs.
+
+Package: python-linaro-media-create
+Architecture: all
+Section: python
+Depends: ${python:Depends}, python-apt, ${misc:Depends}
+Description: python library for the creation of Linaro bootable media
+ Linaro images are generated by combining generic tarballs with
+ hardware-specific packs (hwpacks).
+ .
+ This package provides a python library to generate Linaro images and write
+ them to SD cards or image files that you can be boot in QEMU.
diff --git a/debian/python-linaro-media-create.install b/debian/python-linaro-media-create.install
new file mode 100644
index 0000000..24ac52d
--- /dev/null
+++ b/debian/python-linaro-media-create.install
@@ -0,0 +1 @@
+usr/lib/python*/dist-packages/media_create
diff --git a/debian/rules b/debian/rules
index c1bf2c9..ab9d151 100755
--- a/debian/rules
+++ b/debian/rules
@@ -4,4 +4,6 @@
dh --buildsystem=python_distutils --with-addon=python2 $*
override_dh_auto_test:
- python -m testtools.run hwpack.tests.test_suite
+ # XXX: The test-suite currently fails on Lucid. What can we do about
+ # it?
+ python -m testtools.run tests.test_suite