summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorJohn Rigby <john.rigby@linaro.org>2010-12-16 14:44:23 -0700
committerJohn Rigby <john.rigby@linaro.org>2010-12-16 14:44:23 -0700
commitaa2d8fd7ba1d3b208d6445845ecedece648d290a (patch)
treef79bf237e19a272db794b9d38599b8e5b79ebf02 /debian/rules
parent5f1164649c2ea4f88f37dfce3b43b3585b7ecbdc (diff)
LINARO: use default compiler again
With new upstrean no longer need to force gcc 4.4 Also change CROSS_COMPILE setting in rules to allow setting it in environment. Signed-off-by: John Rigby <john.rigby@linaro.org>
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules7
1 files changed, 2 insertions, 5 deletions
diff --git a/debian/rules b/debian/rules
index 712f03536..96fe90307 100755
--- a/debian/rules
+++ b/debian/rules
@@ -10,12 +10,9 @@ DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
ifneq ($(DEB_BUILD_GNU_TYPE),$(DEB_HOST_GNU_TYPE))
-export CROSS_COMPILE=$(DEB_HOST_GNU_TYPE)-
+export CROSS_COMPILE?=$(DEB_HOST_GNU_TYPE)-
endif
-# u-boot breaks with gcc-4.5
-CC = $(CROSS_COMPILE)gcc-4.4
-
%:
dh $@
@@ -31,7 +28,7 @@ override_dh_auto_build:
mkdir -p debian/build/$$plat; \
$(MAKE) O=$$PWD/debian/build/$$plat $${plat}_config; \
find debian/build; \
- $(MAKE) O=$$PWD/debian/build/$$plat CC="$(CC)"; \
+ $(MAKE) O=$$PWD/debian/build/$$plat; \
done <debian/platform-and-targets
override_dh_auto_install: