summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorJohn Rigby <john.rigby@linaro.org>2010-08-05 22:55:11 -0600
committerJohn Rigby <john.rigby@linaro.org>2010-09-14 18:27:10 -0600
commita3a31b137f9f2ff7a4b4a88d5132397b1a03f27a (patch)
treec33f2fe3c08095a1d761a6d9a6e309802029ad8c /debian/rules
parenta225a6747917d2074b9d8a387a2153f2146d75f4 (diff)
LINARO: Initial Linaro U-Boot tree
Initial Linaro u-boot tree based on Upstream v2010.06-265-gcdb7497 A series of patches from ssakomans exp branch that add support for beagle C4 and xM. These have been rebased onto current upstream. The gitorious beagle trees are still based on v2010.03. These patches will be replaced with patches from ssakoman. Two versatile express patches from Matt Waddel. Debian packaging by John Rigby based on the lucid u-boot-omap3 package. Currently builds u-boot binaries for these platforms: ca9x4_ct_vxp aka Versatile Express mx51evk aka Babbage omap4_panda omap3_beagle Signed-off-by: John Rigby <john.rigby@linaro.org>
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules45
1 files changed, 45 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 000000000..5b61ff6de
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,45 @@
+#!/usr/bin/make -f
+
+# the upstream build passes LDFLAGS directly to ld instead of calling gcc for
+# linking; so instead of passing -Wl,foo in LDFLAGS as in automake builds, one
+# should set LDFLAGS to foo directly
+comma := ,
+LDFLAGS := $(patsubst -Wl$(comma)%,%,$(LDFLAGS))
+
+DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
+DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
+
+ifneq ($(DEB_BUILD_GNU_TYPE),$(DEB_HOST_GNU_TYPE))
+export CROSS_COMPILE=$(DEB_HOST_GNU_TYPE)-
+endif
+#export DH_VERBOSE=1
+#export DH_OPTIONS=-v
+
+PLATFORMS= \
+ ca9x4_ct_vxp \
+ mx51evk \
+ omap3_beagle \
+ omap4_panda
+
+%:
+ dh --with quilt $@
+
+override_dh_auto_configure:
+ @
+
+override_dh_auto_clean:
+ $(MAKE) distclean
+ rm -rf debian/build
+
+override_dh_auto_build:
+ for plat in $(PLATFORMS); do \
+ $(MAKE) O=debian/build/$$plat mrproper; \
+ $(MAKE) O=debian/build/$$plat $${plat}_config; \
+ $(MAKE) O=debian/build/$$plat; \
+# mkdir -p debian/build/$$plat; touch debian/build/$$plat/u-boot.bin; \
+ done
+
+override_dh_auto_install:
+ for plat in $(PLATFORMS); do \
+ install -D -m644 debian/build/$$plat/u-boot.bin debian/tmp/usr/lib/u-boot/u-boot-$$plat.bin; \
+ done