summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorLoïc Minier <loic.minier@linaro.org>2010-12-15 14:29:41 -0700
committerJohn Rigby <john.rigby@linaro.org>2010-12-15 14:29:54 -0700
commit7a517bf2d8538de55730fec9d3f95a4d88c37d69 (patch)
treef6e54cecd0bbc7a04bbaf46af11668ff5f577aae /debian/rules
parent32c3a7ec2dc260c611ef6882bc312d2d7a274238 (diff)
LINARO: Packaging: cleanup and add new Overo target
Signed-off-by: John Rigby <john.rigby@linaro.org> Singed-off-by: Loïc Minier <loic.minier@linaro.org>
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules26
1 files changed, 7 insertions, 19 deletions
diff --git a/debian/rules b/debian/rules
index b3b5d7d01..be9f57293 100755
--- a/debian/rules
+++ b/debian/rules
@@ -12,39 +12,27 @@ DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
ifneq ($(DEB_BUILD_GNU_TYPE),$(DEB_HOST_GNU_TYPE))
export CROSS_COMPILE=$(DEB_HOST_GNU_TYPE)-
endif
-#export DH_VERBOSE=1
-#export DH_OPTIONS=-v
-
-PLATFORMS_AND_TARGETS= \
- ca9x4_ct_vxp u-boot.bin ca9x4-ct-vxp\
- mx51evk u-boot.imx mx51evk\
- omap3_beagle u-boot.bin omap3-beagle\
- omap4_panda u-boot.bin omap4-panda
%:
dh $@
-override_dh_auto_configure:
- @
-
override_dh_auto_clean:
- $(MAKE) distclean
+ # upstream only cleans these files if passing the right O=, but it
+ # shouldn't create these the source tree in the first place
+ # XXX this hardcodes "arm"
+ rm -f arch/arm/include/asm/arch arch/arm/include/asm/proc
rm -rf debian/build
-# the u-boot.imx target does not work with O= and make mrproper
-# removes all *.bin files in the tree so we use rsync to make
-# a copy of the tree for each platform
override_dh_auto_build:
- echo $(PLATFORMS_AND_TARGETS)| xargs -n 3 | \
while read plat target deb; do \
mkdir -p debian/build/$$plat; \
$(MAKE) O=$$PWD/debian/build/$$plat $${plat}_config; \
find debian/build; \
$(MAKE) O=$$PWD/debian/build/$$plat; \
- done
+ done <debian/platform-and-targets
override_dh_auto_install:
- echo $(PLATFORMS_AND_TARGETS) | xargs -n 3 | \
while read plat target deb; do \
install -D -m644 debian/build/$$plat/$$target debian/u-boot-linaro-$$deb/usr/lib/u-boot/$$plat/$$target; \
- done
+ done <debian/platform-and-targets
+